summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-11-19 11:06:21 +0000
committerHans de Graaff <graaff@gentoo.org>2011-11-19 11:06:21 +0000
commitede8beff0e876802a07fb9bb6b03f31eb3f1f1be (patch)
tree2763fbe68f4c2ed82aa5cf77234c51bd43fee5ac /dev-ruby/activerecord
parentVersion bump for Rails 3.0.11. (diff)
downloadgentoo-2-ede8beff0e876802a07fb9bb6b03f31eb3f1f1be.tar.gz
gentoo-2-ede8beff0e876802a07fb9bb6b03f31eb3f1f1be.tar.bz2
gentoo-2-ede8beff0e876802a07fb9bb6b03f31eb3f1f1be.zip
Version bump for Rails 3.0.11.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/ChangeLog7
-rw-r--r--dev-ruby/activerecord/activerecord-3.0.11.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index 7fb8c44d6519..3859c384780e 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.173 2011/10/05 17:55:57 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.174 2011/11/19 11:06:21 graaff Exp $
+
+*activerecord-3.0.11 (19 Nov 2011)
+
+ 19 Nov 2011; Hans de Graaff <graaff@gentoo.org> +activerecord-3.0.11.ebuild:
+ Version bump for Rails 3.0.11.
05 Oct 2011; Hans de Graaff <graaff@gentoo.org> -activerecord-3.0.7.ebuild,
-activerecord-3.0.9.ebuild:
diff --git a/dev-ruby/activerecord/activerecord-3.0.11.ebuild b/dev-ruby/activerecord/activerecord-3.0.11.ebuild
new file mode 100644
index 000000000000..7d10f2d64aba
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-3.0.11.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.0.11.ebuild,v 1.1 2011/11/19 11:06:21 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3"
+
+RUBY_S="rails-rails-*/activerecord"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}
+ >=dev-ruby/arel-2.0.10-r1:2.0
+ >=dev-ruby/tzinfo-0.3.23
+ sqlite3? ( >=dev-ruby/sqlite3-ruby-1.3.3 )
+ mysql? ( dev-ruby/mysql2:0.2 )
+ postgres? ( dev-ruby/pg )"
+
+ruby_add_bdepend "
+ test? (
+ ~dev-ruby/actionpack-${PV}
+ >=dev-ruby/sqlite3-ruby-1.3.3
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+ ;;
+ esac
+}