summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2012-11-26 06:21:02 +0000
committerIan Delaney <idella4@gentoo.org>2012-11-26 06:21:02 +0000
commit30e6c22c64092fc83dab9665b701fb99ba5ae347 (patch)
tree0be9c04c539c0696a5421c17b5cdbc2fd242ff06 /dev-python
parentRemove old. (diff)
downloadgentoo-2-30e6c22c64092fc83dab9665b701fb99ba5ae347.tar.gz
gentoo-2-30e6c22c64092fc83dab9665b701fb99ba5ae347.tar.bz2
gentoo-2-30e6c22c64092fc83dab9665b701fb99ba5ae347.zip
Appended missing hunk to -ft-refcount.patch, reported by, and thanks to, Carl Michal in Bug #442298
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/matplotlib/ChangeLog7
-rw-r--r--dev-python/matplotlib/files/matplotlib-1.1.1-ft-refcount.patch17
-rw-r--r--dev-python/matplotlib/matplotlib-1.1.1.ebuild18
3 files changed, 32 insertions, 10 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
index e94b6288f060..15c6839d769e 100644
--- a/dev-python/matplotlib/ChangeLog
+++ b/dev-python/matplotlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/matplotlib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.126 2012/11/06 10:58:40 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.127 2012/11/26 06:21:01 idella4 Exp $
+
+ 26 Nov 2012; Ian Delaney <idella4@gentoo.org>
+ files/matplotlib-1.1.1-ft-refcount.patch, matplotlib-1.1.1.ebuild:
+ Appended missing hunk to -ft-refcount.patch, reported by, and thanks to, Carl
+ Michal in Bug #442298
06 Nov 2012; Agostino Sarubbo <ago@gentoo.org> matplotlib-1.1.1.ebuild:
Stable for amd64, wrt bug #441278
diff --git a/dev-python/matplotlib/files/matplotlib-1.1.1-ft-refcount.patch b/dev-python/matplotlib/files/matplotlib-1.1.1-ft-refcount.patch
index 810037777621..df135c201c3d 100644
--- a/dev-python/matplotlib/files/matplotlib-1.1.1-ft-refcount.patch
+++ b/dev-python/matplotlib/files/matplotlib-1.1.1-ft-refcount.patch
@@ -1,5 +1,10 @@
-Restoring a fix to an old reference counting bug which was re-included in a recent commit. It fails stix_fonts_demo.py
-https://github.com/matplotlib/matplotlib/commit/85af0c02bf9a8ecdd0fd18eab8c9662c6b9f4302#src/ft2font.cpp
+#Restoring a fix to an old reference counting bug which was re-included in a recent commit. It fails stix_fonts_demo.py
+# https://github.com/matplotlib/matplotlib/commit/85af0c02bf9a8ecdd0fd18eab8c9662c6b9f4302#src/ft2font.cpp (Keep just in case)
+
+Reinstate the manual reference counting as discovered in #1054
+commit ca678a49f37411b1b0e72d7d0dfa88c124b0e34b
+wrt Bug #442298 by Carl Michal, "the patch in the tree is missing the fifth insertion', i.e. the 2nd. hunk
+appending the 2nd hunk to bicatelli's prepared patch
bicatali@gentoo.org 08/2012
--- src/ft2font.cpp.orig 2012-08-01 17:30:33.000000000 +0100
@@ -33,3 +38,11 @@ bicatali@gentoo.org 08/2012
throw Py::RuntimeError(s.str());
}
+@@ -904,6 +908,7 @@ inline double conv(int v)
+ {
+ std::ostringstream s;
+ s << "Could not set the fontsize for facefile " << facefile << std::endl;
++ ob_refcnt--;
+ throw Py::RuntimeError(s.str());
+ }
+
diff --git a/dev-python/matplotlib/matplotlib-1.1.1.ebuild b/dev-python/matplotlib/matplotlib-1.1.1.ebuild
index b0770605246d..1d3e5763552b 100644
--- a/dev-python/matplotlib/matplotlib-1.1.1.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.1.1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.1.1.ebuild,v 1.4 2012/11/06 10:58:40 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.1.1.ebuild,v 1.5 2012/11/26 06:21:01 idella4 Exp $
EAPI="3"
-# python eclass bloat
PYTHON_DEPEND="2"
PYTHON_USE_WITH="tk"
PYTHON_USE_WITH_OPT="tk"
@@ -84,7 +83,9 @@ use_setup() {
}
src_prepare() {
+ # from upstream commit ca678a49f37411b1b0e72d7d0dfa88c124b0e34b
epatch "${FILESDIR}"/${P}-ft-refcount.patch
+
# create setup.cfg (see setup.cfg.template for any changes)
cat > setup.cfg <<-EOF
[provide_packages]
@@ -117,13 +118,16 @@ src_prepare() {
src_compile() {
unset DISPLAY # bug #278524
distutils_src_compile
- if use doc; then
- cd "${S}/doc"
- VARTEXFONTS="${T}"/fonts \
+ makedocs() {
+ if use doc; then
+ cd "${S}/doc"
+ VARTEXFONTS="${T}"/fonts \
PYTHONPATH=$(ls -d "${S}"/build-$(PYTHON -f --ABI)/lib*) \
./make.py --small all
- [[ -e build/latex/Matplotlib.pdf ]] || die "doc generation failed"
- fi
+ [[ -e build/latex/Matplotlib.pdf ]] || die "doc generation failed"
+ fi
+ }
+ python_execute_function -f makedocs
}
src_test() {