summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-03-02 16:56:58 +0000
committerMichał Górny <mgorny@gentoo.org>2013-03-02 16:56:58 +0000
commit2d02a9206e7c503598ec019ec0b0e8cdd462c7d5 (patch)
treec756e937fcb7f42443d884be6b92bcccf2f37a69 /dev-python
parentVersion bump (diff)
downloadgentoo-2-2d02a9206e7c503598ec019ec0b0e8cdd462c7d5.tar.gz
gentoo-2-2d02a9206e7c503598ec019ec0b0e8cdd462c7d5.tar.bz2
gentoo-2-2d02a9206e7c503598ec019ec0b0e8cdd462c7d5.zip
Migrate to distutils-r1.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/py-gnupg/ChangeLog10
-rw-r--r--dev-python/py-gnupg/py-gnupg-0.3.2-r1.ebuild29
2 files changed, 36 insertions, 3 deletions
diff --git a/dev-python/py-gnupg/ChangeLog b/dev-python/py-gnupg/ChangeLog
index 32a8b4d4c484..68a0cd730438 100644
--- a/dev-python/py-gnupg/ChangeLog
+++ b/dev-python/py-gnupg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/py-gnupg
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/py-gnupg/ChangeLog,v 1.12 2010/07/23 22:16:48 arfrever Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/py-gnupg/ChangeLog,v 1.13 2013/03/02 16:56:58 mgorny Exp $
+
+*py-gnupg-0.3.2-r1 (02 Mar 2013)
+
+ 02 Mar 2013; Michał Górny <mgorny@gentoo.org> +py-gnupg-0.3.2-r1.ebuild:
+ Migrate to distutils-r1.
23 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
py-gnupg-0.3.2.ebuild:
@@ -38,4 +43,3 @@
17 Sep 2003; Alastair Tse <liquidx@gentoo.org> py-gnupg-0.3.2.ebuild:
initial commit. thanks to Derek Greentree <derek@leftwise.com> and Rob
Cakebread <robc@myrealbox.com>
-
diff --git a/dev-python/py-gnupg/py-gnupg-0.3.2-r1.ebuild b/dev-python/py-gnupg/py-gnupg-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..07467d282b02
--- /dev/null
+++ b/dev-python/py-gnupg/py-gnupg-0.3.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/py-gnupg/py-gnupg-0.3.2-r1.ebuild,v 1.1 2013/03/02 16:56:58 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+MY_P="GnuPGInterface-${PV}"
+
+DESCRIPTION="A Python module to interface with GnuPG."
+HOMEPAGE="http://py-gnupg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/py-gnupg/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=app-crypt/gnupg-1.2.1-r1"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ "${PYTHON}" unittests.py || die "Tests fail with ${EPYTHON}"
+}