summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-09 08:08:55 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-09 08:08:55 +0000
commit9175873c49e83851dd35939375942f7f6fa9fd63 (patch)
treebdbeb70597a9cd460b404729eed60b1c06c54fe2 /dev-python/yolk
parentBump/fix for #395533 #407065 (diff)
downloadgentoo-2-9175873c49e83851dd35939375942f7f6fa9fd63.tar.gz
gentoo-2-9175873c49e83851dd35939375942f7f6fa9fd63.tar.bz2
gentoo-2-9175873c49e83851dd35939375942f7f6fa9fd63.zip
Bump for 405605
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/yolk')
-rw-r--r--dev-python/yolk/ChangeLog9
-rw-r--r--dev-python/yolk/yolk-0.4.3.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-python/yolk/ChangeLog b/dev-python/yolk/ChangeLog
index 5e9772b3b761..891aae025542 100644
--- a/dev-python/yolk/ChangeLog
+++ b/dev-python/yolk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/yolk
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/yolk/ChangeLog,v 1.13 2011/07/20 17:55:39 neurogeek Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/yolk/ChangeLog,v 1.14 2012/03/09 08:08:55 patrick Exp $
+
+*yolk-0.4.3 (09 Mar 2012)
+
+ 09 Mar 2012; Patrick Lauer <patrick@gentoo.org> +yolk-0.4.3.ebuild:
+ Bump for 405605
20 Jul 2011; Jesus Rivero <neurogeek@gentoo.org> -yolk-0.4.1.ebuild:
Removed older version
diff --git a/dev-python/yolk/yolk-0.4.3.ebuild b/dev-python/yolk/yolk-0.4.3.ebuild
new file mode 100644
index 000000000000..3caa71ca50fd
--- /dev/null
+++ b/dev-python/yolk/yolk-0.4.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/yolk/yolk-0.4.3.ebuild,v 1.1 2012/03/09 08:08:55 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit eutils distutils
+
+DESCRIPTION="Tool and library for querying PyPI and locally installed Python packages"
+HOMEPAGE="http://pypi.python.org/pypi/yolk"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools"
+RDEPEND="dev-python/yolk-portage"
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ docinto examples/plugins
+ dodoc examples/plugins/*
+ docinto examples/plugins/yolk_portage
+ dodoc examples/plugins/yolk_portage/*
+ docinto examples/plugins/yolk_pkg_manager
+ dodoc examples/plugins/yolk_pkg_manager/*
+ fi
+}