summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2003-06-29 08:50:40 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2003-06-29 08:50:40 +0000
commit913feb6026e0d4c105e3590a8d0894dfd6724bb2 (patch)
tree17952779ace87e3ee2dcc2ae9aca28e4428644ac /dev-python/twisted
parentnew version(important security fix for twisted.web) (diff)
downloadgentoo-2-913feb6026e0d4c105e3590a8d0894dfd6724bb2.tar.gz
gentoo-2-913feb6026e0d4c105e3590a8d0894dfd6724bb2.tar.bz2
gentoo-2-913feb6026e0d4c105e3590a8d0894dfd6724bb2.zip
new version(important security fix for twisted.web)
Diffstat (limited to 'dev-python/twisted')
-rw-r--r--dev-python/twisted/ChangeLog6
-rw-r--r--dev-python/twisted/Manifest7
-rw-r--r--dev-python/twisted/files/digest-twisted-1.0.61
-rw-r--r--dev-python/twisted/twisted-1.0.6.ebuild43
4 files changed, 51 insertions, 6 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index 50fe81cd62dd..213016a2d73c 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/twisted
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.19 2003/06/12 20:39:20 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.20 2003/06/29 08:49:43 lordvan Exp $
+
+*twisted-1.0.6 (29 Jun 2003)
+ 29 Jun 2003; Thomas Raschbacher <lordvan@gentoo.org> twisted-1.0.6.ebuild:
+ new version (with security bugfix for twisted.web)
12 Jun 2003; <msterret@gentoo.org> twisted-1.0.2.ebuild:
add Header
diff --git a/dev-python/twisted/Manifest b/dev-python/twisted/Manifest
index 27595f407516..06391bde6fd8 100644
--- a/dev-python/twisted/Manifest
+++ b/dev-python/twisted/Manifest
@@ -1,13 +1,10 @@
MD5 69b224d00f05b6050721bdfd313f112b twisted-1.0.3-r1.ebuild 1240
MD5 4b9567bed4d4f31456feb90773692a72 twisted-1.0.4.ebuild 1242
-MD5 8d498013ad1080c6b0dc4ee4dbba332a twisted-1.0.5.ebuild~ 1237
-MD5 dab4ebc597696742f3554ae530560166 ChangeLog.~1.17.~ 5443
-MD5 74448f71fcb558113436a12d501d8cf3 twisted-1.0.6.ebuild 1250
-MD5 8d498013ad1080c6b0dc4ee4dbba332a twisted-1.0.4.ebuild.~1.1.~ 1237
+MD5 a677c69be996ac33b5f962df8166e258 twisted-1.0.6.ebuild 1250
MD5 a848fa92ee9de9fb7bc6ed24bd455e52 twisted-1.0.3.ebuild 1027
MD5 c54f548d5a9b7b44633f9d6a9e0a9ae4 twisted-1.0.1-r1.ebuild 1046
MD5 2124d063482cbded063fc32a82dfd90d twisted-1.0.5.ebuild 1250
-MD5 d7258a74cbd802f7c6e75ef17c8b7e74 ChangeLog 5676
+MD5 1510bfad35d394f0b5abee38235543f0 ChangeLog 5835
MD5 761bccbe0d02eae820360028ba372642 twisted-1.0.2.ebuild 1159
MD5 a10d97e929ad363df80f670b7579f2a6 files/digest-twisted-1.0.2 67
MD5 bb7d3ef16b63fe638cc8becd30eede88 files/digest-twisted-1.0.3 67
diff --git a/dev-python/twisted/files/digest-twisted-1.0.6 b/dev-python/twisted/files/digest-twisted-1.0.6
new file mode 100644
index 000000000000..5da11ce5dee7
--- /dev/null
+++ b/dev-python/twisted/files/digest-twisted-1.0.6
@@ -0,0 +1 @@
+MD5 ff59478f4101aa05a923a318de8eb741 Twisted-1.0.6.tar.bz2 5191128
diff --git a/dev-python/twisted/twisted-1.0.6.ebuild b/dev-python/twisted/twisted-1.0.6.ebuild
new file mode 100644
index 000000000000..98718e2af7dd
--- /dev/null
+++ b/dev-python/twisted/twisted-1.0.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.0.6.ebuild,v 1.1 2003/06/29 08:49:43 lordvan Exp $
+
+IUSE="gtk2 doc"
+
+S=${WORKDIR}/Twisted-${PV}
+DESCRIPTION="Twisted is a collection of servers and clients, which can be used either by developers of new applications or directly. Documentation included."
+SRC_URI="http://twisted.sourceforge.net/Twisted-${PV}.tar.bz2"
+HOMEPAGE="http://www.twistedmatrix.com/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+DEPEND=">=dev-lang/python-2.2*
+ >=dev-python/pycrypto-1.9_alpha4
+ gtk? ( =dev-python/pygtk-0.6* )
+ gtk2? ( >=dev-python/pygtk-1.99* )"
+KEYWORDS="~x86 ~alpha ~sparc "
+
+inherit distutils
+
+src_install() {
+ distutils_src_install
+
+ # of course it's documentation!
+ doman doc/man/*.[0-9n]
+ rm -rf doc/man # don't dupe the man pages
+
+ # next few lines will install docs: 9.4 megs!
+ if [ -n "`use doc`" ]; then
+ cd ${S}/doc
+ dodir /usr/share/doc/${PF}
+ cp -r . ${D}/usr/share/doc/${PF}
+ fi
+
+ # use gtk2 if they so wish
+ if [ -n "`use gtk2`" ]; then
+ sed -e 's/import manhole/import manhole2/' \
+ -e 's/manhole\.run()/manhole2.run()/' \
+ -i ${D}/usr/bin/manhole
+ fi
+
+}
+