summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-01-05 05:58:05 +0000
committerIan Delaney <idella4@gentoo.org>2013-01-05 05:58:05 +0000
commitdbbf8ba8c59a1f4a7ee7cc6906bf33a45b47e818 (patch)
tree852c6e93410af059b9c9292187a4ce7e2b1cebdd /dev-python/pyusb
parentversion bump (bug #450314) (diff)
downloadgentoo-2-dbbf8ba8c59a1f4a7ee7cc6906bf33a45b47e818.tar.gz
gentoo-2-dbbf8ba8c59a1f4a7ee7cc6906bf33a45b47e818.tar.bz2
gentoo-2-dbbf8ba8c59a1f4a7ee7cc6906bf33a45b47e818.zip
bump, requested by K. Niemi, Bug #447998
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyusb')
-rw-r--r--dev-python/pyusb/ChangeLog10
-rw-r--r--dev-python/pyusb/pyusb-1.0.0_alpha3.ebuild31
2 files changed, 38 insertions, 3 deletions
diff --git a/dev-python/pyusb/ChangeLog b/dev-python/pyusb/ChangeLog
index 7e9d0a3788a3..85188e4a56cc 100644
--- a/dev-python/pyusb/ChangeLog
+++ b/dev-python/pyusb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyusb
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyusb/ChangeLog,v 1.10 2012/07/25 17:57:50 steev Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyusb/ChangeLog,v 1.11 2013/01/05 05:58:05 idella4 Exp $
+
+*pyusb-1.0.0_alpha3 (05 Jan 2013)
+
+ 05 Jan 2013; Ian Delaney <idella4@gentoo.org> +pyusb-1.0.0_alpha3.ebuild:
+ bump, requested by K. Niemi, Bug #447998
25 Jul 2012; Steev Klimaszewski <steev@gentoo.org> pyusb-1.0.0_alpha1.ebuild:
Add ~arm keywording. Tested on an mx51 and mx6.
@@ -45,4 +50,3 @@
28 May 2009; Joseph Jezak <josejx@gentoo.org> +metadata.xml,
+pyusb-0.4.1.ebuild:
Initial commit.
-
diff --git a/dev-python/pyusb/pyusb-1.0.0_alpha3.ebuild b/dev-python/pyusb/pyusb-1.0.0_alpha3.ebuild
new file mode 100644
index 000000000000..431de52e0059
--- /dev/null
+++ b/dev-python/pyusb/pyusb-1.0.0_alpha3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyusb/pyusb-1.0.0_alpha3.ebuild,v 1.1 2013/01/05 05:58:05 idella4 Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit distutils
+
+MY_P="${P/_alpha/a}"
+
+DESCRIPTION="USB support for Python."
+HOMEPAGE="http://pyusb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+### This version is compatible with both 0.X and 1.X versions of libusb
+DEPEND="virtual/libusb:1
+ dev-python/setuptools"
+RDEPEND="${DEPEND}"
+DOCS="README.rst docs/tutorial.rst"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="usb"