summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-01-08 19:00:42 +0000
committerMichał Górny <mgorny@gentoo.org>2013-01-08 19:00:42 +0000
commited4f8f0eedd6c4250e5a7c027bc111569acf1862 (patch)
treef2fd7434a9b020d6324e4eb50f102702e5df19f5 /dev-python/python-gnupg
parentVersion bump. Migrate to distutils-r1. Enable tests. Add to the Python herd. (diff)
downloadgentoo-2-ed4f8f0eedd6c4250e5a7c027bc111569acf1862.tar.gz
gentoo-2-ed4f8f0eedd6c4250e5a7c027bc111569acf1862.tar.bz2
gentoo-2-ed4f8f0eedd6c4250e5a7c027bc111569acf1862.zip
Migrate to distutils-r1. Restrict tests because of bug #449638.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/python-gnupg')
-rw-r--r--dev-python/python-gnupg/ChangeLog10
-rw-r--r--dev-python/python-gnupg/python-gnupg-0.3.1-r1.ebuild26
2 files changed, 33 insertions, 3 deletions
diff --git a/dev-python/python-gnupg/ChangeLog b/dev-python/python-gnupg/ChangeLog
index a05335964ea0..d6940c93a543 100644
--- a/dev-python/python-gnupg/ChangeLog
+++ b/dev-python/python-gnupg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-gnupg
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-gnupg/ChangeLog,v 1.2 2012/09/29 22:47:04 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-gnupg/ChangeLog,v 1.3 2013/01/08 19:00:42 mgorny Exp $
+
+*python-gnupg-0.3.1-r1 (08 Jan 2013)
+
+ 08 Jan 2013; Michał Górny <mgorny@gentoo.org> +python-gnupg-0.3.1-r1.ebuild:
+ Migrate to distutils-r1. Restrict tests because of bug #449638.
*python-gnupg-0.3.1 (29 Sep 2012)
@@ -12,4 +17,3 @@
10 Jun 2012; Mike Gilbert <floppym@gentoo.org> +metadata.xml,
+python-gnupg-0.3.0.ebuild:
New package requested by hwoarang.
-
diff --git a/dev-python/python-gnupg/python-gnupg-0.3.1-r1.ebuild b/dev-python/python-gnupg/python-gnupg-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..ef9f4b8032ad
--- /dev/null
+++ b/dev-python/python-gnupg/python-gnupg-0.3.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-gnupg/python-gnupg-0.3.1-r1.ebuild,v 1.1 2013/01/08 19:00:42 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for GNU Privacy Guard"
+HOMEPAGE="http://code.google.com/p/python-gnupg/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-crypt/gnupg"
+
+# Tests hang, bug #449638.
+RESTRICT=test
+
+python_test() {
+ "${PYTHON}" test_gnupg.py || die "Tests fail with ${EPYTHON}"
+}