summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-11-19 15:10:46 +0000
committerIan Delaney <idella4@gentoo.org>2014-11-19 15:10:46 +0000
commitc760920081d5dc5fd0fad365e68413b2da619d71 (patch)
treee458ac3a86673d2068867cb414dcffda95034901 /dev-python/pytest
parentAdd pypy3 support, dep for doc build (diff)
downloadgentoo-2-c760920081d5dc5fd0fad365e68413b2da619d71.tar.gz
gentoo-2-c760920081d5dc5fd0fad365e68413b2da619d71.tar.bz2
gentoo-2-c760920081d5dc5fd0fad365e68413b2da619d71.zip
Add pypy3 support, dep for doc build
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/ChangeLog6
-rw-r--r--dev-python/pytest/pytest-2.6.4.ebuild9
2 files changed, 9 insertions, 6 deletions
diff --git a/dev-python/pytest/ChangeLog b/dev-python/pytest/ChangeLog
index 6c37d4a0f71c..21c04b45fb76 100644
--- a/dev-python/pytest/ChangeLog
+++ b/dev-python/pytest/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pytest
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.109 2014/11/11 11:14:51 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.110 2014/11/19 15:10:46 idella4 Exp $
+
+ 19 Nov 2014; Ian Delaney <idella4@gentoo.org> pytest-2.6.1.ebuild,
+ pytest-2.6.4.ebuild:
+ Add pypy3 support, dep for doc build
11 Nov 2014; Agostino Sarubbo <ago@gentoo.org> pytest-2.6.3.ebuild:
Stable for ia64, wrt bug #524416
diff --git a/dev-python/pytest/pytest-2.6.4.ebuild b/dev-python/pytest/pytest-2.6.4.ebuild
index e614e2aa6ee0..5c6d85742b2f 100644
--- a/dev-python/pytest/pytest-2.6.4.ebuild
+++ b/dev-python/pytest/pytest-2.6.4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.6.4.ebuild,v 1.1 2014/10/25 22:11:51 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.6.4.ebuild,v 1.2 2014/11/19 15:10:46 idella4 Exp $
EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
inherit distutils-r1
DESCRIPTION="py.test: simple powerful testing with Python"
@@ -23,9 +23,8 @@ RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
- $(python_gen_cond_dep 'dev-python/pexpect[${PYTHON_USEDEP}]' 'python*')
- dev-python/pyyaml[${PYTHON_USEDEP}]
- )
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}] )
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
python_prepare_all() {