summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-12-25 13:37:20 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-12-25 13:37:20 +0000
commit9c8ec7b40324fac1e6f928c149c4d8d6890aa4f7 (patch)
tree8fd31791f009313fa87f41fd9110a1a01e1f7fb1 /dev-python/pyro
parentDrop masked for removal package (diff)
downloadgentoo-2-9c8ec7b40324fac1e6f928c149c4d8d6890aa4f7.tar.gz
gentoo-2-9c8ec7b40324fac1e6f928c149c4d8d6890aa4f7.tar.bz2
gentoo-2-9c8ec7b40324fac1e6f928c149c4d8d6890aa4f7.zip
Version bump. All tests pass fine now (on amd64 at least).
Pyro 4.17 - Fixed possible IndentationError problem with sending modules in Flame - Can now deal with exceptions that can’t be serialized: they’re raised as generic PyroError instead, with appropriate message - Added new config item FLAME_ENABLED, to enable/disable the use of Pyro Flame on the server. Default is false (disabled). - Moved futures from core to new futures module. Code using Pyro4.Future will still work. - Added python version info to configuration dump - Made it more clear in the manual that you need to have the same major Python version on both sides Pyro 4.16 - New implementation for the threadpool server: job queue with self-adjusting number of workers. The workaround that was in place (fixed pool size) has been removed. - Minor api doc fix: corrected reference of Pyro4 package members Pyro 4.15 - Minimum threadpool size increased to 20 (from 4) to give a bit more breathing room while the threadpool scaling still needs to be fixed - Binding a proxy will no longer release an existing connection first, instead it will just do nothing if the proxy has already been bound to its uri - Resolved a race condition related to releasing and binding a proxy, improved unit test - Documentation contains new homepage link - No longer gives a warning about version incompatibility on Jython 2.5 - Optimize bytecode flag no longer added in setup script when using jython, this used to crash the setup.py install process on jython - Fixed a gc issue due to a circular dependency - IronPython: improved suggesting a free port number in socketutil.findProbablyUnusedPort - IronPython: threadpoolserver no longer attempts to join the worker threads because not all threads seemed to actually exit on IronPython, thereby hanging the process when shutting down a daemon. - Added a paragraph to tips&tricks about MSG_WAITALL - socket.MSG_WAITALL is no longer deleted by importing Pyro on systems that have a broken MSG_WAITALL (Windows). You’ll have to check for this yourself now, but I wanted to get rid of this side effect of importing Pyro. (Portage version: 2.1.11.38/cvs/Linux x86_64, signed Manifest commit with key E1DBFAB5)
Diffstat (limited to 'dev-python/pyro')
-rw-r--r--dev-python/pyro/ChangeLog51
-rw-r--r--dev-python/pyro/pyro-4.17.ebuild86
2 files changed, 136 insertions, 1 deletions
diff --git a/dev-python/pyro/ChangeLog b/dev-python/pyro/ChangeLog
index 4bfc8c68395b..c05a747f7183 100644
--- a/dev-python/pyro/ChangeLog
+++ b/dev-python/pyro/ChangeLog
@@ -1,6 +1,55 @@
# ChangeLog for dev-python/pyro
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.73 2012/06/08 11:46:27 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.74 2012/12/25 13:37:20 aidecoe Exp $
+
+*pyro-4.17 (25 Dec 2012)
+
+ 25 Dec 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> +pyro-4.17.ebuild:
+ Version bump. All tests pass fine now (on amd64 at least).
+
+ Pyro 4.17
+
+ - Fixed possible IndentationError problem with sending modules in Flame
+ - Can now deal with exceptions that can’t be serialized: they’re raised as
+ generic PyroError instead, with appropriate message
+ - Added new config item FLAME_ENABLED, to enable/disable the use of Pyro
+ Flame on the server. Default is false (disabled).
+ - Moved futures from core to new futures module. Code using Pyro4.Future will
+ still work.
+ - Added python version info to configuration dump
+ - Made it more clear in the manual that you need to have the same major
+ Python version on both sides
+
+ Pyro 4.16
+
+ - New implementation for the threadpool server: job queue with self-adjusting
+ number of workers. The workaround that was in place (fixed pool size) has
+ been removed.
+ - Minor api doc fix: corrected reference of Pyro4 package members
+
+ Pyro 4.15
+
+ - Minimum threadpool size increased to 20 (from 4) to give a bit more
+ breathing room while the threadpool scaling still needs to be fixed
+ - Binding a proxy will no longer release an existing connection first,
+ instead it will just do nothing if the proxy has already been bound to its
+ uri
+ - Resolved a race condition related to releasing and binding a proxy,
+ improved unit test
+ - Documentation contains new homepage link
+ - No longer gives a warning about version incompatibility on Jython 2.5
+ - Optimize bytecode flag no longer added in setup script when using jython,
+ this used to crash the setup.py install process on jython
+ - Fixed a gc issue due to a circular dependency
+ - IronPython: improved suggesting a free port number in
+ socketutil.findProbablyUnusedPort
+ - IronPython: threadpoolserver no longer attempts to join the worker threads
+ because not all threads seemed to actually exit on IronPython, thereby
+ hanging the process when shutting down a daemon.
+ - Added a paragraph to tips&tricks about MSG_WAITALL
+ - socket.MSG_WAITALL is no longer deleted by importing Pyro on systems that
+ have a broken MSG_WAITALL (Windows). You’ll have to check for this yourself
+ now, but I wanted to get rid of this side effect of importing Pyro.
08 Jun 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> pyro-4.11.ebuild:
x86 stable wrt bug #419025
diff --git a/dev-python/pyro/pyro-4.17.ebuild b/dev-python/pyro/pyro-4.17.ebuild
new file mode 100644
index 000000000000..7f5ec20130e9
--- /dev/null
+++ b/dev-python/pyro/pyro-4.17.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-4.17.ebuild,v 1.1 2012/12/25 13:37:20 aidecoe Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45]"
+
+inherit distutils
+
+MY_PN="Pyro4"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Advanced and powerful Distributed Object Technology system written entirely in Python"
+HOMEPAGE="http://www.xs4all.nl/~irmen/pyro/ http://pypi.python.org/pypi/Pyro4"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="!dev-python/pyro:0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ test? (
+ dev-python/coverage
+ dev-python/nose
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="Pyro4"
+
+src_prepare() {
+ distutils_src_prepare
+
+ sed -e '/sys.path.insert/a sys.path.insert(1,"PyroTests")' -i tests/run_suite.py
+
+ # Disable tests requiring network connection.
+ sed \
+ -e "s/testBCstart/_&/" \
+ -e "s/testDaemonPyroObj/_&/" \
+ -e "s/testLookupAndRegister/_&/" \
+ -e "s/testMulti/_&/" \
+ -e "s/testRefuseDottedNames/_&/" \
+ -e "s/testResolve/_&/" \
+ -i tests/PyroTests/test_naming.py
+ sed \
+ -e "s/testOwnloopBasics/_&/" \
+ -e "s/testStartNSfunc/_&/" \
+ -i tests/PyroTests/test_naming2.py
+
+ sed \
+ -e "s/testServerConnections/_&/" \
+ -e "s/testServerParallelism/_&/" \
+ -i tests/PyroTests/test_server.py
+
+ sed \
+ -e "s/testBroadcast/_&/" \
+ -e "s/testGetIP/_&/" \
+ -i tests/PyroTests/test_socket.py
+}
+
+src_test() {
+ cd tests
+
+ testing() {
+ "$(PYTHON)" run_suite.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/* || die "Installation of documentation failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "Installation of examples failed"
+ fi
+}