summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-12-23 16:45:54 +0000
committerTim Harder <radhermit@gentoo.org>2014-12-23 16:45:54 +0000
commit59b421033510dbc35652dfcd5f47d42339e07799 (patch)
treee35e3898743814d03d45a93e9fa8f757d24243ec /dev-python/pip
parentVersion bump and disable default version checks. (diff)
downloadgentoo-2-59b421033510dbc35652dfcd5f47d42339e07799.tar.gz
gentoo-2-59b421033510dbc35652dfcd5f47d42339e07799.tar.bz2
gentoo-2-59b421033510dbc35652dfcd5f47d42339e07799.zip
Remove old.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 4F064CA3)
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/ChangeLog7
-rw-r--r--dev-python/pip/files/pip-1.3.1-unversioned.patch11
-rw-r--r--dev-python/pip/files/pip-1.5-unversioned.patch12
-rw-r--r--dev-python/pip/pip-1.4.1.ebuild39
-rw-r--r--dev-python/pip/pip-6.0.ebuild37
5 files changed, 6 insertions, 100 deletions
diff --git a/dev-python/pip/ChangeLog b/dev-python/pip/ChangeLog
index f5a2f112c264..15f922aaf729 100644
--- a/dev-python/pip/ChangeLog
+++ b/dev-python/pip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pip
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.46 2014/12/23 16:44:26 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.47 2014/12/23 16:45:54 radhermit Exp $
+
+ 23 Dec 2014; Tim Harder <radhermit@gentoo.org> -pip-1.4.1.ebuild,
+ -pip-6.0.ebuild, -files/pip-1.3.1-unversioned.patch,
+ -files/pip-1.5-unversioned.patch:
+ Remove old.
*pip-6.0.2 (23 Dec 2014)
diff --git a/dev-python/pip/files/pip-1.3.1-unversioned.patch b/dev-python/pip/files/pip-1.3.1-unversioned.patch
deleted file mode 100644
index 25d549361334..000000000000
--- a/dev-python/pip/files/pip-1.3.1-unversioned.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- pip-1.3.1/setup.py
-+++ pip-1.3.1/setup.py
-@@ -51,7 +51,7 @@
- license='MIT',
- packages=['pip', 'pip.commands', 'pip.vcs', 'pip.backwardcompat'],
- package_data={'pip': ['*.pem']},
-- entry_points=dict(console_scripts=['pip=pip:main', 'pip-%s=pip:main' % sys.version[:3]]),
-+ entry_points=dict(console_scripts=['pip=pip:main']),
- test_suite='nose.collector',
- tests_require=tests_require,
- zip_safe=False,
diff --git a/dev-python/pip/files/pip-1.5-unversioned.patch b/dev-python/pip/files/pip-1.5-unversioned.patch
deleted file mode 100644
index 40e40422bdda..000000000000
--- a/dev-python/pip/files/pip-1.5-unversioned.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- pip-1.5/setup.py
-+++ pip-1.5/setup.py
-@@ -71,8 +71,7 @@
- 'pip._vendor.distlib._backport': ['sysconfig.cfg'],
- 'pip._vendor.distlib': ['t32.exe', 't64.exe', 'w32.exe', 'w64.exe'],
- },
-- entry_points=dict(console_scripts=['pip=pip:main', 'pip%s=pip:main' % sys.version[:1],
-- 'pip%s=pip:main' % sys.version[:3]]),
-+ entry_points=dict(console_scripts=['pip=pip:main']),
- tests_require=tests_require,
- zip_safe=False,
- extras_require={
diff --git a/dev-python/pip/pip-1.4.1.ebuild b/dev-python/pip/pip-1.4.1.ebuild
deleted file mode 100644
index cd8679b22fa1..000000000000
--- a/dev-python/pip/pip-1.4.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-1.4.1.ebuild,v 1.8 2014/11/23 19:20:49 mrueg Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Installs python packages -- replacement for easy_install"
-HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE=""
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-# required test data isn't bundled with the tarball
-RESTRICT="test"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.3.1-unversioned.patch )
-
-python_install_all() {
- local DOCS=( AUTHORS.txt docs/*.rst )
- distutils-r1_python_install_all
-
- COMPLETION="${T}"/completion.tmp
-
- ${EPYTHON} pip/runner.py completion --bash > "${COMPLETION}" || die
- newbashcomp "${COMPLETION}" ${PN}
-
- ${EPYTHON} pip/runner.py completion --zsh > "${COMPLETION}" || die
- insinto /usr/share/zsh/site-functions
- newins "${COMPLETION}" _pip
-}
diff --git a/dev-python/pip/pip-6.0.ebuild b/dev-python/pip/pip-6.0.ebuild
deleted file mode 100644
index 79a42114476c..000000000000
--- a/dev-python/pip/pip-6.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-6.0.ebuild,v 1.1 2014/12/22 20:24:43 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Installs python packages -- replacement for easy_install"
-HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE=""
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-# required test data isn't bundled with the tarball
-RESTRICT="test"
-
-python_install_all() {
- local DOCS=( AUTHORS.txt docs/*.rst )
- distutils-r1_python_install_all
-
- COMPLETION="${T}"/completion.tmp
-
- ${EPYTHON} pip/__init__.py completion --bash > "${COMPLETION}" || die
- newbashcomp "${COMPLETION}" ${PN}
-
- ${EPYTHON} pip/__init__.py completion --zsh > "${COMPLETION}" || die
- insinto /usr/share/zsh/site-functions
- newins "${COMPLETION}" _pip
-}