summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-04-25 21:10:12 +0000
committerAlex Brandt <alunduil@gentoo.org>2015-04-25 21:10:12 +0000
commita21c9f063453b000767b01b87d11d588db679c81 (patch)
treecc1484597b4e4f70031ced1f43861ee3aa86d078 /dev-python/oslotest
parentwww-apps/wordpress: 4.2 (diff)
downloadgentoo-2-a21c9f063453b000767b01b87d11d588db679c81.tar.gz
gentoo-2-a21c9f063453b000767b01b87d11d588db679c81.tar.bz2
gentoo-2-a21c9f063453b000767b01b87d11d588db679c81.zip
add version 1.6.0
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 11A8217C!)
Diffstat (limited to 'dev-python/oslotest')
-rw-r--r--dev-python/oslotest/ChangeLog7
-rw-r--r--dev-python/oslotest/oslotest-1.6.0.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-python/oslotest/ChangeLog b/dev-python/oslotest/ChangeLog
index 44f834f13fc3..50d6a972c19b 100644
--- a/dev-python/oslotest/ChangeLog
+++ b/dev-python/oslotest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/oslotest
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oslotest/ChangeLog,v 1.12 2015/03/14 23:22:35 alunduil Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslotest/ChangeLog,v 1.13 2015/04/25 21:10:12 alunduil Exp $
+
+*oslotest-1.6.0 (25 Apr 2015)
+
+ 25 Apr 2015; Alex Brandt <alunduil@gentoo.org> +oslotest-1.6.0.ebuild:
+ add version 1.6.0
*oslotest-1.5.1 (14 Mar 2015)
diff --git a/dev-python/oslotest/oslotest-1.6.0.ebuild b/dev-python/oslotest/oslotest-1.6.0.ebuild
new file mode 100644
index 000000000000..9789bdd2cc65
--- /dev/null
+++ b/dev-python/oslotest/oslotest-1.6.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslotest/oslotest-1.6.0.ebuild,v 1.1 2015/04/25 21:10:12 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Oslo test framework"
+HOMEPAGE="http://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux ~x86 ~x86-linux"
+IUSE="doc test"
+
+CDEPEND="
+ >=dev-python/pbr-0.6[${PYTHON_USEDEP}]
+ !~dev-python/pbr-0.7[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ <dev-python/hacking-0.11[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.10.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.36[${PYTHON_USEDEP}]
+ !~dev-python/testtools-1.2.0[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ rm -rf .testrepository || die "coudln't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ use doc && doman doc/build/man/oslotest.1
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ elog "man page installation requires USE=doc"
+}