summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-05-15 08:16:37 +0000
committerMike Frysinger <vapier@gentoo.org>2015-05-15 08:16:37 +0000
commit4fc82ed2f0f97995cb68a6afcdfbd5f57aed0b4a (patch)
treef39668428d468bd7da70b266a61f9452acf5f4cd /dev-python/matplotlib
parentamd64/ppc/ppc64/x86 stable, bug #547668 (diff)
downloadgentoo-2-4fc82ed2f0f97995cb68a6afcdfbd5f57aed0b4a.tar.gz
gentoo-2-4fc82ed2f0f97995cb68a6afcdfbd5f57aed0b4a.tar.bz2
gentoo-2-4fc82ed2f0f97995cb68a6afcdfbd5f57aed0b4a.zip
Punt unreferenced patches.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/ChangeLog9
-rw-r--r--dev-python/matplotlib/files/matplotlib-1.1.1-ft-refcount.patch48
-rw-r--r--dev-python/matplotlib/files/matplotlib-1.2.0-ft-refcount.patch41
-rw-r--r--dev-python/matplotlib/files/matplotlib-1.2.0-setup.patch36
-rw-r--r--dev-python/matplotlib/files/matplotlib-1.3.0-setup_without_X11.patch42
5 files changed, 8 insertions, 168 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
index 02674eafcad0..9d758efa6aa5 100644
--- a/dev-python/matplotlib/ChangeLog
+++ b/dev-python/matplotlib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/matplotlib
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.187 2015/03/20 12:57:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.188 2015/05/15 08:16:37 vapier Exp $
+
+ 15 May 2015; Mike Frysinger <vapier@gentoo.org>
+ -files/matplotlib-1.1.1-ft-refcount.patch,
+ -files/matplotlib-1.2.0-ft-refcount.patch,
+ -files/matplotlib-1.2.0-setup.patch,
+ -files/matplotlib-1.3.0-setup_without_X11.patch:
+ Punt unreferenced patches.
20 Mar 2015; Justin Lecher <jlec@gentoo.org> -matplotlib-1.1.1.ebuild,
-matplotlib-1.3.0-r1.ebuild, -matplotlib-1.4.0.ebuild,
diff --git a/dev-python/matplotlib/files/matplotlib-1.1.1-ft-refcount.patch b/dev-python/matplotlib/files/matplotlib-1.1.1-ft-refcount.patch
deleted file mode 100644
index df135c201c3d..000000000000
--- a/dev-python/matplotlib/files/matplotlib-1.1.1-ft-refcount.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-#Restoring a fix to an old reference counting bug which was re-included in a recent commit. It fails stix_fonts_demo.py
-# https://github.com/matplotlib/matplotlib/commit/85af0c02bf9a8ecdd0fd18eab8c9662c6b9f4302#src/ft2font.cpp (Keep just in case)
-
-Reinstate the manual reference counting as discovered in #1054
-commit ca678a49f37411b1b0e72d7d0dfa88c124b0e34b
-wrt Bug #442298 by Carl Michal, "the patch in the tree is missing the fifth insertion', i.e. the 2nd. hunk
-appending the 2nd hunk to bicatelli's prepared patch
-
-bicatali@gentoo.org 08/2012
---- src/ft2font.cpp.orig 2012-08-01 17:30:33.000000000 +0100
-+++ src/ft2font.cpp 2012-08-01 17:30:42.000000000 +0100
-@@ -870,24 +870,28 @@
- {
- std::ostringstream s;
- s << "Could not load facefile " << facefile << "; Unknown_File_Format" << std::endl;
-+ ob_refcnt--;
- throw Py::RuntimeError(s.str());
- }
- else if (error == FT_Err_Cannot_Open_Resource)
- {
- std::ostringstream s;
- s << "Could not open facefile " << facefile << "; Cannot_Open_Resource" << std::endl;
-+ ob_refcnt--;
- throw Py::RuntimeError(s.str());
- }
- else if (error == FT_Err_Invalid_File_Format)
- {
- std::ostringstream s;
- s << "Could not open facefile " << facefile << "; Invalid_File_Format" << std::endl;
-+ ob_refcnt--;
- throw Py::RuntimeError(s.str());
- }
- else if (error)
- {
- std::ostringstream s;
- s << "Could not open facefile " << facefile << "; freetype error code " << error << std::endl;
-+ ob_refcnt--;
- throw Py::RuntimeError(s.str());
- }
-
-@@ -904,6 +908,7 @@ inline double conv(int v)
- {
- std::ostringstream s;
- s << "Could not set the fontsize for facefile " << facefile << std::endl;
-+ ob_refcnt--;
- throw Py::RuntimeError(s.str());
- }
-
diff --git a/dev-python/matplotlib/files/matplotlib-1.2.0-ft-refcount.patch b/dev-python/matplotlib/files/matplotlib-1.2.0-ft-refcount.patch
deleted file mode 100644
index 822f3491427b..000000000000
--- a/dev-python/matplotlib/files/matplotlib-1.2.0-ft-refcount.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-Issue 532; https://github.com/mdboom/matplotlib/commit/81068e9967387ea69133277242a9804d646ea4ef
-diff -ur matplotlib-1.2.0.orig/src/ft2font.cpp matplotlib-1.2.0/src/ft2font.cpp
---- src/ft2font.cpp 2012-10-31 08:11:14.000000000 +0800
-+++ src/ft2font.cpp 2012-11-29 11:09:43.569808461 +0800
-@@ -852,28 +852,24 @@
- {
- std::ostringstream s;
- s << "Could not load facefile " << facefile << "; Unknown_File_Format" << std::endl;
-- ob_refcnt--;
- throw Py::RuntimeError(s.str());
- }
- else if (error == FT_Err_Cannot_Open_Resource)
- {
- std::ostringstream s;
- s << "Could not open facefile " << facefile << "; Cannot_Open_Resource" << std::endl;
-- ob_refcnt--;
- throw Py::RuntimeError(s.str());
- }
- else if (error == FT_Err_Invalid_File_Format)
- {
- std::ostringstream s;
- s << "Could not open facefile " << facefile << "; Invalid_File_Format" << std::endl;
-- ob_refcnt--;
- throw Py::RuntimeError(s.str());
- }
- else if (error)
- {
- std::ostringstream s;
- s << "Could not open facefile " << facefile << "; freetype error code " << error << std::endl;
-- ob_refcnt--;
- throw Py::RuntimeError(s.str());
- }
-
-@@ -891,7 +887,6 @@
- {
- std::ostringstream s;
- s << "Could not set the fontsize for facefile " << facefile << std::endl;
-- ob_refcnt--;
- throw Py::RuntimeError(s.str());
- }
-
diff --git a/dev-python/matplotlib/files/matplotlib-1.2.0-setup.patch b/dev-python/matplotlib/files/matplotlib-1.2.0-setup.patch
deleted file mode 100644
index ba0351840749..000000000000
--- a/dev-python/matplotlib/files/matplotlib-1.2.0-setup.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -ur matplotlib-1.2.0.orig/setup.py matplotlib-1.2.0/setup.py
---- setup.py 2012-11-08 10:24:12.000000000 +0800
-+++ setup.py 2012-11-25 06:55:27.531042898 +0800
-@@ -171,20 +171,19 @@
- # regardless of the lack of dependencies. If auto, silently skip
- # when dependencies are missing.
- if options['build_tkagg']:
-- if check_for_tk() or (options['build_tkagg'] is True):
-- options['build_agg'] = 1
-- build_tkagg(ext_modules, packages)
-- rc['backend'] = 'TkAgg'
-+ options['build_agg'] = 1
-+ build_tkagg(ext_modules, packages)
-+ rc['backend'] = 'TkAgg'
-
--hasgtk = check_for_gtk()
--if options['build_gtk']:
-- if hasgtk or (options['build_gtk'] is True):
-- build_gdk(ext_modules, packages)
--if options['build_gtkagg']:
-- if hasgtk or (options['build_gtkagg'] is True):
-- options['build_agg'] = 1
-- build_gtkagg(ext_modules, packages)
-- rc['backend'] = 'GTKAgg'
-+if sys.version_info[0] >= 3:
-+ hasgtk = False
-+else:
-+ hasgtk = True
-+if hasgtk and (options['build_gtk'] is True):
-+ build_gdk(ext_modules, packages)
-+ options['build_agg'] = 1
-+ build_gtkagg(ext_modules, packages)
-+ rc['backend'] = 'GTKAgg'
-
- if options['build_macosx']:
- if check_for_macosx() or (options['build_macosx'] is True):
diff --git a/dev-python/matplotlib/files/matplotlib-1.3.0-setup_without_X11.patch b/dev-python/matplotlib/files/matplotlib-1.3.0-setup_without_X11.patch
deleted file mode 100644
index 2835ae547096..000000000000
--- a/dev-python/matplotlib/files/matplotlib-1.3.0-setup_without_X11.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=481564
-https://github.com/matplotlib/matplotlib/commit/1b3106c1bcd6017455232e8c974f1af8383a010c
-
---- a/setupext.py
-+++ b/setupext.py
-@@ -1463,7 +1463,7 @@ def backend_gtk3agg_internal_check(x):
-
- try:
- from gi.repository import Gtk, Gdk, GObject
-- except ImportError:
-+ except (ImportError, RuntimeError):
- return (False, "Requires pygobject to be installed.")
-
- return (True, "version %s.%s.%s" % (
-@@ -1489,9 +1489,14 @@ def check(self):
- p = multiprocessing.Pool()
- except:
- return "unknown (can not use multiprocessing to determine)"
-- success, msg = p.map(backend_gtk3agg_internal_check, [0])[0]
-- p.close()
-- p.join()
-+ try:
-+ success, msg = p.map(backend_gtk3agg_internal_check, [0])[0]
-+ except:
-+ success = False
-+ msg = "Could not determine"
-+ finally:
-+ p.close()
-+ p.join()
- if success:
- BackendAgg.force = True
-
-@@ -1521,7 +1526,7 @@ def backend_gtk3cairo_internal_check(x):
-
- try:
- from gi.repository import Gtk, Gdk, GObject
-- except ImportError:
-+ except (RuntimeError, ImportError):
- return (False, "Requires pygobject to be installed.")
-
- return (True, "version %s.%s.%s" % (
-