summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-07-01 08:45:37 +0000
committerIan Delaney <idella4@gentoo.org>2013-07-01 08:45:37 +0000
commit6d26f405ab081ebd104ff54585f5ca08e7262857 (patch)
tree9b46a64149959c954f0adf351242abc9034d63c9 /dev-python/kaa-base
parentrevbump; migrate -> distutils-r1 (diff)
downloadgentoo-2-6d26f405ab081ebd104ff54585f5ca08e7262857.tar.gz
gentoo-2-6d26f405ab081ebd104ff54585f5ca08e7262857.tar.bz2
gentoo-2-6d26f405ab081ebd104ff54585f5ca08e7262857.zip
revbump; migrate -> distutils-r1
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/kaa-base')
-rw-r--r--dev-python/kaa-base/ChangeLog7
-rw-r--r--dev-python/kaa-base/kaa-base-0.6.0-r1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/kaa-base/ChangeLog b/dev-python/kaa-base/ChangeLog
index e09b6d093693..1974ce4ca11b 100644
--- a/dev-python/kaa-base/ChangeLog
+++ b/dev-python/kaa-base/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/kaa-base
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-base/ChangeLog,v 1.27 2013/02/20 14:35:11 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-base/ChangeLog,v 1.28 2013/07/01 08:45:37 idella4 Exp $
+
+*kaa-base-0.6.0-r1 (01 Jul 2013)
+
+ 01 Jul 2013; Ian Delaney <idella4@gentoo.org> +kaa-base-0.6.0-r1.ebuild:
+ revbump; migrate -> distutils-r1
20 Feb 2013; Ian Delaney <idella4@gentoo.org> kaa-base-0.6.0.ebuild:
Disused IUSE ssl deleted, reported by Nikoli in Bug #457874
diff --git a/dev-python/kaa-base/kaa-base-0.6.0-r1.ebuild b/dev-python/kaa-base/kaa-base-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..ef52616806f3
--- /dev/null
+++ b/dev-python/kaa-base/kaa-base-0.6.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-base/kaa-base-0.6.0-r1.ebuild,v 1.1 2013/07/01 08:45:37 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="sqlite?,threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Basic Framework for all Kaa Python Modules."
+HOMEPAGE="http://freevo.sourceforge.net/kaa/"
+SRC_URI="mirror://sourceforge/freevo/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="avahi sqlite tls lirc"
+
+DEPEND=">=dev-libs/glib-2.4.0
+ avahi? ( net-dns/avahi[python] )
+ sqlite? ( dev-python/dbus-python[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}
+ dev-python/pynotifier[${PYTHON_USEDEP}]
+ lirc? ( dev-python/pylirc[${PYTHON_USEDEP}] )
+ tls? ( dev-python/tlslite[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -i -e 's:from pysqlite2 import dbapi2:import sqlite3:' \
+ src/db.py || die
+
+ rm -fr src/pynotifier
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ export CFLAGS
+ distutils-r1_python_compile
+}