summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-03-08 14:47:42 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-03-08 14:47:42 +0000
commit8e74b2bd9ceb8c5de071960b209019569ea0eb6b (patch)
tree4eb9e1df5954b95b1a360560ac68f6cedab6b261 /dev-python/htmlgen
parentChanged ~sparc keyword to sparc. (diff)
downloadgentoo-2-8e74b2bd9ceb8c5de071960b209019569ea0eb6b.tar.gz
gentoo-2-8e74b2bd9ceb8c5de071960b209019569ea0eb6b.tar.bz2
gentoo-2-8e74b2bd9ceb8c5de071960b209019569ea0eb6b.zip
HTMLgen initial commit. Bug #10653.
Diffstat (limited to 'dev-python/htmlgen')
-rw-r--r--dev-python/htmlgen/ChangeLog9
-rw-r--r--dev-python/htmlgen/files/digest-htmlgen-2.2.21
-rw-r--r--dev-python/htmlgen/htmlgen-2.2.2.ebuild38
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/htmlgen/ChangeLog b/dev-python/htmlgen/ChangeLog
new file mode 100644
index 000000000000..52d75d0f9b00
--- /dev/null
+++ b/dev-python/htmlgen/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/htmlgen
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/htmlgen/ChangeLog,v 1.1 2003/03/08 14:47:42 liquidx Exp $
+
+*htmlgen-2.2.2 (08 Mar 2003)
+
+ 08 Mar 2003; Alastair Tse <liquidx@gentoo.org> htmlgen-2.2.2.ebuild:
+ initial ebuild. solves #10653.
+
diff --git a/dev-python/htmlgen/files/digest-htmlgen-2.2.2 b/dev-python/htmlgen/files/digest-htmlgen-2.2.2
new file mode 100644
index 000000000000..38c6f05fd548
--- /dev/null
+++ b/dev-python/htmlgen/files/digest-htmlgen-2.2.2
@@ -0,0 +1 @@
+MD5 cd20f8b63d3215e57289ddbf56c97f48 HTMLgen.tgz 316415
diff --git a/dev-python/htmlgen/htmlgen-2.2.2.ebuild b/dev-python/htmlgen/htmlgen-2.2.2.ebuild
new file mode 100644
index 000000000000..30f904ca5a60
--- /dev/null
+++ b/dev-python/htmlgen/htmlgen-2.2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/htmlgen/htmlgen-2.2.2.ebuild,v 1.1 2003/03/08 14:47:42 liquidx Exp $
+
+IUSE=""
+MY_P="HTMLgen"
+DESCRIPTION="HTMLgen - Python modules for the generation of HTML documents"
+HOMEPAGE="http://starship.python.net/crew/friedrich/HTMLgen/html/main.html"
+SRC_URI="http://starship.python.net/crew/friedrich/${MY_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/python
+ dev-python/Imaging"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ make compileall || die "make failed"
+}
+
+src_install() {
+ PYTHON_VER=$(python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:')
+ # doing this manually because their build scripts suck
+ dodir /usr/lib/python${PYTHON_VER}/site-packages
+ insinto /usr/lib/python${PYTHON_VER}/site-packages
+ doins HTMLgen.py HTMLcolors.py HTMLutil.py HTMLcalendar.py
+ doins barchart.py colorcube.py imgsize.py NavLinks.py
+ doins Formtools.py HTMLgen.pyc HTMLcolors.pyc HTMLutil.pyc
+ doins HTMLcalendar.pyc barchart.pyc colorcube.pyc imgsize.pyc
+ doins NavLinks.pyc Formtools.pyc ImageH.py ImageFileH.py
+ doins ImagePaletteH.py GifImagePluginH.py JpegImagePluginH.py
+ doins PngImagePluginH.py ImageH.pyc ImageFileH.pyc
+ doins ImagePaletteH.pyc GifImagePluginH.pyc JpegImagePluginH.pyc
+ doins PngImagePluginH.pyc
+}