summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-26 13:16:03 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-26 13:16:03 +0000
commit98f83cc81e13d8ec3723df876ea8d8213db385dd (patch)
tree91fde6d8ab1ae1db52d4f2734408ff5f5e0273e0 /dev-python/django-pipeline
parentbump; add py3.4 support (diff)
downloadgentoo-2-98f83cc81e13d8ec3723df876ea8d8213db385dd.tar.gz
gentoo-2-98f83cc81e13d8ec3723df876ea8d8213db385dd.tar.bz2
gentoo-2-98f83cc81e13d8ec3723df876ea8d8213db385dd.zip
bump; add py3 support
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/django-pipeline')
-rw-r--r--dev-python/django-pipeline/ChangeLog8
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.2.9.ebuild4
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.3.16.ebuild46
3 files changed, 55 insertions, 3 deletions
diff --git a/dev-python/django-pipeline/ChangeLog b/dev-python/django-pipeline/ChangeLog
index d082311b1dd0..acff967df221 100644
--- a/dev-python/django-pipeline/ChangeLog
+++ b/dev-python/django-pipeline/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/django-pipeline
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/ChangeLog,v 1.20 2014/04/26 12:25:28 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/ChangeLog,v 1.21 2014/04/26 13:16:03 idella4 Exp $
+
+*django-pipeline-1.3.16 (26 Apr 2014)
+
+ 26 Apr 2014; Ian Delaney <idella4@gentoo.org> +django-pipeline-1.3.16.ebuild,
+ django-pipeline-1.2.9.ebuild:
+ bump; add py3 support
26 Apr 2014; Ian Delaney <idella4@gentoo.org> django-pipeline-1.3.15.ebuild:
fix the ebuild
diff --git a/dev-python/django-pipeline/django-pipeline-1.2.9.ebuild b/dev-python/django-pipeline/django-pipeline-1.2.9.ebuild
index 0d67653fe6d5..1ee3b6f9b12d 100644
--- a/dev-python/django-pipeline/django-pipeline-1.2.9.ebuild
+++ b/dev-python/django-pipeline/django-pipeline-1.2.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.2.9.ebuild,v 1.6 2013/01/21 05:46:14 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.2.9.ebuild,v 1.7 2014/04/26 13:16:03 idella4 Exp $
EAPI=4
PYTHON_DEPEND="2:2.6"
diff --git a/dev-python/django-pipeline/django-pipeline-1.3.16.ebuild b/dev-python/django-pipeline/django-pipeline-1.3.16.ebuild
new file mode 100644
index 000000000000..3fe821850545
--- /dev/null
+++ b/dev-python/django-pipeline/django-pipeline-1.3.16.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.3.16.ebuild,v 1.1 2014/04/26 13:16:03 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="An asset packaging library for Django"
+HOMEPAGE="http://pypi.python.org/pypi/django-pipeline/ https://github.com/cyberdelia/django-pipeline"
+
+# PyPi releases lack docs/ subdir:
+# https://github.com/cyberdelia/django-pipeline/pull/254
+SRC_URI="https://github.com/cyberdelia/django-pipeline/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/django-1.5.5[${PYTHON_USEDEP}]
+ dev-python/jsmin[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? (
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+# As usual for test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH=. django-admin.py test --settings=tests.settings tests \
+ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}