summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2013-05-05 15:09:34 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2013-05-05 15:09:34 +0000
commita4132d407971aa0a42e96d3bc4284edf0ccd86b6 (patch)
treefaf0bd3e581f821508c7a1bd23df6647850f8016 /dev-python/django-auth-ldap
parentBump -6.3 development version (diff)
downloadgentoo-2-a4132d407971aa0a42e96d3bc4284edf0ccd86b6.tar.gz
gentoo-2-a4132d407971aa0a42e96d3bc4284edf0ccd86b6.tar.bz2
gentoo-2-a4132d407971aa0a42e96d3bc4284edf0ccd86b6.zip
Version bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 0x57DC0078)
Diffstat (limited to 'dev-python/django-auth-ldap')
-rw-r--r--dev-python/django-auth-ldap/ChangeLog8
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-1.1.4.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/django-auth-ldap/ChangeLog b/dev-python/django-auth-ldap/ChangeLog
index fe655f4d1f3b..33c9795664d0 100644
--- a/dev-python/django-auth-ldap/ChangeLog
+++ b/dev-python/django-auth-ldap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/django-auth-ldap
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-auth-ldap/ChangeLog,v 1.6 2013/02/03 15:54:20 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-auth-ldap/ChangeLog,v 1.7 2013/05/05 15:09:34 tampakrap Exp $
+
+*django-auth-ldap-1.1.4 (05 May 2013)
+
+ 05 May 2013; Theo Chatzimichos <tampakrap@gentoo.org>
+ +django-auth-ldap-1.1.4.ebuild:
+ Version bump
04 Feb 2013; Ian Delaney <idella4@gentoo.org> metadata.xml:
Correct typo to my email add. in metadata.xml
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-1.1.4.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-1.1.4.ebuild
new file mode 100644
index 000000000000..e835f1fe13e0
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-1.1.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-auth-ldap/django-auth-ldap-1.1.4.ebuild,v 1.1 2013/05/05 15:09:34 tampakrap Exp $
+
+EAPI=4
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="http://pypi.python.org/pypi/django-auth-ldap http://bitbucket.org/psagers/django-auth-ldap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+LICENSE="BSD"
+SLOT="0"
+PYTHON_MODNAME="django_auth_ldap"
+
+RDEPEND=">=dev-python/django-1.0"
+DEPEND="${RDEPEND}
+ dev-python/python-ldap
+ doc? ( dev-python/sphinx )"
+
+src_compile() {
+ distutils_src_compile
+
+ use doc && emake -C docs html
+}
+
+src_test() {
+ export DJANGO_SETTINGS_MODULE="django.conf"
+
+ # Python.[56] trigger a harmless deprecation warning
+ testing() {
+ "$(PYTHON)" -m django_auth_ldap.tests
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html/
+ fi
+}