summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2012-02-22 19:21:11 +0000
committerMatti Bickel <mabi@gentoo.org>2012-02-22 19:21:11 +0000
commitdce447b9e1db909cf352b4ba554ae3c0c9aed95a (patch)
tree87c2d48e26a6dcb5c82a71c2706f16032a7e6a1a /dev-php
parent[bump] dev-perl/Log-Log4perl-1.360.0 (diff)
downloadgentoo-2-dce447b9e1db909cf352b4ba554ae3c0c9aed95a.tar.gz
gentoo-2-dce447b9e1db909cf352b4ba554ae3c0c9aed95a.tar.bz2
gentoo-2-dce447b9e1db909cf352b4ba554ae3c0c9aed95a.zip
version bump
(Portage version: 2.2.0_alpha87/cvs/Linux x86_64)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/smarty/ChangeLog7
-rw-r--r--dev-php/smarty/smarty-3.1.8.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-php/smarty/ChangeLog b/dev-php/smarty/ChangeLog
index c55b727e6fc5..c3cffcbe1801 100644
--- a/dev-php/smarty/ChangeLog
+++ b/dev-php/smarty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/smarty
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.110 2012/01/28 14:24:23 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.111 2012/02/22 19:21:11 mabi Exp $
+
+*smarty-3.1.8 (22 Feb 2012)
+
+ 22 Feb 2012; Matti Bickel <mabi@gentoo.org> +smarty-3.1.8.ebuild:
+ version bump
*smarty-3.1.7 (28 Jan 2012)
diff --git a/dev-php/smarty/smarty-3.1.8.ebuild b/dev-php/smarty/smarty-3.1.8.ebuild
new file mode 100644
index 000000000000..061084cbe5aa
--- /dev/null
+++ b/dev-php/smarty/smarty-3.1.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-3.1.8.ebuild,v 1.1 2012/02/22 19:21:11 mabi Exp $
+
+EAPI=4
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_P="Smarty-${PV}"
+
+DESCRIPTION="A template engine for PHP."
+HOMEPAGE="http://www.smarty.net/"
+SRC_URI="http://www.smarty.net/files/${MY_P}.tar.gz
+ doc? ( http://www.smarty.net/files/docs/manual-en-${PV}.zip )"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-lang/php"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r libs/*
+
+ dodoc *.txt README
+ use doc && dohtml -r "${WORKDIR}/manual-en/"*
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "To use it in your scripts, either"
+ elog "1. define('SMARTY_DIR', \"/usr/share/php/${PN}/\") in your scripts, or"
+ elog "2. add '/usr/share/php/${PN}/' to the 'include_path' variable in your"
+ elog "php.ini file under /etc/php/SAPI (where SAPI is e.g apache2-php5.3,"
+ elog "cgi-php5.3, etc)."
+ elog
+ elog "If you're upgrading from a previous version make sure to clear out your"
+ elog "templates_c and cache directories as some include paths have changed!"
+}