summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-02-10 09:18:30 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-02-10 09:18:30 +0000
commit760cc145a07087b38f34942a0c58d0c6bf7d2f27 (patch)
tree8c6a0a0fa650b6704a1ac06668630d0fc7b19f45 /dev-lisp/cl-araneida
parentx86 for chrpath (diff)
downloadgentoo-2-760cc145a07087b38f34942a0c58d0c6bf7d2f27.tar.gz
gentoo-2-760cc145a07087b38f34942a0c58d0c6bf7d2f27.tar.bz2
gentoo-2-760cc145a07087b38f34942a0c58d0c6bf7d2f27.zip
controler refresh
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-lisp/cl-araneida')
-rw-r--r--dev-lisp/cl-araneida/ChangeLog10
-rw-r--r--dev-lisp/cl-araneida/Manifest4
-rw-r--r--dev-lisp/cl-araneida/cl-araneida-0.9.ebuild36
-rw-r--r--dev-lisp/cl-araneida/files/digest-cl-araneida-0.91
-rw-r--r--dev-lisp/cl-araneida/metadata.xml33
5 files changed, 84 insertions, 0 deletions
diff --git a/dev-lisp/cl-araneida/ChangeLog b/dev-lisp/cl-araneida/ChangeLog
new file mode 100644
index 000000000000..7e5a7563b555
--- /dev/null
+++ b/dev-lisp/cl-araneida/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-araneida
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-araneida/ChangeLog,v 1.1 2005/02/10 09:18:29 mkennedy Exp $
+
+*cl-araneida-0.9 (08 Feb 2005)
+
+ 08 Feb 2005; Matthew Kennedy <mkennedy@gentoo.org> +metadata.xml,
+ +cl-araneida-0.9.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-araneida/Manifest b/dev-lisp/cl-araneida/Manifest
new file mode 100644
index 000000000000..1b9302775657
--- /dev/null
+++ b/dev-lisp/cl-araneida/Manifest
@@ -0,0 +1,4 @@
+MD5 1795c2ecf04c42e3e10f35cd3675e1ef cl-araneida-0.9.ebuild 1069
+MD5 2e8e1d7ffc5c13f7aa8d3f8e849e094e ChangeLog 326
+MD5 bed806f237a48cfeae6c387d74857eae metadata.xml 1334
+MD5 ab9016b24624fad7509736318cfa4fbd files/digest-cl-araneida-0.9 64
diff --git a/dev-lisp/cl-araneida/cl-araneida-0.9.ebuild b/dev-lisp/cl-araneida/cl-araneida-0.9.ebuild
new file mode 100644
index 000000000000..d22143965162
--- /dev/null
+++ b/dev-lisp/cl-araneida/cl-araneida-0.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-araneida/cl-araneida-0.9.ebuild,v 1.1 2005/02/10 09:18:29 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DESCRIPTION="Araneida is small, highly-portable web server for Common Lisp"
+HOMEPAGE="http://www.cliki.net/Araneida"
+SRC_URI="http://www-jcsu.jesus.cam.ac.uk/ftp/pub/cclan/araneida_${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="net-www/apache
+ dev-lisp/cl-split-sequence
+ dev-lisp/cl-net-telent-date"
+
+CLPACKAGE=araneida
+
+S=${WORKDIR}/araneida_${PV}
+
+src_install() {
+ insinto $CLSOURCEROOT/araneida
+ doins *.asd *.lisp NEWS
+ insinto $CLSOURCEROOT/araneida/utility
+ doins utility/*.lisp
+ insinto $CLSOURCEROOT/araneida/compat
+ doins compat/*.lisp
+ insinto $CLSOURCEROOT/araneida/doc
+ doins doc/*.html doc/*.css doc/*.lisp doc/PLAN
+ common-lisp-system-symlink
+ dohtml doc/*.html doc/*.css
+ insinto /usr/share/doc/${PF}/examples/
+ doins doc/*.lisp
+ dodoc doc/*.txt new-dispatch-model
+}
diff --git a/dev-lisp/cl-araneida/files/digest-cl-araneida-0.9 b/dev-lisp/cl-araneida/files/digest-cl-araneida-0.9
new file mode 100644
index 000000000000..2d9677ca665e
--- /dev/null
+++ b/dev-lisp/cl-araneida/files/digest-cl-araneida-0.9
@@ -0,0 +1 @@
+MD5 78459fd3b293a89de198c8b055f1e68c araneida_0.9.tar.gz 199562
diff --git a/dev-lisp/cl-araneida/metadata.xml b/dev-lisp/cl-araneida/metadata.xml
new file mode 100644
index 000000000000..507b7cc7b951
--- /dev/null
+++ b/dev-lisp/cl-araneida/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+Araneida is a fairly small free extensible Web server for SBCL and
+many other Common Lisp implementations. CLiki is an Araneida
+application.
+
+ * Works with or without multiple threads (depending on the lisp
+ implementation). In single-threaded mode, hooks into the event loop
+ so that you still have the top-level available while it listens for
+ connections.
+
+ * Designed to sit behind a caching proxy; can write appropriate bits
+ of Apache config. If this bothers you, pretend that mod_proxy is a
+ typo for mod_araneida. This includes playing nicely with SSL
+
+ * Understands HTTP/1.1 Host: header for multiple host support
+
+ * All content is dynamic and created by calling user-defined
+ handlers (there is a handler in there already that outputs files, if
+ you need it)
+
+ * Pattern-matching tree rewrite functions and HTML-from-sexpr
+ generation makes balancing tags suddenly trivially simple
+
+ * Runs on multiple Lisps. As of version 0.9, these are SBCL, CMUCL,
+ OpenMCL, ABCL, CLisp, Allegro Common Lisp, and LispWorks. MCL is
+ supported in CVS. This makes Araneida the most portable Common Lisp
+ web server.
+</longdescription>
+</pkgmetadata>