summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-03-22 11:30:06 +0000
committerJohannes Huber <johu@gentoo.org>2012-03-22 11:30:06 +0000
commitf6dc700e78fb86c1a71e7c65dc341e4d5c86b191 (patch)
tree42279efd2d55c0a7a5c57dcf37033db0d3d2de95 /dev-libs
parentFix quotation. (diff)
downloadgentoo-2-f6dc700e78fb86c1a71e7c65dc341e4d5c86b191.tar.gz
gentoo-2-f6dc700e78fb86c1a71e7c65dc341e4d5c86b191.tar.bz2
gentoo-2-f6dc700e78fb86c1a71e7c65dc341e4d5c86b191.zip
Fix build if qt-test is not installed and add missing dep on qt-test, fixes bug #409131.
(Portage version: 2.2.0_alpha93/cvs/Linux i686)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/grantlee/ChangeLog7
-rw-r--r--dev-libs/grantlee/files/grantlee-0.1.9-qt-test-optional.patch46
-rw-r--r--dev-libs/grantlee/grantlee-0.1.9.ebuild5
3 files changed, 56 insertions, 2 deletions
diff --git a/dev-libs/grantlee/ChangeLog b/dev-libs/grantlee/ChangeLog
index e522b9695f05..968ca74c5331 100644
--- a/dev-libs/grantlee/ChangeLog
+++ b/dev-libs/grantlee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/grantlee
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/grantlee/ChangeLog,v 1.10 2012/02/23 16:38:31 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/grantlee/ChangeLog,v 1.11 2012/03/22 11:30:06 johu Exp $
+
+ 22 Mar 2012; Johannes Huber <johu@gentoo.org>
+ +files/grantlee-0.1.9-qt-test-optional.patch, grantlee-0.1.9.ebuild:
+ Fix build if qt-test is not installed and add missing dep on qt-test, fixes
+ bug #409131.
23 Feb 2012; Kacper Kowalik <xarthisius@gentoo.org> grantlee-0.1.8.ebuild,
grantlee-0.1.9.ebuild:
diff --git a/dev-libs/grantlee/files/grantlee-0.1.9-qt-test-optional.patch b/dev-libs/grantlee/files/grantlee-0.1.9-qt-test-optional.patch
new file mode 100644
index 000000000000..6af42cbab3fb
--- /dev/null
+++ b/dev-libs/grantlee/files/grantlee-0.1.9-qt-test-optional.patch
@@ -0,0 +1,46 @@
+From ab40a1ce4bff38fe6c19931bcdb46cdf754e29ed Mon Sep 17 00:00:00 2001
+From: Johannes Huber <johu@gentoo.org>
+Date: Thu, 22 Mar 2012 11:37:57 +0100
+Subject: [PATCH] Search only for qt-test if test build option is enabled.
+
+Build fails on systems were no qt-test is installed and the build option
+for tests is disabled. See downstream bug report
+https://bugs.gentoo.org/show_bug.cgi?id=409131.
+---
+ templates/CMakeLists.txt | 6 +++++-
+ textdocument/CMakeLists.txt | 6 +++++-
+ 2 files changed, 10 insertions(+), 2 deletions(-)
+
+diff --git a/templates/CMakeLists.txt b/templates/CMakeLists.txt
+index 0594cc3..eec0f12 100644
+--- a/templates/CMakeLists.txt
++++ b/templates/CMakeLists.txt
+@@ -1,5 +1,9 @@
+
+-find_package(Qt4 4.5.0 REQUIRED QtCore QtScript QtTest)
++if (BUILD_TESTS)
++ find_package(Qt4 4.5.0 REQUIRED QtCore QtScript QtTest)
++else (BUILD_TESTS)
++ find_package(Qt4 4.5.0 REQUIRED QtCore QtScript)
++endif (BUILD_TESTS)
+
+ include(${Grantlee_USE_FILE})
+
+diff --git a/textdocument/CMakeLists.txt b/textdocument/CMakeLists.txt
+index d456663..8fa2892 100644
+--- a/textdocument/CMakeLists.txt
++++ b/textdocument/CMakeLists.txt
+@@ -1,5 +1,9 @@
+
+-find_package(Qt4 4.5.0 REQUIRED QtCore QtGui QtTest)
++if (BUILD_TESTS)
++ find_package(Qt4 4.5.0 REQUIRED QtCore QtScript QtTest)
++else (BUILD_TESTS)
++ find_package(Qt4 4.5.0 REQUIRED QtCore QtScript)
++endif (BUILD_TESTS)
+
+ include(${QT_USE_FILE})
+
+--
+1.7.9.4
+
diff --git a/dev-libs/grantlee/grantlee-0.1.9.ebuild b/dev-libs/grantlee/grantlee-0.1.9.ebuild
index 1916ea63c9dc..74f889dc96ef 100644
--- a/dev-libs/grantlee/grantlee-0.1.9.ebuild
+++ b/dev-libs/grantlee/grantlee-0.1.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/grantlee/grantlee-0.1.9.ebuild,v 1.2 2012/02/23 16:38:31 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/grantlee/grantlee-0.1.9.ebuild,v 1.3 2012/03/22 11:30:06 johu Exp $
EAPI=4
@@ -22,6 +22,7 @@ COMMON_DEPEND="
"
DEPEND="${COMMON_DEPEND}
doc? ( || ( <app-doc/doxygen-1.7.6.1[-nodot] >=app-doc/doxygen-1.7.6.1[dot] ) )
+ test? ( >=x11-libs/qt-test-4.5.0:4 )
"
RDEPEND="${COMMON_DEPEND}"
@@ -30,6 +31,8 @@ DOCS=(AUTHORS CHANGELOG GOALS README)
# Some tests fail
RESTRICT="test"
+PATCHES=( "${FILESDIR}/${P}-qt-test-optional.patch" )
+
src_configure() {
mycmakeargs=(
$(cmake-utils_use_build test TESTS)