summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-30 20:54:08 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-30 20:54:08 +0000
commit86a33b60c15f0c27c8f0d1147ce3f08b27fadd91 (patch)
tree306f733f018250a061b49a870b168d1ccfdbc1c2 /dev-libs
parentKeyword ~mips (diff)
downloadgentoo-2-86a33b60c15f0c27c8f0d1147ce3f08b27fadd91.tar.gz
gentoo-2-86a33b60c15f0c27c8f0d1147ce3f08b27fadd91.tar.bz2
gentoo-2-86a33b60c15f0c27c8f0d1147ce3f08b27fadd91.zip
Enable multilib krb5 support.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openssl/ChangeLog6
-rw-r--r--dev-libs/openssl/openssl-0.9.8y-r1.ebuild7
-rw-r--r--dev-libs/openssl/openssl-1.0.1g-r1.ebuild7
-rw-r--r--dev-libs/openssl/openssl-1.0.2_beta1-r3.ebuild7
4 files changed, 14 insertions, 13 deletions
diff --git a/dev-libs/openssl/ChangeLog b/dev-libs/openssl/ChangeLog
index ce8eaa515584..93da50e7127b 100644
--- a/dev-libs/openssl/ChangeLog
+++ b/dev-libs/openssl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/openssl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.539 2014/05/23 23:13:54 jcallen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.540 2014/05/30 20:54:08 mgorny Exp $
+
+ 30 May 2014; Michał Górny <mgorny@gentoo.org> openssl-0.9.8y-r1.ebuild,
+ openssl-1.0.1g-r1.ebuild, openssl-1.0.2_beta1-r3.ebuild:
+ Enable multilib krb5 support.
*openssl-0.9.8y-r1 (23 May 2014)
diff --git a/dev-libs/openssl/openssl-0.9.8y-r1.ebuild b/dev-libs/openssl/openssl-0.9.8y-r1.ebuild
index 09aa6ea6df9d..c2a21b2eb316 100644
--- a/dev-libs/openssl/openssl-0.9.8y-r1.ebuild
+++ b/dev-libs/openssl/openssl-0.9.8y-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.8y-r1.ebuild,v 1.1 2014/05/23 23:13:54 jcallen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.8y-r1.ebuild,v 1.2 2014/05/30 20:54:08 mgorny Exp $
# this ebuild is only for the libcrypto.so.0.9.8 and libssl.so.0.9.8 SONAME for ABI compat
@@ -19,7 +19,7 @@ IUSE="bindist gmp kerberos sse2 test zlib"
RDEPEND="gmp? ( dev-libs/gmp[${MULTILIB_USEDEP}] )
zlib? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
- kerberos? ( app-crypt/mit-krb5 )
+ kerberos? ( app-crypt/mit-krb5[${MULTILIB_USEDEP}] )
abi_x86_32? (
!<=app-emulation/emul-linux-x86-baselibs-20140508-r4
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
@@ -87,7 +87,6 @@ multilib_src_configure() {
# RC5: 5,724,428 03/03/2015 http://en.wikipedia.org/wiki/RC5
use_ssl() { use $1 && echo "enable-${2:-$1} ${*:3}" || echo "no-${2:-$1}" ; }
- multilib_native_use_ssl() { multilib_native_usex $1 "enable-${2:-$1}" "no-${2:-$1}" " ${*:3}" ; }
echoit() { echo "$@" ; "$@" ; }
local krb5=$(has_version app-crypt/mit-krb5 && echo "MIT" || echo "Heimdal")
@@ -108,7 +107,7 @@ multilib_src_configure() {
$(use_ssl !bindist rc5) \
enable-tlsext \
$(use_ssl gmp gmp -lgmp) \
- $(multilib_native_use_ssl kerberos krb5 --with-krb5-flavor=${krb5}) \
+ $(use_ssl kerberos krb5 --with-krb5-flavor=${krb5}) \
$(use_ssl zlib) \
--prefix=/usr \
--openssldir=/etc/ssl \
diff --git a/dev-libs/openssl/openssl-1.0.1g-r1.ebuild b/dev-libs/openssl/openssl-1.0.1g-r1.ebuild
index 4dba154868b8..3f40ec659155 100644
--- a/dev-libs/openssl/openssl-1.0.1g-r1.ebuild
+++ b/dev-libs/openssl/openssl-1.0.1g-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.1g-r1.ebuild,v 1.3 2014/05/20 06:41:24 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.1g-r1.ebuild,v 1.4 2014/05/30 20:54:08 mgorny Exp $
EAPI="4"
@@ -22,7 +22,7 @@ IUSE="bindist gmp kerberos rfc3779 sse2 static-libs test +tls-heartbeat vanilla
# the future.
RDEPEND="gmp? ( dev-libs/gmp[static-libs(+)?,${MULTILIB_USEDEP}] )
zlib? ( sys-libs/zlib[static-libs(+)?,${MULTILIB_USEDEP}] )
- kerberos? ( app-crypt/mit-krb5 )
+ kerberos? ( app-crypt/mit-krb5[${MULTILIB_USEDEP}] )
abi_x86_32? (
!<=app-emulation/emul-linux-x86-baselibs-20140406-r3
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
@@ -112,7 +112,6 @@ multilib_src_configure() {
# RC5: 5,724,428 03/03/2015 http://en.wikipedia.org/wiki/RC5
use_ssl() { usex $1 "enable-${2:-$1}" "no-${2:-$1}" " ${*:3}" ; }
- multilib_native_use_ssl() { multilib_native_usex $1 "enable-${2:-$1}" "no-${2:-$1}" " ${*:3}" ; }
echoit() { echo "$@" ; "$@" ; }
local krb5=$(has_version app-crypt/mit-krb5 && echo "MIT" || echo "Heimdal")
@@ -145,7 +144,7 @@ multilib_src_configure() {
$(use_ssl !bindist rc5) \
enable-tlsext \
$(use_ssl gmp gmp -lgmp) \
- $(multilib_native_use_ssl kerberos krb5 --with-krb5-flavor=${krb5}) \
+ $(use_ssl kerberos krb5 --with-krb5-flavor=${krb5}) \
$(use_ssl rfc3779) \
$(use_ssl tls-heartbeat heartbeats) \
$(use_ssl zlib) \
diff --git a/dev-libs/openssl/openssl-1.0.2_beta1-r3.ebuild b/dev-libs/openssl/openssl-1.0.2_beta1-r3.ebuild
index 3acbf9a4aa00..45774929a313 100644
--- a/dev-libs/openssl/openssl-1.0.2_beta1-r3.ebuild
+++ b/dev-libs/openssl/openssl-1.0.2_beta1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.2_beta1-r3.ebuild,v 1.3 2014/05/20 06:41:24 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.2_beta1-r3.ebuild,v 1.4 2014/05/30 20:54:08 mgorny Exp $
EAPI="4"
@@ -24,7 +24,7 @@ IUSE="bindist gmp kerberos rfc3779 sse2 static-libs test +tls-heartbeat vanilla
# the future.
RDEPEND="gmp? ( dev-libs/gmp[static-libs(+)?,${MULTILIB_USEDEP}] )
zlib? ( sys-libs/zlib[static-libs(+)?,${MULTILIB_USEDEP}] )
- kerberos? ( app-crypt/mit-krb5 )
+ kerberos? ( app-crypt/mit-krb5[${MULTILIB_USEDEP}] )
abi_x86_32? (
!<=app-emulation/emul-linux-x86-baselibs-20140508
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
@@ -119,7 +119,6 @@ multilib_src_configure() {
# RC5: 5,724,428 03/03/2015 http://en.wikipedia.org/wiki/RC5
use_ssl() { usex $1 "enable-${2:-$1}" "no-${2:-$1}" " ${*:3}" ; }
- multilib_native_use_ssl() { multilib_native_usex $1 "enable-${2:-$1}" "no-${2:-$1}" " ${*:3}" ; }
echoit() { echo "$@" ; "$@" ; }
local krb5=$(has_version app-crypt/mit-krb5 && echo "MIT" || echo "Heimdal")
@@ -152,7 +151,7 @@ multilib_src_configure() {
$(use_ssl !bindist rc5) \
enable-tlsext \
$(use_ssl gmp gmp -lgmp) \
- $(multilib_native_use_ssl kerberos krb5 --with-krb5-flavor=${krb5}) \
+ $(use_ssl kerberos krb5 --with-krb5-flavor=${krb5}) \
$(use_ssl rfc3779) \
$(use_ssl tls-heartbeat heartbeats) \
$(use_ssl zlib) \