summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-06-15 04:07:19 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-06-15 04:07:19 +0000
commit6f83622b8fc3098c3eb4a6b2e61f93c057f4a475 (patch)
tree0077ec01944ea29ed1207efbb78524810f4f7dfe /dev-libs
parentBump to bobotpp-2.2.3 and to EAPI=4. (diff)
downloadgentoo-2-6f83622b8fc3098c3eb4a6b2e61f93c057f4a475.tar.gz
gentoo-2-6f83622b8fc3098c3eb4a6b2e61f93c057f4a475.tar.bz2
gentoo-2-6f83622b8fc3098c3eb4a6b2e61f93c057f4a475.zip
Bump to 3.0.2
(Portage version: 2.2.0_alpha39_p14/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libunique/ChangeLog7
-rw-r--r--dev-libs/libunique/libunique-3.0.2.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-libs/libunique/ChangeLog b/dev-libs/libunique/ChangeLog
index d991af99958f..341caeae2d1f 100644
--- a/dev-libs/libunique/ChangeLog
+++ b/dev-libs/libunique/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libunique
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libunique/ChangeLog,v 1.40 2011/04/29 00:59:09 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libunique/ChangeLog,v 1.41 2011/06/15 04:07:18 nirbheek Exp $
+
+*libunique-3.0.2 (15 Jun 2011)
+
+ 15 Jun 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +libunique-3.0.2.ebuild:
+ Bump to 3.0.2
29 Apr 2011; Jeroen Roovers <jer@gentoo.org> libunique-3.0.0.ebuild:
Marked ~hppa (bug #364693).
diff --git a/dev-libs/libunique/libunique-3.0.2.ebuild b/dev-libs/libunique/libunique-3.0.2.ebuild
new file mode 100644
index 000000000000..7e4215fecbfd
--- /dev/null
+++ b/dev-libs/libunique/libunique-3.0.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libunique/libunique-3.0.2.ebuild,v 1.1 2011/06/15 04:07:19 nirbheek Exp $
+
+EAPI="4"
+GCONF_DEBUF="yes"
+GNOME_TARBALL_SUFFIX="xz"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="a library for writing single instance application"
+HOMEPAGE="http://live.gnome.org/LibUnique"
+
+LICENSE="LGPL-2.1"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-solaris"
+IUSE="doc +introspection"
+
+RDEPEND=">=dev-libs/glib-2.25.7:2
+ >=x11-libs/gtk+-2.90.0:3[introspection?]
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.17
+ doc? ( >=dev-util/gtk-doc-1.13 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
+# For eautoreconf
+# dev-util/gtk-doc-am
+
+pkg_setup() {
+ DOCS="AUTHORS NEWS ChangeLog README TODO"
+ # --disable-dbus means gdbus is used instead of dbus-glib
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-maintainer-flags
+ --disable-dbus
+ $(use_enable introspection)"
+}
+
+src_test() {
+ cd "${S}/tests"
+
+ # Fix environment variable leakage (due to `su` etc)
+ unset DBUS_SESSION_BUS_ADDRESS
+
+ # Force Xemake to use Xvfb, bug 279840
+ unset XAUTHORITY
+ unset DISPLAY
+
+ cp "${FILESDIR}/run-tests" . || die "Unable to cp \${FILESDIR}/run-tests"
+ Xemake -f run-tests || die "Tests failed"
+}