summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-13 08:55:07 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-13 08:55:07 +0000
commit4724a72677f06ce522f6388e6439c731d057e4c3 (patch)
tree4ea4ea0dc6d3c5c204ee539692198fcae7a0396a /dev-libs
parentnew upstream release. (diff)
downloadgentoo-2-4724a72677f06ce522f6388e6439c731d057e4c3.tar.gz
gentoo-2-4724a72677f06ce522f6388e6439c731d057e4c3.tar.bz2
gentoo-2-4724a72677f06ce522f6388e6439c731d057e4c3.zip
touchups
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/opensc/opensc-0.10.0.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/dev-libs/opensc/opensc-0.10.0.ebuild b/dev-libs/opensc/opensc-0.10.0.ebuild
index 4f16b30ae5c4..817eae500740 100644
--- a/dev-libs/opensc/opensc-0.10.0.ebuild
+++ b/dev-libs/opensc/opensc-0.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/opensc/opensc-0.10.0.ebuild,v 1.1 2005/11/12 15:06:19 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/opensc/opensc-0.10.0.ebuild,v 1.2 2005/11/13 08:55:07 vapier Exp $
inherit eutils libtool
@@ -22,7 +22,7 @@ RDEPEND="ldap? ( net-nds/openldap )
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
use X || echo 'all:'$'\n''install:' > src/signer/Makefile.in
EPATCH_SINGLE_MSG="Applying libtool reverse deps patch ..." \
epatch ${ELT_PATCH_DIR}/fix-relink/1.5.0
@@ -33,17 +33,15 @@ src_compile() {
use pcsc-lite \
&& mycard="--with-pcsclite" \
|| mycard="--with-openct=/usr"
+ # --without-plugin-dir generates a /no directory
econf \
--disable-usbtoken \
--with-plugin-dir=/usr/lib/mozilla/plugins \
- `use_enable ldap` \
- `use_with pam` \
+ $(use_enable ldap) \
+ $(use_with pam) \
${mycard} \
|| die
- # --without-plugin-dir generates a /no directory
-
-
emake -j1 || die
}