summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-03-04 11:43:27 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-03-04 11:43:27 +0000
commitf81435e12817fd055e5004c0d71412a23137c07d (patch)
tree34c78ed9a246c1b70336e025018baede5989fbb2 /dev-libs/libindicate
parentdo an out-of-tree build (diff)
downloadgentoo-2-f81435e12817fd055e5004c0d71412a23137c07d.tar.gz
gentoo-2-f81435e12817fd055e5004c0d71412a23137c07d.tar.bz2
gentoo-2-f81435e12817fd055e5004c0d71412a23137c07d.zip
Version bump wrt bug #452232.
(Portage version: 2.1.11.54/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'dev-libs/libindicate')
-rw-r--r--dev-libs/libindicate/ChangeLog11
-rw-r--r--dev-libs/libindicate/libindicate-12.10.1.ebuild66
2 files changed, 74 insertions, 3 deletions
diff --git a/dev-libs/libindicate/ChangeLog b/dev-libs/libindicate/ChangeLog
index 55e1e87def9a..30da14b0daa5 100644
--- a/dev-libs/libindicate/ChangeLog
+++ b/dev-libs/libindicate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libindicate
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libindicate/ChangeLog,v 1.32 2012/07/26 16:36:18 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libindicate/ChangeLog,v 1.33 2013/03/04 11:43:27 kensington Exp $
+
+*libindicate-12.10.1 (04 Mar 2013)
+
+ 04 Mar 2013; Michael Palimaka <kensington@gentoo.org>
+ +libindicate-12.10.1.ebuild:
+ Version bump wrt bug #452232.
26 Jul 2012; Samuli Suominen <ssuominen@gentoo.org>
-libindicate-0.6.1-r201.ebuild, -libindicate-0.6.1-r300.ebuild:
@@ -190,4 +196,3 @@
+libindicate-0.2.3.ebuild,
+files/libindicate-0.2.3-optional-gtk-support.patch, +metadata.xml:
New package, necessary for libindicate-qt (kde team).
-
diff --git a/dev-libs/libindicate/libindicate-12.10.1.ebuild b/dev-libs/libindicate/libindicate-12.10.1.ebuild
new file mode 100644
index 000000000000..2451b453c1ce
--- /dev/null
+++ b/dev-libs/libindicate/libindicate-12.10.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libindicate/libindicate-12.10.1.ebuild,v 1.1 2013/03/04 11:43:27 kensington Exp $
+
+EAPI=5
+
+AYATANA_VALA_VERSION=0.16
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="A library to raise flags on DBus for other components of the desktop to pick up and visualize"
+HOMEPAGE="http://launchpad.net/libindicate"
+SRC_URI="http://launchpad.net/${PN}/${PV%.*}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 LGPL-3"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk +introspection"
+
+RESTRICT="test" # consequence of the -no-mono.patch
+
+RDEPEND=">=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.30
+ >=dev-libs/libdbusmenu-0.6.2:3[gtk?,introspection?]
+ dev-libs/libxml2
+ gtk? ( >=x11-libs/gtk+-3.2:3 )
+ introspection? ( >=dev-libs/gobject-introspection-1 )
+ !<${CATEGORY}/${PN}-0.6.1-r201"
+EAUTORECONF_DEPEND="dev-util/gtk-doc-am
+ gnome-base/gnome-common"
+DEPEND="${RDEPEND}
+ ${EAUTORECONF_DEPEND}
+ app-text/gnome-doc-utils
+ dev-lang/vala:${AYATANA_VALA_VERSION}[vapigen]
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.6.1-no-mono.patch
+ sed -i -e "s:vapigen:vapigen-${AYATANA_VALA_VERSION}:" configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ append-flags -Wno-error
+
+ # python bindings are only for GTK+-2.x
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-silent-rules \
+ --disable-static \
+ $(use_enable gtk) \
+ $(use_enable introspection) \
+ --disable-python \
+ --disable-scrollkeeper \
+ --with-gtk=3 \
+ --with-html-dir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS
+
+ nonfatal dosym /usr/share/doc/${PF}/html/${PN} /usr/share/gtk-doc/html/${PN}
+
+ prune_libtool_files
+}