summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-05-31 10:33:49 +0000
committerPacho Ramos <pacho@gentoo.org>2014-05-31 10:33:49 +0000
commita596d259122d957ac9dd211fdc23d62c9f0cf8b9 (patch)
tree130e8ae03887ab33a0b94916f120875347293bd2 /dev-libs/libgweather
parentNeeds to be rebuilt with libgtop soname bumps (diff)
downloadgentoo-2-a596d259122d957ac9dd211fdc23d62c9f0cf8b9.tar.gz
gentoo-2-a596d259122d957ac9dd211fdc23d62c9f0cf8b9.tar.bz2
gentoo-2-a596d259122d957ac9dd211fdc23d62c9f0cf8b9.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs/libgweather')
-rw-r--r--dev-libs/libgweather/ChangeLog7
-rw-r--r--dev-libs/libgweather/libgweather-3.12.2.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-libs/libgweather/ChangeLog b/dev-libs/libgweather/ChangeLog
index 0a6ff404f322..0924a489a6f2 100644
--- a/dev-libs/libgweather/ChangeLog
+++ b/dev-libs/libgweather/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libgweather
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/ChangeLog,v 1.108 2014/04/27 16:26:24 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/ChangeLog,v 1.109 2014/05/31 10:33:49 pacho Exp $
+
+*libgweather-3.12.2 (31 May 2014)
+
+ 31 May 2014; Pacho Ramos <pacho@gentoo.org> +libgweather-3.12.2.ebuild:
+ Version bump
*libgweather-3.12.1 (27 Apr 2014)
diff --git a/dev-libs/libgweather/libgweather-3.12.2.ebuild b/dev-libs/libgweather/libgweather-3.12.2.ebuild
new file mode 100644
index 000000000000..3581cf5e9e38
--- /dev/null
+++ b/dev-libs/libgweather/libgweather-3.12.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/libgweather-3.12.2.ebuild,v 1.1 2014/05/31 10:33:49 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.18"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Library to access weather information from online services"
+HOMEPAGE="https://wiki.gnome.org/Projects/LibGWeather"
+
+LICENSE="GPL-2+"
+SLOT="2/3-6" # subslot = 3-(libgweather-3 soname suffix)
+IUSE="glade +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+
+COMMON_DEPEND="
+ >=x11-libs/gtk+-2.90.0:3[introspection?]
+ >=dev-libs/glib-2.35.1:2
+ >=net-libs/libsoup-2.34:2.4
+ >=dev-libs/libxml2-2.6.0
+ >=sys-libs/timezone-data-2010k
+
+ glade? ( >=dev-util/glade-3.16:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gnome-applets-2.22.0
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.11
+ >=dev-util/intltool-0.50
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS"
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable glade glade-catalog) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}