summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2010-11-03 07:32:54 +0000
committerKeri Harris <keri@gentoo.org>2010-11-03 07:32:54 +0000
commit330bb5c4410ef693a2a1088b9a64f36ffd3b52ce (patch)
tree6e71293881611b260c648d391041d70da02ca0d5 /dev-lang
parentRemove old beta version (diff)
downloadgentoo-2-330bb5c4410ef693a2a1088b9a64f36ffd3b52ce.tar.gz
gentoo-2-330bb5c4410ef693a2a1088b9a64f36ffd3b52ce.tar.bz2
gentoo-2-330bb5c4410ef693a2a1088b9a64f36ffd3b52ce.zip
Bundle patches into distfiles tarball.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mercury/ChangeLog5
-rw-r--r--dev-lang/mercury/mercury-10.04-r1.ebuild19
2 files changed, 11 insertions, 13 deletions
diff --git a/dev-lang/mercury/ChangeLog b/dev-lang/mercury/ChangeLog
index 1de7ac2359a4..e0eb7ce1f039 100644
--- a/dev-lang/mercury/ChangeLog
+++ b/dev-lang/mercury/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/mercury
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/ChangeLog,v 1.125 2010/11/03 07:10:08 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/ChangeLog,v 1.126 2010/11/03 07:32:54 keri Exp $
+
+ 03 Nov 2010; <keri@gentoo.org> mercury-10.04-r1.ebuild:
+ Bundle patches into distfiles tarball.
03 Nov 2010; <keri@gentoo.org> mercury-10.04.ebuild,
mercury-10.04.1.ebuild, -files/mercury-10.04.1-boehm_gc.patch,
diff --git a/dev-lang/mercury/mercury-10.04-r1.ebuild b/dev-lang/mercury/mercury-10.04-r1.ebuild
index 1526f3471538..759d09eacfdd 100644
--- a/dev-lang/mercury/mercury-10.04-r1.ebuild
+++ b/dev-lang/mercury/mercury-10.04-r1.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-10.04-r1.ebuild,v 1.1 2010/08/22 06:09:57 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/mercury-10.04-r1.ebuild,v 1.2 2010/11/03 07:32:54 keri Exp $
inherit elisp-common eutils flag-o-matic java-pkg-opt-2 multilib
+PATCHSET_VER="0"
MY_P=${PN}-compiler-${PV}
DESCRIPTION="Mercury is a modern general-purpose logic/functional programming language"
HOMEPAGE="http://www.cs.mu.oz.au/research/mercury/index.html"
SRC_URI="http://www.mercury.cs.mu.oz.au/download/files/${MY_P}.tar.gz
+ mirror://gentoo/${P}-gentoo-patchset-${PATCHSET_VER}.tar.gz
test? ( http://www.mercury.cs.mu.oz.au/download/files/mercury-tests-${PV}.tar.gz )"
LICENSE="GPL-2"
@@ -34,23 +36,16 @@ SITEFILE=50${PN}-gentoo.el
src_unpack() {
unpack ${A}
- epatch "${FILESDIR}"/${P}-multilib.patch
- epatch "${FILESDIR}"/${P}-linker-flags.patch
- epatch "${FILESDIR}"/${P}-default-grade.patch
- epatch "${FILESDIR}"/${P}-boehm_gc.patch
- epatch "${FILESDIR}"/${P}-sparc-llds-base-grade.patch
- epatch "${FILESDIR}"/${P}-docs.patch
- epatch "${FILESDIR}"/${P}-no-reconf.patch
+ EPATCH_FORCE=yes
+ EPATCH_SUFFIX=patch
+ epatch "${WORKDIR}"/${PV}
sed -i -e "s/@libdir@/$(get_libdir)/" \
"${S}"/compiler/make.program_target.c \
"${S}"/scripts/Mmake.vars.in
if use test; then
- epatch "${FILESDIR}"/${P}-tests-workspace.patch
- epatch "${FILESDIR}"/${P}-tests-sandbox.patch
- epatch "${FILESDIR}"/${P}-tests-mercury-float.patch
- epatch "${FILESDIR}"/${P}-tests-static-link.patch
+ epatch "${WORKDIR}"/${PV}-tests
fi
}