summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2008-02-14 01:46:08 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2008-02-14 01:46:08 +0000
commit38f45cac2372a1230b91eb8ecaaeea77711abb3d (patch)
tree2a11f075f6b68cbc0132fe8b9a0e2ae0de87ea7d /dev-java/hessian
parentVersion snapshot bump, bug 208566 (diff)
downloadgentoo-2-38f45cac2372a1230b91eb8ecaaeea77711abb3d.tar.gz
gentoo-2-38f45cac2372a1230b91eb8ecaaeea77711abb3d.tar.bz2
gentoo-2-38f45cac2372a1230b91eb8ecaaeea77711abb3d.zip
Ebuild cleanup and fix bug #210060.
(Portage version: 2.1.4.1)
Diffstat (limited to 'dev-java/hessian')
-rw-r--r--dev-java/hessian/ChangeLog11
-rw-r--r--dev-java/hessian/files/build-3.0.8.xml4
-rw-r--r--dev-java/hessian/hessian-3.0.8-r5.ebuild15
3 files changed, 17 insertions, 13 deletions
diff --git a/dev-java/hessian/ChangeLog b/dev-java/hessian/ChangeLog
index 644023dbaa96..a4ac60e8eb26 100644
--- a/dev-java/hessian/ChangeLog
+++ b/dev-java/hessian/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/hessian
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/hessian/ChangeLog,v 1.11 2008/02/14 01:16:18 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/hessian/ChangeLog,v 1.12 2008/02/14 01:46:08 betelgeuse Exp $
+
+ 14 Feb 2008; Petteri Räty <betelgeuse@gentoo.org> files/build-3.0.8.xml,
+ hessian-3.0.8-r5.ebuild:
+ Ebuild cleanup and fix bug #210060.
*hessian-3.0.8-r5 (14 Feb 2008)
@@ -19,6 +23,11 @@
hessian-3.0.8-r4.ebuild:
Shortened DESCRIPTION and removed unused revisions.
+*hessian-3.0.8-r4 (16 Jan 2007)
+
+ 16 Jan 2007; Petteri Räty <betelgeuse@gentoo.org +hessian-3.0.8-r4.ebuild:
+ Fix to compile with 1.5.
+
28 Nov 2006; Joshua Nichols <nichoj@gentoo.org> hessian-3.0.8-r3.ebuild:
Stabilized on amd64 (see bug #155622).
diff --git a/dev-java/hessian/files/build-3.0.8.xml b/dev-java/hessian/files/build-3.0.8.xml
index 4153ebfa4868..d3a85de83b8f 100644
--- a/dev-java/hessian/files/build-3.0.8.xml
+++ b/dev-java/hessian/files/build-3.0.8.xml
@@ -42,9 +42,7 @@
</target>
<target name="javadoc" depends="compile">
- <javadoc destdir="${dist}/doc/api">
- <fileset dir="${src}"/>
- </javadoc>
+ <javadoc destdir="${dist}/doc/api" sourcepath="${src}"/>
</target>
<target name="clean">
diff --git a/dev-java/hessian/hessian-3.0.8-r5.ebuild b/dev-java/hessian/hessian-3.0.8-r5.ebuild
index 7586edd5ccca..65bf599a33b0 100644
--- a/dev-java/hessian/hessian-3.0.8-r5.ebuild
+++ b/dev-java/hessian/hessian-3.0.8-r5.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/hessian/hessian-3.0.8-r5.ebuild,v 1.1 2008/02/14 01:16:18 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/hessian/hessian-3.0.8-r5.ebuild,v 1.2 2008/02/14 01:46:08 betelgeuse Exp $
EAPI=1
+JAVA_PKG_IUSE="doc source"
inherit java-pkg-2 java-ant-2
@@ -13,16 +14,14 @@ SRC_URI="http://www.caucho.com/hessian/download/${P}-src.jar"
LICENSE="Apache-1.1"
SLOT="3.0.8"
KEYWORDS="~amd64 ~x86"
-IUSE="doc source"
+IUSE=""
COMMON_DEP="java-virtuals/servlet-api:2.3
- ~dev-java/caucho-services-${PV}"
+ dev-java/caucho-services:3.0"
RDEPEND=">=virtual/jre-1.4
${COMMON_DEP}"
DEPEND=">=virtual/jdk-1.4
app-arch/unzip
- source? ( app-arch/zip )
- dev-java/ant-core
${COMMON_DEP}"
src_unpack() {
@@ -39,15 +38,13 @@ src_unpack() {
epatch "${FILESDIR}/3.0.8-java5.patch"
# No included ant script! Bad Java developer, bad!
- cp ${FILESDIR}/build-${PV}.xml build.xml
+ cp "${FILESDIR}/build-${PV}.xml" build.xml
# Populate classpath
echo "classpath=$(java-pkg_getjars servlet-api-2.3):$(java-pkg_getjars caucho-services-3.0)" >> build.properties
}
-src_compile() {
- eant -Dproject.name=${PN} jar $(use_doc)
-}
+EANT_EXTRA_ARGS="-Dproject.name=${PN}"
src_install() {
java-pkg_dojar dist/${PN}.jar