summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-07-13 10:45:23 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-07-13 10:45:23 +0000
commite13ac45496a171070dc89ffdfcfd6ece004e6dd6 (patch)
tree471ac2ae78c1af8c91b6bd8210ae2d81a7e6f314 /dev-java/eclipsito
parentUpdated patchset, fixes build failure on FreeBSD 9.1, bug 473364. (diff)
downloadgentoo-2-e13ac45496a171070dc89ffdfcfd6ece004e6dd6.tar.gz
gentoo-2-e13ac45496a171070dc89ffdfcfd6ece004e6dd6.tar.bz2
gentoo-2-e13ac45496a171070dc89ffdfcfd6ece004e6dd6.zip
New ebuild for dev-java/eclipsito, a small subset of Eclipse core libraries for modular applications. Necessary dependency for app-office/ganttproject, see bug #119276. Imported from lh-overlay, contributed by Johann Schmitz (ercpe); slightly adjusted.
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/eclipsito')
-rw-r--r--dev-java/eclipsito/ChangeLog12
-rw-r--r--dev-java/eclipsito/eclipsito-0_pre20130713.ebuild33
-rw-r--r--dev-java/eclipsito/files/eclipsito-0_pre20130713-build.xml36
-rw-r--r--dev-java/eclipsito/metadata.xml5
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-java/eclipsito/ChangeLog b/dev-java/eclipsito/ChangeLog
new file mode 100644
index 000000000000..6c9a89cc0766
--- /dev/null
+++ b/dev-java/eclipsito/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-java/eclipsito
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/eclipsito/ChangeLog,v 1.1 2013/07/13 10:45:23 tomwij Exp $
+
+*eclipsito-0_pre20130713 (13 Jul 2013)
+
+ 13 Jul 2013; Tom Wijsman <TomWij@gentoo.org> +eclipsito-0_pre20130713.ebuild,
+ +files/eclipsito-0_pre20130713-build.xml, +metadata.xml:
+ New ebuild for dev-java/eclipsito, a small subset of Eclipse core libraries
+ for modular applications. Necessary dependency for app-office/ganttproject,
+ see bug #119276. Imported from lh-overlay, contributed by Johann Schmitz
+ (ercpe); slightly adjusted.
diff --git a/dev-java/eclipsito/eclipsito-0_pre20130713.ebuild b/dev-java/eclipsito/eclipsito-0_pre20130713.ebuild
new file mode 100644
index 000000000000..13a0bd3f23e8
--- /dev/null
+++ b/dev-java/eclipsito/eclipsito-0_pre20130713.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/eclipsito/eclipsito-0_pre20130713.ebuild,v 1.1 2013/07/13 10:45:23 tomwij Exp $
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="A small subset of Eclipse core libraries for modular applications."
+HOMEPAGE="https://code.google.com/p/eclipsito/"
+SRC_URI="http://dev.gentoo.org/~tomwij/files/dist/${P}.tar.xz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5"
+
+S="${WORKDIR}/${PN}/org.bardsoftware.${PN}"
+
+java_prepare() {
+ epatch "${FILESDIR}"/${P}-build.xml
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc apidocs
+ use source && java-pkg_dosrc src/
+} \ No newline at end of file
diff --git a/dev-java/eclipsito/files/eclipsito-0_pre20130713-build.xml b/dev-java/eclipsito/files/eclipsito-0_pre20130713-build.xml
new file mode 100644
index 000000000000..c6055e5525c3
--- /dev/null
+++ b/dev-java/eclipsito/files/eclipsito-0_pre20130713-build.xml
@@ -0,0 +1,36 @@
+diff --git a/build.xml b/build.xml
+index d89485a..7be5431 100644
+--- a/build.xml
++++ b/build.xml
+@@ -17,4 +17,31 @@
+ <target depends="build" name="jar">
+ <jar destfile="eclipsito.jar" basedir="bin" compress="yes"/>
+ </target>
++
++ <target name="javadoc" description="Generates the Javadoc of the application">
++ <javadoc sourcepath="src"
++ packagenames="*"
++ destdir="apidocs"
++ access="protected"
++ old="false"
++ verbose="false"
++ encoding="UTF-8"
++ version="true"
++ use="true"
++ author="true"
++ splitindex="false"
++ nodeprecated="false"
++ nodeprecatedlist="false"
++ notree="false"
++ noindex="false"
++ nohelp="false"
++ nonavbar="false"
++ serialwarn="false"
++ charset="ISO-8859-1"
++ docencoding="UTF-8"
++ source="1.5"
++ linksource="true"
++ breakiterator="false">
++ </javadoc>
++ </target>
+ </project>
diff --git a/dev-java/eclipsito/metadata.xml b/dev-java/eclipsito/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/eclipsito/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>