summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-03-10 02:55:18 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-03-10 02:55:18 +0000
commitee8b0fd9c653658637b10b65d5af8a833e226610 (patch)
tree8579d3aa15459f8c111626b47f3c08c92618cd92 /dev-db
parentBump. (diff)
downloadgentoo-2-ee8b0fd9c653658637b10b65d5af8a833e226610.tar.gz
gentoo-2-ee8b0fd9c653658637b10b65d5af8a833e226610.tar.bz2
gentoo-2-ee8b0fd9c653658637b10b65d5af8a833e226610.zip
5.0.56 release, just as a plain version bump from 5.0.54. More patches to follow in -r1.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/ChangeLog8
-rw-r--r--dev-db/mysql/mysql-5.0.56.ebuild104
2 files changed, 111 insertions, 1 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 14706eedb1ac..aa035ba78d5d 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/mysql
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.447 2008/01/28 07:06:09 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.448 2008/03/10 02:55:18 robbat2 Exp $
+
+*mysql-5.0.56 (10 Mar 2008)
+
+ 10 Mar 2008; Robin H. Johnson <robbat2@gentoo.org> +mysql-5.0.56.ebuild:
+ 5.0.56 release, just as a plain version bump from 5.0.54. More patches to
+ follow in -r1.
28 Jan 2008; Jeroen Roovers <jer@gentoo.org> mysql-5.0.54.ebuild:
Stable for HPPA (bug #201669).
diff --git a/dev-db/mysql/mysql-5.0.56.ebuild b/dev-db/mysql/mysql-5.0.56.ebuild
new file mode 100644
index 000000000000..899a85295f30
--- /dev/null
+++ b/dev-db/mysql/mysql-5.0.56.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.56.ebuild,v 1.1 2008/03/10 02:55:18 robbat2 Exp $
+
+MY_EXTRAS_VER="20080310"
+SERVER_URI="http://mirror.provenscaling.com/mysql/enterprise/source/5.0/${P}.tar.gz"
+
+inherit toolchain-funcs mysql
+
+# REMEMBER: also update eclass/mysql*.eclass before committing!
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+# When MY_EXTRAS is bumped, the index should be revised to exclude these.
+EPATCH_EXCLUDE=''
+
+# Please do not add a naive src_unpack to this ebuild
+# If you want to add a single patch, copy the ebuild to an overlay
+# and create your own mysql-extras tarball, looking at 000_index.txt
+
+src_test() {
+ make check || die "make check failed"
+ if ! use "minimal" ; then
+ if ! hasq "userpriv" ${FEATURES} ; then
+ die "Testing with FEATURES=-userpriv is no longer supported by upstream"
+ fi
+ cd "${S}"
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ local retstatus1
+ local retstatus2
+ local t
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ # Ensure that parallel runs don't die
+ export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
+
+ # archive_gis really sucks a lot, but it's only relevant for the
+ # USE=extraengines case
+ case ${PV} in
+ 5.0.42)
+ mysql_disable_test "archive_gis" "Totally broken in 5.0.42"
+ ;;
+
+ 5.0.44|5.0.45|5.0.46|5.0.48|5.0.5[0-6]*)
+ [ "$(tc-endian)" == "big" ] && \
+ mysql_disable_test \
+ "archive_gis" \
+ "Broken in 5.0.44-56 on big-endian boxes only"
+ ;;
+ esac
+
+ # This was a slight testcase breakage when the read_only security issue
+ # was fixed.
+ case ${PV} in
+ 5.0.54|5.0.51*)
+ mysql_disable_test \
+ "read_only" \
+ "Broken in 5.0.51-54, output in wrong order"
+ ;;
+ esac
+
+ # Ditto to read_only
+ [ "${PV}" == "5.0.51a" ] && \
+ mysql_disable_test \
+ "view" \
+ "Broken in 5.0.51, output in wrong order"
+
+ # x86-specific, OOM issue with some subselects on low memory servers
+ [ "${PV}" == "5.0.54" ] && \
+ [ "${ARCH/x86}" != "${ARCH}" ] && \
+ mysql_disable_test \
+ "subselect" \
+ "Testcase needs tuning on x86 for oom condition"
+
+ # Broke with the YaSSL security issue that didn't affect Gentoo.
+ [ "${PV}" == "5.0.56" ] && \
+ for t in openssl_1 rpl_openssl rpl_ssl ssl \
+ ssl_8k_key ssl_compress ssl_connect ; do \
+ mysql_disable_test \
+ "$t" \
+ "OpenSSL tests broken on 5.0.56"
+ done
+
+ # create directories because mysqladmin might right out of order
+ mkdir -p "${S}"/mysql-test/var-{ps,ns}{,/log}
+
+ # We run the test protocols seperately
+ make -j1 test-ns force="--force --vardir=${S}/mysql-test/var-ns"
+ retstatus1=$?
+ [[ $retstatus1 -eq 0 ]] || eerror "test-ns failed"
+
+ make -j1 test-ps force="--force --vardir=${S}/mysql-test/var-ps"
+ retstatus2=$?
+ [[ $retstatus2 -eq 0 ]] || eerror "test-ps failed"
+
+ # Cleanup is important for these testcases.
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+ [[ $retstatus1 -eq 0 ]] || die "test-ns failed"
+ [[ $retstatus2 -eq 0 ]] || die "test-ps failed"
+ einfo "Tests successfully completed"
+ else
+ einfo "Skipping server tests due to minimal build."
+ fi
+}