summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-08-04 10:25:18 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-08-04 10:25:18 +0000
commitff0c81f6cc001e00f32c92e5c79c889c5dc14997 (patch)
treed7037eb0325582319b245643165e834635a5a3b3 /dev-cpp
parentApply patch to build against new boost releases. bug #362913 (diff)
downloadgentoo-2-ff0c81f6cc001e00f32c92e5c79c889c5dc14997.tar.gz
gentoo-2-ff0c81f6cc001e00f32c92e5c79c889c5dc14997.tar.bz2
gentoo-2-ff0c81f6cc001e00f32c92e5c79c889c5dc14997.zip
Append -DBOOST_FILESYSTEM_VERSION=2 to C{XX}FLAGS. Bug #362911
(Portage version: 2.2.0_alpha46/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libxsd-frontend/ChangeLog8
-rw-r--r--dev-cpp/libxsd-frontend/libxsd-frontend-1.17.0.ebuild10
2 files changed, 13 insertions, 5 deletions
diff --git a/dev-cpp/libxsd-frontend/ChangeLog b/dev-cpp/libxsd-frontend/ChangeLog
index 3b33089f26ee..9983a7466c0a 100644
--- a/dev-cpp/libxsd-frontend/ChangeLog
+++ b/dev-cpp/libxsd-frontend/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-cpp/libxsd-frontend
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxsd-frontend/ChangeLog,v 1.1 2010/10/20 06:02:17 dev-zero Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxsd-frontend/ChangeLog,v 1.2 2011/08/04 10:25:18 hwoarang Exp $
+
+ 04 Aug 2011; Markos Chandras <hwoarang@gentoo.org>
+ libxsd-frontend-1.17.0.ebuild:
+ Append -DBOOST_FILESYSTEM_VERSION=2 to C{XX}FLAGS. Bug #362911
*libxsd-frontend-1.17.0 (20 Oct 2010)
diff --git a/dev-cpp/libxsd-frontend/libxsd-frontend-1.17.0.ebuild b/dev-cpp/libxsd-frontend/libxsd-frontend-1.17.0.ebuild
index d2fe709a9975..dd59114a77f1 100644
--- a/dev-cpp/libxsd-frontend/libxsd-frontend-1.17.0.ebuild
+++ b/dev-cpp/libxsd-frontend/libxsd-frontend-1.17.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxsd-frontend/libxsd-frontend-1.17.0.ebuild,v 1.1 2010/10/20 06:02:17 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxsd-frontend/libxsd-frontend-1.17.0.ebuild,v 1.2 2011/08/04 10:25:18 hwoarang Exp $
EAPI="2"
-inherit toolchain-funcs versionator
+inherit flag-o-matic toolchain-funcs versionator
DESCRIPTION="A compiler frontend for the W3C XML Schema definition language."
HOMEPAGE="http://www.codesynthesis.com/projects/libxsd-frontend/"
@@ -21,6 +21,10 @@ RDEPEND=">=dev-libs/xerces-c-3
DEPEND="${RDEPEND}
dev-util/build:0.3"
+src_prepare() {
+ append-flags -DBOOST_FILESYSTEM_VERSION=2
+}
+
src_configure() {
BOOST_PKG="$(best_version ">=dev-libs/boost-1.35.0-r5")"
BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"