summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-07-14 12:06:11 +0000
committerTravis Tilley <lv@gentoo.org>2004-07-14 12:06:11 +0000
commit75d75ee9367f7495aea9ee011ff3424c1540ba3f (patch)
tree23d3de00beb1d7563da541fab490fc5968731c04 /dev-cpp
parentVersion bump; submitted by Jacob Gemmell in bug #47253 (Manifest recommit) (diff)
downloadgentoo-2-75d75ee9367f7495aea9ee011ff3424c1540ba3f.tar.gz
gentoo-2-75d75ee9367f7495aea9ee011ff3424c1540ba3f.tar.bz2
gentoo-2-75d75ee9367f7495aea9ee011ff3424c1540ba3f.zip
gcc 3.4 fix
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libgnomecanvasmm/ChangeLog7
-rw-r--r--dev-cpp/libgnomecanvasmm/files/2.0.1-gcc3.4-after-cvs.patch80
-rw-r--r--dev-cpp/libgnomecanvasmm/files/2.0.1-gcc3.4-to-cvs.patch42
-rw-r--r--dev-cpp/libgnomecanvasmm/libgnomecanvasmm-2.0.1.ebuild19
4 files changed, 141 insertions, 7 deletions
diff --git a/dev-cpp/libgnomecanvasmm/ChangeLog b/dev-cpp/libgnomecanvasmm/ChangeLog
index 2da2b3c9e53e..0367c122b0dd 100644
--- a/dev-cpp/libgnomecanvasmm/ChangeLog
+++ b/dev-cpp/libgnomecanvasmm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/libgnomecanvasmm
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libgnomecanvasmm/ChangeLog,v 1.17 2004/07/13 23:15:29 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libgnomecanvasmm/ChangeLog,v 1.18 2004/07/14 12:06:11 lv Exp $
+
+ 14 Jul 2004; Travis Tilley <lv@gentoo.org>
+ +files/2.0.1-gcc3.4-after-cvs.patch, +files/2.0.1-gcc3.4-to-cvs.patch,
+ libgnomecanvasmm-2.0.1.ebuild:
+ added gcc 3.4 fix from ed catmur
14 Jul 2004; foser <foser@gentoo.org> libgnomecanvasmm-2.0.{0,1}.ebuild :
Fix *mm deps to actually work..
diff --git a/dev-cpp/libgnomecanvasmm/files/2.0.1-gcc3.4-after-cvs.patch b/dev-cpp/libgnomecanvasmm/files/2.0.1-gcc3.4-after-cvs.patch
new file mode 100644
index 000000000000..0bd9f26983cd
--- /dev/null
+++ b/dev-cpp/libgnomecanvasmm/files/2.0.1-gcc3.4-after-cvs.patch
@@ -0,0 +1,80 @@
+Index: ChangeLog
+===================================================================
+RCS file: /cvs/gnome/gnomemm/libgnomecanvasmm/ChangeLog,v
+retrieving revision 1.55.2.2
+diff -u -p -r1.55.2.2 ChangeLog
+--- ChangeLog 2 May 2004 10:06:31 -0000 1.55.2.2
++++ ChangeLog 11 Jul 2004 18:05:21 -0000
+@@ -1,3 +1,7 @@
++2004-07-11 Ed Catmur <ed@catmur.co.uk>
++
++ * examples/canvas_events/canvas_events.cc: use named enum, for gcc 3.4
++
+ 2004-05-01 Takashi Takekawa <takekawa@users.sourceforge.jp>
+
+ * libgnomecanvas/libgnomecanvas.[h,cc] (GNOMEMM_PROPERTY,
+Index: examples/canvas_events/canvas_events.cc
+===================================================================
+RCS file: /cvs/gnome/gnomemm/libgnomecanvasmm/examples/canvas_events/canvas_events.cc,v
+retrieving revision 1.1
+diff -u -p -r1.1 canvas_events.cc
+--- examples/canvas_events/canvas_events.cc 9 Dec 2002 09:41:19 -0000 1.1
++++ examples/canvas_events/canvas_events.cc 11 Jul 2004 18:05:21 -0000
+@@ -14,7 +14,7 @@
+
+ guint32 etime = 0;
+ guint status = 0;
+-enum
++enum someEnum
+ {
+ CE = 0,
+ CEA = 1,
+@@ -42,12 +42,12 @@ public:
+ virtual ~CanvasExample();
+
+ protected:
+- void on_event_explorer_notify(GdkEvent* e, guint caller);
+- void on_button_event_stub_notify(GdkEventButton* e, guint caller);
+- bool on_button_event_stub(GdkEventButton* e, guint caller);
++ void on_event_explorer_notify(GdkEvent* e, someEnum caller);
++ void on_button_event_stub_notify(GdkEventButton* e, someEnum caller);
++ bool on_button_event_stub(GdkEventButton* e, someEnum caller);
+
+ private:
+- bool on_event_explorer(GdkEvent* e, guint caller);
++ bool on_event_explorer(GdkEvent* e, someEnum caller);
+ Gnome::Canvas::Group m_canvasgroup;
+ };
+
+@@ -89,7 +89,7 @@ CanvasExample::~CanvasExample()
+ }
+
+ bool
+-CanvasExample::on_event_explorer(GdkEvent* e, guint caller)
++CanvasExample::on_event_explorer(GdkEvent* e, someEnum caller)
+ {
+ GdkEventButton* b;
+ // Ignore all but button-press events:
+@@ -133,19 +133,19 @@ CanvasExample::on_event_explorer(GdkEven
+ }
+
+ void
+-CanvasExample::on_event_explorer_notify(GdkEvent* e, guint caller)
++CanvasExample::on_event_explorer_notify(GdkEvent* e, someEnum caller)
+ {
+ std::cerr << "on_event_explorer_notify" << std::endl;
+ }
+
+ bool
+-CanvasExample::on_button_event_stub(GdkEventButton* b, guint caller)
++CanvasExample::on_button_event_stub(GdkEventButton* b, someEnum caller)
+ {
+ return on_event_explorer((GdkEvent *) b, caller);
+ }
+
+ void
+-CanvasExample::on_button_event_stub_notify(GdkEventButton* b, guint caller)
++CanvasExample::on_button_event_stub_notify(GdkEventButton* b, someEnum caller)
+ {
+ std::cerr << "on_button_event_stub_notify" << std::endl;
+ }
diff --git a/dev-cpp/libgnomecanvasmm/files/2.0.1-gcc3.4-to-cvs.patch b/dev-cpp/libgnomecanvasmm/files/2.0.1-gcc3.4-to-cvs.patch
new file mode 100644
index 000000000000..01ed843eb709
--- /dev/null
+++ b/dev-cpp/libgnomecanvasmm/files/2.0.1-gcc3.4-to-cvs.patch
@@ -0,0 +1,42 @@
+--- libgnomecanvas/src/line.hg 2004/07/09 08:38:56 1.1
++++ libgnomecanvas/src/line.hg 2004/07/09 08:40:31
+@@ -115,7 +115,7 @@ namespace Glib
+ {
+
+ template <>
+-class Glib::Value<Gnome::Canvas::Points> : public Glib::Value_Boxed<Gnome::Canvas::Points>
++class Value<Gnome::Canvas::Points> : public Value_Boxed<Gnome::Canvas::Points>
+ {
+ public:
+ static GType value_type() G_GNUC_CONST;
+--- libgnomecanvas/libgnomecanvasmm/line.h 2004/07/09 08:42:09 1.1
++++ libgnomecanvas/libgnomecanvasmm/line.h 2004/07/09 08:42:34
+@@ -286,7 +286,7 @@ namespace Glib
+ {
+
+ template <>
+-class Glib::Value<Gnome::Canvas::Points> : public Glib::Value_Boxed<Gnome::Canvas::Points>
++class Value<Gnome::Canvas::Points> : public Value_Boxed<Gnome::Canvas::Points>
+ {
+ public:
+ static GType value_type() G_GNUC_CONST;
+--- ChangeLog 11 Jul 2004 18:10:49 -0000
++++ ChangeLog 2 May 2004 10:06:31 -0000 1.55.2.2
+@@ -1,3 +1,17 @@
++2004-05-01 Takashi Takekawa <takekawa@users.sourceforge.jp>
++
++ * libgnomecanvas/libgnomecanvas.[h,cc] (GNOMEMM_PROPERTY,
++ GNOMEMM_PROPERTY_IMPL): fixed doubled '>' when T is a template class,
++ for the Intel compiler.
++ * libgnomecanvas/src/line.hg: deleted unnecessary namespace
++ qualification, for the Intel compiler.
++
++2003-12-21 Eric Bourque <ericb@computer.org>
++ * libgnomecanvasmm.spec.in: fixed dependency to gtkmm2 instead of gtkmm
++
++2003-09-25 Eric Bourque <ericb@computer.org>
++ * libgnomecanvasmm.spec.in: updated for libgnomecanvasmm-2.0
++
+ 2.0.1:
+
+ 2003-08-22 Murray Cumming <murrayc@usa.net>
diff --git a/dev-cpp/libgnomecanvasmm/libgnomecanvasmm-2.0.1.ebuild b/dev-cpp/libgnomecanvasmm/libgnomecanvasmm-2.0.1.ebuild
index 48bd53c0fd08..70332b95e6b1 100644
--- a/dev-cpp/libgnomecanvasmm/libgnomecanvasmm-2.0.1.ebuild
+++ b/dev-cpp/libgnomecanvasmm/libgnomecanvasmm-2.0.1.ebuild
@@ -1,27 +1,34 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libgnomecanvasmm/libgnomecanvasmm-2.0.1.ebuild,v 1.9 2004/07/13 23:15:29 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libgnomecanvasmm/libgnomecanvasmm-2.0.1.ebuild,v 1.10 2004/07/14 12:06:11 lv Exp $
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="C++ bindings for libgnomecanvasmm"
SRC_URI="mirror://sourceforge/gtkmm/${P}.tar.gz"
HOMEPAGE="http://gtkmm.sourceforge.net/"
IUSE=""
-SLOT="2"
+SLOT="2.0"
LICENSE="LGPL-2.1"
-KEYWORDS="~x86 ppc ~sparc hppa amd64"
+KEYWORDS="~x86 ~ppc ~sparc"
RDEPEND=">=gnome-base/libgnomecanvas-2
- =dev-cpp/gtkmm-2.2*"
+ >=dev-cpp/gtkmm-2.2.5"
DEPEND=">=dev-util/pkgconfig-0.12.0
${RDEPEND}"
DOCS="AUTHORS COPYING ChangeLog NEWS README TODO INSTALL"
+src_unpack() {
+ unpack ${A}
+ cd ${S}; epatch ${FILESDIR}/2.0.1-gcc3.4-to-cvs.patch
+ cd ${S}; epatch ${FILESDIR}/2.0.1-gcc3.4-after-cvs.patch
+}
+
src_compile() {
use amd64 && aclocal -I scripts && automake && autoconf
gnome2_src_compile
}
+