summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2008-12-17 17:52:06 +0000
committerIlya Volynets <iluxa@gentoo.org>2008-12-17 17:52:06 +0000
commit512708644a8a26151c268c58a5bff2fb34db0ead (patch)
tree859f8fdbdb4bb504115f3e340ffc606c804cff41 /dev-cpp/sptk
parentMarking sound-theme-freedesktop-0 ~ppc64 for bug 239847 (diff)
downloadgentoo-2-512708644a8a26151c268c58a5bff2fb34db0ead.tar.gz
gentoo-2-512708644a8a26151c268c58a5bff2fb34db0ead.tar.bz2
gentoo-2-512708644a8a26151c268c58a5bff2fb34db0ead.zip
Add SPTK 3.5.8.8
(Portage version: 2.1.4.5)
Diffstat (limited to 'dev-cpp/sptk')
-rw-r--r--dev-cpp/sptk/ChangeLog8
-rw-r--r--dev-cpp/sptk/sptk-3.5.8.8.ebuild80
2 files changed, 87 insertions, 1 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index d4ccf8ce0523..b5335257cbcf 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,11 +1,17 @@
# ChangeLog for dev-cpp/sptk
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.45 2008/11/21 00:44:39 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.46 2008/12/17 17:52:06 iluxa Exp $
21 Nov 2008; Thomas Anderson <gentoofan23@gentoo.org>
sptk-3.5.7.13.ebuild:
stable amd64, bug 237728
+*sptk-3.5.8.8 (17 Dec 2008)
+
+ 17 Dec 2008; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
+ +sptk-3.5.8.8.ebuild:
+ Add sptk-3.5.8.8
+
15 Nov 2008; Santiago M. Mola <coldwind@gentoo.org> sptk-2.3.28.ebuild,
sptk-3.5.7.13.ebuild, sptk-3.5.8.ebuild, sptk-3.5.8.4.ebuild,
sptk-3.5.8.6.ebuild:
diff --git a/dev-cpp/sptk/sptk-3.5.8.8.ebuild b/dev-cpp/sptk/sptk-3.5.8.8.ebuild
new file mode 100644
index 000000000000..07deb0d1d69b
--- /dev/null
+++ b/dev-cpp/sptk/sptk-3.5.8.8.ebuild
@@ -0,0 +1,80 @@
+# Copyright 2006-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.8.8.ebuild,v 1.1 2008/12/17 17:52:06 iluxa Exp $
+
+EAPI=1
+
+inherit eutils flag-o-matic autotools multilib
+
+IUSE="fltk odbc doc sqlite3 examples excel postgres aspell mysql"
+
+DESCRIPTION="C++ user interface toolkit for X with database and Excel support"
+SRC_URI="http://www.sptk.net/sptk-${PV}.tbz2"
+HOMEPAGE="http://www.sptk.net"
+
+SLOT="3"
+LICENSE="|| ( BSD )"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+RDEPEND="fltk? ( >=x11-libs/fltk-1.1.6:1.1 )
+ odbc? ( >=dev-db/unixODBC-2.2.6 )
+ sqlite3? ( >=dev-db/sqlite-3 )
+ postgres? ( >=virtual/postgresql-base-8.0 )
+ mysql? ( dev-db/mysql )
+ aspell? ( >=app-text/aspell-0.50 )"
+
+DEPEND="${RDEPEND}
+ dev-util/cmake
+ doc? ( app-doc/doxygen )"
+
+check_use() {
+ if use ${1}; then
+ SPTK_OPTIONS="${SPTK_OPTIONS} -DNO_${2}:BOOLEAN=FALSE"
+ else
+ SPTK_OPTIONS="${SPTK_OPTIONS} -DNO_${2}:BOOLEAN=TRUE"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ check_use examples EXAMPLES
+ check_use postgres POSTGRESQL
+ check_use mysql MYSQL
+ check_use sqlite3 SQLITE3
+ check_use odbc ODBC
+ check_use aspell ASPELL
+ check_use fltk FLTK
+ check_use excel EXCEL
+
+ cmake -D CMAKE_INSTALL_PREFIX:PATH=/usr -D LIBDIR=$(get_libdir) ${SPTK_OPTIONS} . || die "Configuration Failed"
+}
+
+src_compile() {
+
+ emake || die "Parallel Make Failed"
+
+ if use doc; then
+ cd "${S}"
+ einfo "Fixing sptk3.doxygen"
+ sed -i -e 's,/cvs/sptk3/,,g' sptk3.doxygen
+ einfo "Building docs"
+ doxygen sptk3.doxygen
+ fi
+
+}
+
+src_install () {
+
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc README AUTHORS
+
+ dodir /usr/share/doc/${PF}
+ cp -r "${S}"/docs/* "${D}"/usr/share/doc/${PF}
+ if use doc; then
+ rm -fr "${D}/usr/share/doc/${PF}/latex"
+ cp -rf "${S}/pictures" "${D}/usr/share/doc/${PF}"
+ fi
+}