summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-04-20 17:55:00 +0000
committerMike Frysinger <vapier@gentoo.org>2012-04-20 17:55:00 +0000
commite16d0d614aa5e9a10220d4d75e1f77efaf8fa10f (patch)
treebcbda8e5cbb8d8ce106490914705765c6a263f9c /dev-cpp/ctemplate
parentInitial impoort. Ebuild initially submitted by Nils Andresen, bug #401325 (diff)
downloadgentoo-2-e16d0d614aa5e9a10220d4d75e1f77efaf8fa10f.tar.gz
gentoo-2-e16d0d614aa5e9a10220d4d75e1f77efaf8fa10f.tar.bz2
gentoo-2-e16d0d614aa5e9a10220d4d75e1f77efaf8fa10f.zip
Version bump.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/ctemplate')
-rw-r--r--dev-cpp/ctemplate/ChangeLog7
-rw-r--r--dev-cpp/ctemplate/ctemplate-2.2.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/dev-cpp/ctemplate/ChangeLog b/dev-cpp/ctemplate/ChangeLog
index 9aece1e2a823..f89a14bb94d6 100644
--- a/dev-cpp/ctemplate/ChangeLog
+++ b/dev-cpp/ctemplate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/ctemplate
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.21 2012/03/07 19:07:34 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.22 2012/04/20 17:55:00 vapier Exp $
+
+*ctemplate-2.2 (20 Apr 2012)
+
+ 20 Apr 2012; Mike Frysinger <vapier@gentoo.org> +ctemplate-2.2.ebuild:
+ Version bump.
07 Mar 2012; Brent Baude <ranger@gentoo.org> ctemplate-2.0.ebuild:
Marking ctemplate-2.0 ppc for bug 394729
diff --git a/dev-cpp/ctemplate/ctemplate-2.2.ebuild b/dev-cpp/ctemplate/ctemplate-2.2.ebuild
new file mode 100644
index 000000000000..1d8fd29cca94
--- /dev/null
+++ b/dev-cpp/ctemplate/ctemplate-2.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ctemplate-2.2.ebuild,v 1.1 2012/04/20 17:55:00 vapier Exp $
+
+EAPI="4"
+
+inherit elisp-common python
+
+DESCRIPTION="A simple but powerful template language for C++"
+HOMEPAGE="http://code.google.com/p/ctemplate/"
+SRC_URI="http://ctemplate.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc emacs vim-syntax static-libs test"
+
+DEPEND="test? ( =dev-lang/python-2* )"
+RDEPEND="vim-syntax? ( >=app-editors/vim-core-7 )
+ emacs? ( virtual/emacs )"
+
+SITEFILE="70ctemplate-gentoo.el"
+
+pkg_setup() {
+ if use test ; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+
+ if use emacs ; then
+ elisp-compile contrib/tpl-mode.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # Installs just every piece
+ rm -rf "${ED}/usr/share/doc"
+
+ dodoc AUTHORS ChangeLog NEWS README
+ use doc && dohtml doc/*
+
+ if use vim-syntax ; then
+ cd "${S}/contrib"
+ sh highlighting.vim || die "unpacking vim scripts failed"
+ insinto /usr/share/vim/vimfiles
+ doins -r .vim/*
+ fi
+
+ if use emacs ; then
+ cd "${S}/contrib"
+ elisp-install ${PN} tpl-mode.el tpl-mode.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}