summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-05-25 06:41:03 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-05-25 06:41:03 +0000
commit27974f7ddb7a47f58da9fa2165df71494c033b46 (patch)
treeae45227c0d905704287cff2b15f2f5ef9322ba21 /dev-cpp/clucene
parentRemove old version. (diff)
downloadgentoo-2-27974f7ddb7a47f58da9fa2165df71494c033b46.tar.gz
gentoo-2-27974f7ddb7a47f58da9fa2165df71494c033b46.tar.bz2
gentoo-2-27974f7ddb7a47f58da9fa2165df71494c033b46.zip
Add static-libs USE flag, conditionally remove libtool files, move to EAPI-2
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/clucene')
-rw-r--r--dev-cpp/clucene/ChangeLog12
-rw-r--r--dev-cpp/clucene/clucene-0.9.21b-r1.ebuild50
2 files changed, 59 insertions, 3 deletions
diff --git a/dev-cpp/clucene/ChangeLog b/dev-cpp/clucene/ChangeLog
index 6d95903b488f..25f1c24930b5 100644
--- a/dev-cpp/clucene/ChangeLog
+++ b/dev-cpp/clucene/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/clucene
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/clucene/ChangeLog,v 1.28 2010/04/30 15:45:45 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/clucene/ChangeLog,v 1.29 2010/05/25 06:41:03 reavertm Exp $
+
+*clucene-0.9.21b-r1 (25 May 2010)
+
+ 25 May 2010; Maciej Mrozowski <reavertm@gentoo.org>
+ +clucene-0.9.21b-r1.ebuild:
+ Add static-libs USE flag, conditionally remove libtool files, move to EAPI-2
30 Apr 2010; Fabian Groffen <grobian@gentoo.org> clucene-0.9.21b.ebuild:
Marked ~ppc-macos
@@ -68,8 +74,8 @@
02 Oct 2007; Wulf C. Krueger <philantrop@gentoo.org> metadata.xml,
-clucene-0.9.15.ebuild, -clucene-0.9.16a.ebuild, -clucene-0.9.17.ebuild,
+clucene-0.9.20.ebuild:
- Version bump to 0.9.20. Fixes bug 179670.
- Removed obsolete versions.
+ Version bump to 0.9.20. Fixes bug 179670.
+ Removed obsolete versions.
Added myself to metadata.xml as the maintainer.
19 Mar 2007; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
diff --git a/dev-cpp/clucene/clucene-0.9.21b-r1.ebuild b/dev-cpp/clucene/clucene-0.9.21b-r1.ebuild
new file mode 100644
index 000000000000..29ece13b2526
--- /dev/null
+++ b/dev-cpp/clucene/clucene-0.9.21b-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/clucene/clucene-0.9.21b-r1.ebuild,v 1.1 2010/05/25 06:41:03 reavertm Exp $
+
+EAPI="2"
+
+inherit eutils
+
+MY_P=${PN}-core-${PV}
+
+DESCRIPTION="High-performance, full-featured text search engine based off of lucene in C++"
+HOMEPAGE="http://clucene.sourceforge.net/"
+SRC_URI="mirror://sourceforge/clucene/${MY_P}.tar.bz2"
+
+LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="debug doc static-libs threads"
+
+DEPEND="doc? ( >=app-doc/doxygen-1.4.2 )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch #254254
+}
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_enable debug cnddebug) \
+ $(use_enable static-libs static) \
+ $(use_enable threads multithreading)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc ; then
+ emake doxygen || die "making docs failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "installation failed"
+ use doc && dohtml "${S}"/doc/html/*
+ if ! use static-libs; then
+ find "${D}" -type f -name '*.la' -exec rm -f {} + \
+ || die "la removal failed"
+ fi
+}