summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2003-10-28 13:07:53 +0000
committerDavid Holm <dholm@gentoo.org>2003-10-28 13:07:53 +0000
commit1ab45792ca561cb1d7af76c980c75e34785c1453 (patch)
treece721a5d634457fb42d369d124e2f8794f675284 /dev-ada
parent*** empty log message *** (diff)
downloadgentoo-2-1ab45792ca561cb1d7af76c980c75e34785c1453.tar.gz
gentoo-2-1ab45792ca561cb1d7af76c980c75e34785c1453.tar.bz2
gentoo-2-1ab45792ca561cb1d7af76c980c75e34785c1453.zip
Masked on systems with GNAT-5.*. Added to ADA_INCLUDE_PATH and ADA_OBJECTS_PATH.
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/adabroker/ChangeLog6
-rw-r--r--dev-ada/adabroker/Manifest4
-rw-r--r--dev-ada/adabroker/adabroker-1.0_pre4.ebuild18
3 files changed, 23 insertions, 5 deletions
diff --git a/dev-ada/adabroker/ChangeLog b/dev-ada/adabroker/ChangeLog
index 0188fd225d35..6db84bd280e2 100644
--- a/dev-ada/adabroker/ChangeLog
+++ b/dev-ada/adabroker/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ada/adabroker
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/adabroker/ChangeLog,v 1.3 2003/10/06 06:57:21 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/adabroker/ChangeLog,v 1.4 2003/10/28 13:07:44 dholm Exp $
+
+ 28 Oct 2003; David Holm <dholm@gentoo.org> adabroker-1.0_pre4.ebuild:
+ Added to ADA_INCLUDE_PATH and ADA_OBJECTS_PATH. Masked on systems with
+ GNAT-5.*.
06 Oct 2003; David Holm <dholm@gentoo.org> adabroker-1.0_pre4.ebuild:
Fixed gnat dependency.
diff --git a/dev-ada/adabroker/Manifest b/dev-ada/adabroker/Manifest
index d1dcc4927280..8c614a9ac9d7 100644
--- a/dev-ada/adabroker/Manifest
+++ b/dev-ada/adabroker/Manifest
@@ -1,4 +1,4 @@
-MD5 bfe522ac41f0c75dd5d4adcf10320983 ChangeLog 634
-MD5 18525b50f747ad0fd4b181e022c9008b adabroker-1.0_pre4.ebuild 2191
+MD5 41ac517b2021ead67f709c294a6ee6f3 ChangeLog 792
+MD5 9fde1df9939779c414fbaf8afa0dab81 adabroker-1.0_pre4.ebuild 2750
MD5 edb2dfe606abb7f8e8e1fdee7f5e5855 metadata.xml 407
MD5 ad5e1f69b3219ffe276383a2132b0ef3 files/digest-adabroker-1.0_pre4 69
diff --git a/dev-ada/adabroker/adabroker-1.0_pre4.ebuild b/dev-ada/adabroker/adabroker-1.0_pre4.ebuild
index 449d2f87ff0f..339ac9c13c46 100644
--- a/dev-ada/adabroker/adabroker-1.0_pre4.ebuild
+++ b/dev-ada/adabroker/adabroker-1.0_pre4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/adabroker/adabroker-1.0_pre4.ebuild,v 1.4 2003/10/06 06:57:21 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/adabroker/adabroker-1.0_pre4.ebuild,v 1.5 2003/10/28 13:07:44 dholm Exp $
inherit gnat
@@ -10,7 +10,7 @@ SRC_URI="http://adabroker.eu.org/distrib/${PN}-1.0pre4.tar.gz"
HOMEPAGE="http://adabroker.eu.org/"
LICENSE="GMGPL"
-DEPEND="dev-lang/gnat"
+DEPEND="<dev-lang/gnat-5.*"
RDEPEND=""
IUSE=""
SLOT="0"
@@ -62,4 +62,18 @@ src_install () {
dosym /usr/lib/ada/adalib/adabroker/libbroca.so /usr/lib
dosym /usr/lib/ada/adalib/adabroker/libbroca.so.0 /usr/lib
dosym /usr/lib/ada/adalib/adabroker/libbroca.so.0.0.0 /usr/lib
+
+ #set up environment
+ dodir /etc/env.d
+ echo "ADA_OBJECTS_PATH=\${ADA_OBJECTS_PATH}:/usr/lib/ada/adalib/${PN}" > ${D}/etc/env.d/55adabroker
+ echo "ADA_INCLUDE_PATH=\${ADA_INCLUDE_PATH}:/usr/lib/ada/adainclude/${PN}" \
+ >> ${D}/etc/env.d/55adabroker
+}
+
+pkg_postinst() {
+ einfo "The envaironment has been set up to make gnat automatically find files for"
+ einfo "AdaBroker. In order to immediately activate these settings please do:"
+ einfo "env-update"
+ einfo "source /etc/profile"
+ einfo "Otherwise the settings will become active next time you login"
}