summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-10-07 08:57:51 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-10-07 08:57:51 +0000
commit88241e728e0a7f91b089ca76320d3d084b2cd44a (patch)
tree9c494b8a15ac9bd6d52dfd5776a6267f76c778b0 /app-text/xdvik
parentDo not register a driver twice. bug #159166 (diff)
downloadgentoo-2-88241e728e0a7f91b089ca76320d3d084b2cd44a.tar.gz
gentoo-2-88241e728e0a7f91b089ca76320d3d084b2cd44a.tar.bz2
gentoo-2-88241e728e0a7f91b089ca76320d3d084b2cd44a.zip
quote a lot of variables, plus add a pkg_postinst message how to activate Emacs support, fixes bug 184259
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-text/xdvik')
-rw-r--r--app-text/xdvik/ChangeLog7
-rw-r--r--app-text/xdvik/xdvik-22.84.10.ebuild45
2 files changed, 33 insertions, 19 deletions
diff --git a/app-text/xdvik/ChangeLog b/app-text/xdvik/ChangeLog
index a5acfc87aeaf..60ac9888dd1b 100644
--- a/app-text/xdvik/ChangeLog
+++ b/app-text/xdvik/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/xdvik
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xdvik/ChangeLog,v 1.39 2007/07/22 10:24:39 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xdvik/ChangeLog,v 1.40 2007/10/07 08:57:51 opfer Exp $
+
+ 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
+ xdvik-22.84.10.ebuild:
+ quote a lot of variables, plus add a pkg_postinst message how to activate
+ Emacs support, fixes bug 184259
22 Jul 2007; Denis Dupeyron <calchan@gentoo.org> xdvik-22.40y-r2.ebuild,
xdvik-22.84.5.ebuild:
diff --git a/app-text/xdvik/xdvik-22.84.10.ebuild b/app-text/xdvik/xdvik-22.84.10.ebuild
index e39863e88f2f..dc3373d6b33b 100644
--- a/app-text/xdvik/xdvik-22.84.10.ebuild
+++ b/app-text/xdvik/xdvik-22.84.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xdvik/xdvik-22.84.10.ebuild,v 1.13 2007/04/22 10:55:31 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xdvik/xdvik-22.84.10.ebuild,v 1.14 2007/10/07 08:57:51 opfer Exp $
WANT_AUTOCONF=2.1
@@ -32,21 +32,21 @@ RDEPEND=">=media-libs/t1lib-5.0.2
!app-text/texlive"
DEPEND="${RDEPEND}"
-pkg_setup() {
- if has_version virtual/tetex && built_with_use virtual/tetex X ; then
- eerror "tetex provides xdvik when built with the X flag."
- eerror "To install this version of xdvik re-install tetex"
- eerror "without the X flag."
- die "xdvik collides with tetex built with the X flag"
- fi
-}
+# pkg_setup() {
+# if has_version virtual/tetex && built_with_use virtual/tetex X ; then
+# eerror "tetex provides xdvik when built with the X flag."
+# eerror "To install this version of xdvik re-install tetex"
+# eerror "without the X flag."
+# die "xdvik collides with tetex built with the X flag"
+# fi
+# }
src_unpack() {
unpack ${P}.tar.gz
cd "${S}"
if use cjk ; then
- epatch ${DISTDIR}/${XDVIK_JP}
- cat >>${S}/texk/xdvik/vfontmap.sample<<-EOF
+ epatch "${DISTDIR}/${XDVIK_JP}"
+ cat >>"${S}/texk/xdvik/vfontmap.sample"<<-EOF
# TrueType fonts
min /usr/share/fonts/kochi-substitute/kochi-mincho-subst.ttf
@@ -92,7 +92,7 @@ src_compile() {
${myconf} || die "econf failed"
cd texk/xdvik
- make texmf=${TEXMF_PATH} || die
+ emake texmf="${TEXMF_PATH}" || die
use emacs && elisp-compile xdvi-search.el
}
@@ -103,13 +103,13 @@ src_install() {
local TEXMF_PATH=$(kpsewhich --expand-var='$TEXMFMAIN')
cd ${S}/texk/xdvik
- einstall texmf=${D}${TEXMF_PATH} || die "install failed"
+ einstall texmf="${D}${TEXMF_PATH}" || die "install failed"
- mv ${D}${TEXMF_PATH}/xdvi/XDvi ${D}etc/X11/app-defaults
- dosym {/etc/X11/app-defaults,${TEXMF_PATH}}/XDvi
- for i in $(find ${D}${TEXMF_PATH}/xdvi -type f -maxdepth 1) ; do
- mv $i ${D}etc/texmf/xdvi
- dosym {/etc/texmf,${TEXMF_PATH}}/xdvi/$(basename $i)
+ mv "${D}${TEXMF_PATH}/xdvi/XDvi" "${D}etc/X11/app-defaults"
+ dosym {/etc/X11/app-defaults,"${TEXMF_PATH}"}/XDvi
+ for i in $(find "${D}${TEXMF_PATH}/xdvi" -type f -maxdepth 1) ; do
+ mv ${i} "${D}etc/texmf/xdvi"
+ dosym {/etc/texmf,"${TEXMF_PATH}"}/xdvi/$(basename ${i})
done
dodoc BUGS FAQ README.*
@@ -121,3 +121,12 @@ src_install() {
use emacs && elisp-install tex-utils *.el *.elc
}
+
+pkg_postinst() {
+ if use emacs; then
+ elog "Add"
+ elog " (add-to-list 'load-path (\"/usr/share/emacs/site-lisp/tex-utils\"))"
+ elog " (require 'xdvi-search)"
+ elog "to your ~/.emacs file"
+ fi
+}