summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-05-02 02:44:35 +0000
committerJon Hood <squinky86@gentoo.org>2004-05-02 02:44:35 +0000
commit6d79c071ecb5f7b5875506a9acf09905c9ae0ffa (patch)
tree9106afcc23abb471be2ce51320f83dbb94655109 /app-text/sword
parentAdded gcc-3.0 notice to pkg_postinstall() (Manifest recommit) (diff)
downloadgentoo-2-6d79c071ecb5f7b5875506a9acf09905c9ae0ffa.tar.gz
gentoo-2-6d79c071ecb5f7b5875506a9acf09905c9ae0ffa.tar.bz2
gentoo-2-6d79c071ecb5f7b5875506a9acf09905c9ae0ffa.zip
gcc-3.4 compile-time fix from Robert Moss irt #48523
Diffstat (limited to 'app-text/sword')
-rw-r--r--app-text/sword/ChangeLog7
-rw-r--r--app-text/sword/files/sword-gcc34-gentoo.patch19
-rw-r--r--app-text/sword/sword-1.5.7.ebuild3
3 files changed, 26 insertions, 3 deletions
diff --git a/app-text/sword/ChangeLog b/app-text/sword/ChangeLog
index a4453ae6ba19..a80fac57bcf5 100644
--- a/app-text/sword/ChangeLog
+++ b/app-text/sword/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for app-text/sword
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sword/ChangeLog,v 1.12 2004/04/08 22:11:14 squinky86 Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sword/ChangeLog,v 1.13 2004/05/02 02:44:35 squinky86 Exp $
+ 01 May 2004; Jon Hood <squinky86@gentoo.org>
+ +files/sword-gcc34-gentoo.patch, sword-1.5.7.ebuild:
+ gcc3.4 compile time patch from Robert Moss <robert.moss@jesus.ox.ac.uk>
*sword-1.5.7 (05 Apr 2004)
diff --git a/app-text/sword/files/sword-gcc34-gentoo.patch b/app-text/sword/files/sword-gcc34-gentoo.patch
new file mode 100644
index 000000000000..bf0869f9cb20
--- /dev/null
+++ b/app-text/sword/files/sword-gcc34-gentoo.patch
@@ -0,0 +1,19 @@
+--- include/multimapwdef.h.old 2004-04-29 04:22:07.516715976 +0100
++++ include/multimapwdef.h 2004-04-29 04:22:20.051810352 +0100
+@@ -12,14 +12,14 @@
+ public:
+ typedef std::pair<const Key, T> value_type;
+ T& getWithDefault(const Key& k, const T& defaultValue) {
+- if (find(k) == end()) {
++ if (find(k) == this->end()) {
+ insert(value_type(k, defaultValue));
+ }
+ return (*(find(k))).second;
+ }
+
+ T& operator[](const Key& k) {
+- if (find(k) == end()) {
++ if (find(k) == this->end()) {
+ insert(value_type(k, T()));
+ }
+ return (*(find(k))).second;
diff --git a/app-text/sword/sword-1.5.7.ebuild b/app-text/sword/sword-1.5.7.ebuild
index 2994c8907ab3..10f057c6aeed 100644
--- a/app-text/sword/sword-1.5.7.ebuild
+++ b/app-text/sword/sword-1.5.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sword/sword-1.5.7.ebuild,v 1.4 2004/04/08 22:11:14 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sword/sword-1.5.7.ebuild,v 1.5 2004/05/02 02:44:35 squinky86 Exp $
inherit eutils
@@ -22,6 +22,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${PN}-installmgr-gentoo.patch
+ epatch ${FILESDIR}/${PN}-gcc34-gentoo.patch
}
src_compile() {