summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-08-23 01:17:53 +0000
committerMike Frysinger <vapier@gentoo.org>2012-08-23 01:17:53 +0000
commite5a3831e2407e1ea7fe118929697f92d2b3ba622 (patch)
treea251d962c2775c2e507d1c6c818b69ded86ea590 /app-shells
parentVersion bump, remove old. (diff)
downloadgentoo-2-e5a3831e2407e1ea7fe118929697f92d2b3ba622.tar.gz
gentoo-2-e5a3831e2407e1ea7fe118929697f92d2b3ba622.tar.bz2
gentoo-2-e5a3831e2407e1ea7fe118929697f92d2b3ba622.zip
Disable readline-specific options in bashrc when USE=-readline #432338 by Agostino Sarubbo.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog6
-rw-r--r--app-shells/bash/bash-4.2_p37.ebuild18
2 files changed, 20 insertions, 4 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 6300ce2830c7..b43aeb56cc15 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.319 2012/08/20 02:46:57 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.320 2012/08/23 01:17:53 vapier Exp $
+
+ 23 Aug 2012; Mike Frysinger <vapier@gentoo.org> bash-4.2_p37.ebuild:
+ Disable readline-specific options in bashrc when USE=-readline #432338 by
+ Agostino Sarubbo.
20 Aug 2012; Jeroen Roovers <jer@gentoo.org> bash-4.2_p37.ebuild:
Stable for HPPA (bug #431850).
diff --git a/app-shells/bash/bash-4.2_p37.ebuild b/app-shells/bash/bash-4.2_p37.ebuild
index e54eff9c3af1..94e418d432a1 100644
--- a/app-shells/bash/bash-4.2_p37.ebuild
+++ b/app-shells/bash/bash-4.2_p37.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.2_p37.ebuild,v 1.5 2012/08/20 02:46:57 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.2_p37.ebuild,v 1.6 2012/08/23 01:17:53 vapier Exp $
EAPI="1"
@@ -151,8 +151,20 @@ src_install() {
newins "${FILESDIR}"/dot-${f} .${f}
done
- sed -i -e "s:#${USERLAND}#@::" "${D}"/etc/skel/.bashrc "${D}"/etc/bash/bashrc
- sed -i -e '/#@/d' "${D}"/etc/skel/.bashrc "${D}"/etc/bash/bashrc
+ local sed_args=(
+ -e "s:#${USERLAND}#@::"
+ -e '/#@/d'
+ )
+ if ! use readline ; then
+ sed_args+=( #432338
+ -e '/^shopt -s histappend/s:^:#:'
+ -e 's:use_color=true:use_color=false:'
+ )
+ fi
+ sed -i \
+ "${sed_args[@]}" \
+ "${D}"/etc/skel/.bashrc \
+ "${D}"/etc/bash/bashrc || die
if use plugins ; then
exeinto /usr/$(get_libdir)/bash