summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-12-01 17:29:36 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-12-01 17:29:36 +0000
commitc7c09e778da3c38947c70260d781cdf22917460d (patch)
tree12919e8943e540b3573a936d4524b381b3ade440 /app-shells/bash-completion
parentProxy commit, see ChangeLog for details (diff)
downloadgentoo-2-c7c09e778da3c38947c70260d781cdf22917460d.tar.gz
gentoo-2-c7c09e778da3c38947c70260d781cdf22917460d.tar.bz2
gentoo-2-c7c09e778da3c38947c70260d781cdf22917460d.zip
Revbump for minor ommision in bash-completion.sh file which didn't clean up the env properly. bug 293871
(Portage version: 2.1.7.4/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/bash-completion')
-rw-r--r--app-shells/bash-completion/ChangeLog10
-rw-r--r--app-shells/bash-completion/bash-completion-1.1-r4.ebuild (renamed from app-shells/bash-completion/bash-completion-1.1-r3.ebuild)2
-rw-r--r--app-shells/bash-completion/files/bash-completion.sh3
3 files changed, 12 insertions, 3 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index 7ea8b1b5877b..abf55333058e 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-shells/bash-completion
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.198 2009/11/11 15:14:55 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.199 2009/12/01 17:29:36 darkside Exp $
+
+*bash-completion-1.1-r4 (01 Dec 2009)
+
+ 01 Dec 2009; Jeremy Olexa <darkside@gentoo.org>
+ -bash-completion-1.1-r3.ebuild, +bash-completion-1.1-r4.ebuild,
+ files/bash-completion.sh:
+ Revbump for minor ommision in bash-completion.sh file which didn't clean
+ up the env properly. bug 293871
11 Nov 2009; Fabian Groffen <grobian@gentoo.org>
bash-completion-1.1-r3.ebuild:
diff --git a/app-shells/bash-completion/bash-completion-1.1-r3.ebuild b/app-shells/bash-completion/bash-completion-1.1-r4.ebuild
index b2e1e91cb17c..5e187244d442 100644
--- a/app-shells/bash-completion/bash-completion-1.1-r3.ebuild
+++ b/app-shells/bash-completion/bash-completion-1.1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-1.1-r3.ebuild,v 1.2 2009/11/11 15:14:55 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-1.1-r4.ebuild,v 1.1 2009/12/01 17:29:36 darkside Exp $
EAPI="2"
inherit prefix
diff --git a/app-shells/bash-completion/files/bash-completion.sh b/app-shells/bash-completion/files/bash-completion.sh
index 7f8896921b43..6ce5313f2fa7 100644
--- a/app-shells/bash-completion/files/bash-completion.sh
+++ b/app-shells/bash-completion/files/bash-completion.sh
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/files/bash-completion.sh,v 1.6 2009/10/16 03:01:10 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/files/bash-completion.sh,v 1.7 2009/12/01 17:29:36 darkside Exp $
# Check for interactive bash and that we haven't already been sourced.
[ -z "$BASH_VERSION" -o -z "$PS1" -o -n "$BASH_COMPLETION" ] && return
@@ -32,6 +32,7 @@ if [ $bmajor -eq 2 -a $bminor '>' 04 ] || [ $bmajor -gt 2 ]; then
done
# Clean up
+ $loaded_pre && source /usr/share/bash-completion/.post
unset -f _load_completions # not designed to be called more than once
}