summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-01-11 17:39:57 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-01-11 17:39:57 +0000
commit5b1ae2fcca5b7c510ae49311572b6d9d029aeae8 (patch)
treed458cd96dd74725a65b68cc08fe6d0508d119b35 /app-shells/bash-completion
parentRemove usage of deprecated kde.eclass (diff)
downloadgentoo-2-5b1ae2fcca5b7c510ae49311572b6d9d029aeae8.tar.gz
gentoo-2-5b1ae2fcca5b7c510ae49311572b6d9d029aeae8.tar.bz2
gentoo-2-5b1ae2fcca5b7c510ae49311572b6d9d029aeae8.zip
Style changes and fix for trying to source a file outside of the EPREFIX. bug 300582, comment #2
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/bash-completion')
-rw-r--r--app-shells/bash-completion/ChangeLog6
-rw-r--r--app-shells/bash-completion/files/bash-completion.sh12
2 files changed, 11 insertions, 7 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index f634174d3721..a96bc9c81605 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/bash-completion
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.209 2010/01/09 15:12:05 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.210 2010/01/11 17:39:56 darkside Exp $
+
+ 11 Jan 2010; Jeremy Olexa <darkside@gentoo.org> files/bash-completion.sh:
+ Style changes and fix for trying to source a file outside of the EPREFIX.
+ bug 300582, comment #2
09 Jan 2010; Alexis Ballier <aballier@gentoo.org>
bash-completion-1.1-r5.ebuild:
diff --git a/app-shells/bash-completion/files/bash-completion.sh b/app-shells/bash-completion/files/bash-completion.sh
index 6ce5313f2fa7..3487d5ac0fa1 100644
--- a/app-shells/bash-completion/files/bash-completion.sh
+++ b/app-shells/bash-completion/files/bash-completion.sh
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/files/bash-completion.sh,v 1.7 2009/12/01 17:29:36 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/files/bash-completion.sh,v 1.8 2010/01/11 17:39:57 darkside Exp $
# Check for interactive bash and that we haven't already been sourced.
[ -z "$BASH_VERSION" -o -z "$PS1" -o -n "$BASH_COMPLETION" ] && return
@@ -21,9 +21,9 @@ if [ $bmajor -eq 2 -a $bminor '>' 04 ] || [ $bmajor -gt 2 ]; then
# in .pre. See the ebuild for how this is created.
if ! $loaded_pre; then
if [[ ${BASH_COMPLETION-unset} == unset ]]; then
- BASH_COMPLETION="@GENTOO_PORTAGE_EPREFIX@"/usr/share/bash-completion/base
+ BASH_COMPLETION="@GENTOO_PORTAGE_EPREFIX@/usr/share/bash-completion/base"
fi
- source "@GENTOO_PORTAGE_EPREFIX@"/usr/share/bash-completion/.pre
+ source "@GENTOO_PORTAGE_EPREFIX@/usr/share/bash-completion/.pre"
loaded_pre=true
fi
@@ -32,7 +32,7 @@ if [ $bmajor -eq 2 -a $bminor '>' 04 ] || [ $bmajor -gt 2 ]; then
done
# Clean up
- $loaded_pre && source /usr/share/bash-completion/.post
+ $loaded_pre && source "@GENTOO_PORTAGE_EPREFIX@/usr/share/bash-completion/.post"
unset -f _load_completions # not designed to be called more than once
}
@@ -43,9 +43,9 @@ if [ $bmajor -eq 2 -a $bminor '>' 04 ] || [ $bmajor -gt 2 ]; then
# 4. Load user completion file last, overrides modules at user discretion
# This order is subject to change once upstream decides on something.
_load_completions \
- "@GENTOO_PORTAGE_EPREFIX@"/etc/bash_completion.d/base \
+ "@GENTOO_PORTAGE_EPREFIX@/etc/bash_completion.d/base" \
~/.bash_completion.d/base \
- "@GENTOO_PORTAGE_EPREFIX@"/etc/bash_completion.d/* \
+ "@GENTOO_PORTAGE_EPREFIX@/etc/bash_completion.d/"* \
~/.bash_completion.d/* \
~/.bash_completion
fi