summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Jackson <iggy@gentoo.org>2004-10-04 03:22:56 +0000
committerBrian Jackson <iggy@gentoo.org>2004-10-04 03:22:56 +0000
commit556d9760a920b35148285723ea50e20bf426a91e (patch)
tree4cd02138f0719591ea3d7d294a404d0690406def /app-sci/comedi
parentversion bump (diff)
downloadgentoo-2-556d9760a920b35148285723ea50e20bf426a91e.tar.gz
gentoo-2-556d9760a920b35148285723ea50e20bf426a91e.tar.bz2
gentoo-2-556d9760a920b35148285723ea50e20bf426a91e.zip
switched custom ARCH setting code to use set_arch_to_* from eutils
Diffstat (limited to 'app-sci/comedi')
-rw-r--r--app-sci/comedi/ChangeLog5
-rw-r--r--app-sci/comedi/comedi-0.7.68.ebuild17
2 files changed, 9 insertions, 13 deletions
diff --git a/app-sci/comedi/ChangeLog b/app-sci/comedi/ChangeLog
index bcf3acae6236..5f2d94cfbdb5 100644
--- a/app-sci/comedi/ChangeLog
+++ b/app-sci/comedi/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-sci/comedi
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/comedi/ChangeLog,v 1.3 2004/06/24 21:55:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/comedi/ChangeLog,v 1.4 2004/10/04 03:22:56 iggy Exp $
+
+ 03 Oct 2004; <iggy@gentoo.org> comedi-0.7.68.ebuild:
+ switched custom ARCH setting code to use set_arch_to_* from eutils
*comedi-0.7.68 (01 Mar 2004)
diff --git a/app-sci/comedi/comedi-0.7.68.ebuild b/app-sci/comedi/comedi-0.7.68.ebuild
index d7bff76680c8..3a715f475125 100644
--- a/app-sci/comedi/comedi-0.7.68.ebuild
+++ b/app-sci/comedi/comedi-0.7.68.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/comedi/comedi-0.7.68.ebuild,v 1.3 2004/07/13 20:27:36 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/comedi/comedi-0.7.68.ebuild,v 1.4 2004/10/04 03:22:56 iggy Exp $
-inherit kernel-mod
+inherit kernel-mod eutils
DESCRIPTION="Comedi - COntrol and MEasurement Device Interface for Linux"
SRC_URI="ftp://ftp.comedi.org/pub/comedi/${P}.tar.gz"
@@ -18,20 +18,13 @@ src_compile()
addpredict ${KERNEL_DIR}
- # The stuff below is taken from the kernel's Makefile. The problem here is that
- # we need the ARCH variable to be set to what the kernel is expecting, but the Gento
- # build system overrides it, so we'll force it to what the kernel wants for the
- # compilation phase.
-
- LOCALARCH=$(uname -m | sed -e s/i.86/i386/ -e s/sun4u/sparc64/ \
- -e s/arm.*/arm/ -e s/sa110/arm/ \
- -e s/s390x/s390/ -e s/parisc64/parisc/ )
-
- ARCH=${LOCALARCH} ./configure --prefix=${D}/usr --libdir=${D}/lib --with-linuxdir=${KERNEL_DIR}
+ set_arch_to_kernel
+ ./configure --prefix=${D}/usr --libdir=${D}/lib --with-linuxdir=${KERNEL_DIR}
emake
}
src_install()
{
make install
+ set_arch_to_portage
}