summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2009-05-23 08:22:08 +0000
committerZac Medico <zmedico@gentoo.org>2009-05-23 08:22:08 +0000
commitc54abf44f195cd2c40597828881aa1df8e9e8667 (patch)
treec718daa02d0fbb3e3b90fa67f75eacfe6dcb8e36 /app-pda/libsyncml
parentVersion bump, bug #217388. Fixes also #184375 and #213391. Many thanks to Jam... (diff)
downloadgentoo-2-c54abf44f195cd2c40597828881aa1df8e9e8667.tar.gz
gentoo-2-c54abf44f195cd2c40597828881aa1df8e9e8667.tar.bz2
gentoo-2-c54abf44f195cd2c40597828881aa1df8e9e8667.zip
23 May 2009; Zac Medico <zmedico@gentoo.org> +libsyncml-0.4.6-r1.ebuild:
Change bluez-libs dep to bluez. This is useful if rolling back from 0.5.2 due to packages not building against it. (Portage version: 2.2_rc33_p13615/cvs/Linux i686)
Diffstat (limited to 'app-pda/libsyncml')
-rw-r--r--app-pda/libsyncml/ChangeLog8
-rw-r--r--app-pda/libsyncml/libsyncml-0.4.6-r1.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/app-pda/libsyncml/ChangeLog b/app-pda/libsyncml/ChangeLog
index 0f34f35e0789..17923bc76a45 100644
--- a/app-pda/libsyncml/ChangeLog
+++ b/app-pda/libsyncml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/libsyncml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/ChangeLog,v 1.13 2009/03/20 14:42:43 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/ChangeLog,v 1.14 2009/05/23 08:22:08 zmedico Exp $
+
+*libsyncml-0.4.6-r1 (23 May 2009)
+
+ 23 May 2009; Zac Medico <zmedico@gentoo.org> +libsyncml-0.4.6-r1.ebuild:
+ Change bluez-libs dep to bluez. This is useful if rolling back from 0.5.2
+ due to packages not building against it.
*libsyncml-0.5.2 (20 Mar 2009)
diff --git a/app-pda/libsyncml/libsyncml-0.4.6-r1.ebuild b/app-pda/libsyncml/libsyncml-0.4.6-r1.ebuild
new file mode 100644
index 000000000000..a8fe14a774ea
--- /dev/null
+++ b/app-pda/libsyncml/libsyncml-0.4.6-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/libsyncml-0.4.6-r1.ebuild,v 1.1 2009/05/23 08:22:08 zmedico Exp $
+
+EAPI="1"
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Implementation of the SyncML protocol"
+HOMEPAGE="http://libsyncml.opensync.org/"
+SRC_URI="http://libsyncml.opensync.org/download/releases/${PV}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="bluetooth +debug doc http +obex"
+
+RDEPEND=">=dev-libs/glib-2.0
+ >=dev-libs/libwbxml-0.9.2
+ dev-libs/libxml2
+ http? ( >=net-libs/libsoup-2.2.91:2.2 )
+ obex? ( >=dev-libs/openobex-1.1 )
+ bluetooth? ( net-wireless/bluez )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+# Some of the tests are broken
+RESTRICT="test"
+
+pkg_setup() {
+ if ! use obex && ! use http; then
+ eerror "${CATEGORY}/${P} without support for obex nor http is unusable."
+ eerror "Please enable \"obex\" or/and \"http\" USE flags."
+ die "Please enable \"obex\" or/and \"http\" USE flags."
+ fi
+
+ if use bluetooth; then
+ if use obex && ! built_with_use dev-libs/openobex bluetooth; then
+ eerror "You are trying to build ${CATEGORY}/${P} with the \"bluetooth\""
+ eerror "and \"obex\" USE flags, but dev-libs/openobex was built without"
+ eerror "the \"bluetooth\" USE flag."
+ eerror "Please rebuild dev-libs/openobex with \"bluetooth\" USE flag."
+ die "Please rebuild dev-libs/openobex with \"bluetooth\" USE flag."
+ elif ! use obex; then
+ eerror "You are trying to build ${CATEGORY}/${P} with the \"bluetooth\""
+ eerror "USE flag, but you didn't enable the \"obex\" flag, which is"
+ eerror "needed for bluetooth support."
+ eerror "Please enable \"obex\" USE flag."
+ die "Please enable \"obex\" USE flag."
+ fi
+ fi
+}
+
+src_compile() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable http HTTP)
+ $(cmake-utils_use_enable obex OBEX)
+ $(cmake-utils_use_enable bluetooth BLUETOOTH)
+ $(cmake-utils_use_enable debug TRACE)"
+
+ cmake-utils_src_compile
+}