summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2010-05-28 16:08:00 +0000
committerThilo Bangert <bangert@gentoo.org>2010-05-28 16:08:00 +0000
commit7473cc3b2321b0ea62dd643117aa365cdead28e8 (patch)
tree78a81d8f29a469a50b1450599927dcf90dbe981b /app-pda/ifuse
parentConvert to ruby-ng. (diff)
downloadgentoo-2-7473cc3b2321b0ea62dd643117aa365cdead28e8.tar.gz
gentoo-2-7473cc3b2321b0ea62dd643117aa365cdead28e8.tar.bz2
gentoo-2-7473cc3b2321b0ea62dd643117aa365cdead28e8.zip
version bump (#311089)
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'app-pda/ifuse')
-rw-r--r--app-pda/ifuse/ChangeLog9
-rw-r--r--app-pda/ifuse/ifuse-1.0.0.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/app-pda/ifuse/ChangeLog b/app-pda/ifuse/ChangeLog
index e80c2bc93b45..c6adda229e9b 100644
--- a/app-pda/ifuse/ChangeLog
+++ b/app-pda/ifuse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-pda/ifuse
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/ifuse/ChangeLog,v 1.2 2009/12/14 23:26:24 chainsaw Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/ifuse/ChangeLog,v 1.3 2010/05/28 16:08:00 bangert Exp $
+
+*ifuse-1.0.0 (28 May 2010)
+
+ 28 May 2010; Thilo Bangert <bangert@gentoo.org> +ifuse-1.0.0.ebuild:
+ version bump (#311089)
*ifuse-0.9.5 (14 Dec 2009)
diff --git a/app-pda/ifuse/ifuse-1.0.0.ebuild b/app-pda/ifuse/ifuse-1.0.0.ebuild
new file mode 100644
index 000000000000..c563720aca08
--- /dev/null
+++ b/app-pda/ifuse/ifuse-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/ifuse/ifuse-1.0.0.ebuild,v 1.1 2010/05/28 16:08:00 bangert Exp $
+
+EAPI=3
+
+DESCRIPTION="Mount Apple iPhone/iPod Touch file systems for backup purposes"
+HOMEPAGE="http://libimobiledevice.org/"
+SRC_URI="http://cloud.github.com/downloads/MattColyer/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-pda/libplist-1.3
+ >=app-pda/libimobiledevice-1.0.1
+ =dev-libs/glib-2*
+ sys-fs/fuse"
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README
+}
+
+pkg_postinst() {
+ ewarn "Only use this filesystem driver to create backups of your data."
+ ewarn "The music database is hashed, and attempting to add files will "
+ ewarn "cause the iPod/iPhone to consider your database unauthorised."
+ ewarn "It will respond by wiping all media files, requiring a restore "
+ ewarn "through iTunes. You have been warned."
+}