summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-10-22 16:37:13 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-10-22 16:37:13 +0000
commit6484d68c7cbc803e0300d03f2670b5d5c4de6d0b (patch)
tree19a730a99890e037719df158655f71f8d4af1ef8 /app-office
parentNew upstream version (diff)
downloadgentoo-2-6484d68c7cbc803e0300d03f2670b5d5c4de6d0b.tar.gz
gentoo-2-6484d68c7cbc803e0300d03f2670b5d5c4de6d0b.tar.bz2
gentoo-2-6484d68c7cbc803e0300d03f2670b5d5c4de6d0b.zip
Don't save corrupt png files.
(Portage version: 2.1.2_pre3-r6)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/koffice/ChangeLog8
-rw-r--r--app-office/koffice/files/digest-koffice-1.6.0-r23
-rw-r--r--app-office/koffice/files/krita-1.6.0-corrupt_png_save.diff13
-rw-r--r--app-office/koffice/koffice-1.6.0-r2.ebuild97
4 files changed, 120 insertions, 1 deletions
diff --git a/app-office/koffice/ChangeLog b/app-office/koffice/ChangeLog
index 8e4c751630a1..cab961d1e673 100644
--- a/app-office/koffice/ChangeLog
+++ b/app-office/koffice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/koffice
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.193 2006/10/22 00:19:37 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.194 2006/10/22 16:37:13 carlo Exp $
+
+*koffice-1.6.0-r2 (22 Oct 2006)
+
+ 22 Oct 2006; Carsten Lohrke <carlo@gentoo.org>
+ +files/krita-1.6.0-corrupt_png_save.diff, +koffice-1.6.0-r2.ebuild:
+ Don't save corrupt png files.
22 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
koffice-1.6.0-r1.ebuild:
diff --git a/app-office/koffice/files/digest-koffice-1.6.0-r2 b/app-office/koffice/files/digest-koffice-1.6.0-r2
new file mode 100644
index 000000000000..2e01d4cedd36
--- /dev/null
+++ b/app-office/koffice/files/digest-koffice-1.6.0-r2
@@ -0,0 +1,3 @@
+MD5 e669cf19b2e1c7db7029c0772c527c0d koffice-1.6.0.tar.bz2 56718478
+RMD160 be09c18005eb33f6dc35ab0359cc97a8a658ce7c koffice-1.6.0.tar.bz2 56718478
+SHA256 9eddaae640ada9bd184f001e2489854daf7094b73e5f15b0b8deffb4cc654ae2 koffice-1.6.0.tar.bz2 56718478
diff --git a/app-office/koffice/files/krita-1.6.0-corrupt_png_save.diff b/app-office/koffice/files/krita-1.6.0-corrupt_png_save.diff
new file mode 100644
index 000000000000..471650ceec6c
--- /dev/null
+++ b/app-office/koffice/files/krita-1.6.0-corrupt_png_save.diff
@@ -0,0 +1,13 @@
+Index: filters/krita/png/kis_png_converter.cc
+===================================================================
+--- filters/krita/png/kis_png_converter.cc (revision 598005)
++++ filters/krita/png/kis_png_converter.cc (revision 598006)
+@@ -123,7 +123,7 @@
+
+ class KisPNGStream {
+ public:
+- KisPNGStream(Q_UINT8* buf, Q_UINT32 depth ) : m_posinc(8),m_depth(depth), m_buf(buf) {};
++ KisPNGStream(Q_UINT8* buf, Q_UINT32 depth ) : m_posinc(8),m_depth(depth), m_buf(buf) { *m_buf = 0;};
+ int nextValue()
+ {
+ if( m_posinc == 0)
diff --git a/app-office/koffice/koffice-1.6.0-r2.ebuild b/app-office/koffice/koffice-1.6.0-r2.ebuild
new file mode 100644
index 000000000000..6de941a55153
--- /dev/null
+++ b/app-office/koffice/koffice-1.6.0-r2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.6.0-r2.ebuild,v 1.1 2006/10/22 16:37:13 carlo Exp $
+
+inherit kde
+
+RV="${PV}"
+MY_P="koffice-${RV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="KOffice is an integrated office suite for KDE, the K Desktop Environment."
+HOMEPAGE="http://www.koffice.org/"
+SRC_URI="mirror://kde/stable/koffice-${PV}/src/${P}.tar.bz2"
+#SRC_URI="mirror://kde/unstable/koffice-${PV/_/-}/src/${MY_P}.tar.bz2"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# See bug #130442.
+#IUSE="doc mysql opengl postgres"
+IUSE="doc mysql postgres"
+
+RDEPEND=">=media-libs/freetype-2
+ media-libs/fontconfig
+ media-libs/libart_lgpl
+ dev-libs/libxml2
+ dev-libs/libxslt
+ sys-libs/readline
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-libs/libpqxx )
+ virtual/python
+ dev-lang/ruby
+ >=app-text/wv2-0.1.9
+ >=app-text/libwpd-0.8.2
+ >=media-gfx/imagemagick-6.2.5.5
+ >=media-libs/lcms-1.15
+ media-libs/tiff
+ media-libs/jpeg
+ >=media-libs/openexr-1.2.2-r2
+ media-libs/libpng
+ >=media-libs/libexif-0.6.13-r1
+ virtual/opengl
+ virtual/glu"
+# opengl? ( virtual/opengl virtual/glu )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+# add blockers on split packages derived from this one
+for x in $(get-child-packages ${CATEGORY}/${PN}); do
+ DEPEND="${DEPEND} !${x}"
+ RDEPEND="${RDEPEND} !${x}"
+done
+
+need-kde 3.4
+
+# TODO: kword sql plugin needs Qt compiled with sql support
+# the dependency on python is needed for scripting support in kexi
+# and for kivio/kiviopart/kiviosdk.
+
+PATCHES="${FILESDIR}/krita-1.6.0-corrupt_png_save.diff"
+
+pkg_setup() {
+ # use opengl &&
+ if ! built_with_use =x11-libs/qt-3* opengl ; then
+ eerror "You need to build x11-libs/qt with opengl use flag enabled."
+ die
+ fi
+}
+
+src_unpack() {
+ kde_src_unpack
+ # FIXME - disable broken tests for now
+ sed -i -e "s:TESTSDIR =.*:TESTSDIR=:" ${S}/krita/core/Makefile.am \
+ `ls ${S}/krita/colorspaces/*/Makefile.am`
+ sed -i -e "s:toolbar tests:toolbar:" ${S}/kplato/Makefile.am
+}
+
+src_compile() {
+ local myconf="$(use_enable mysql) $(use_enable postgres pgsql)"
+ # $(use_enable opengl gl)"
+
+ kde_src_compile
+ if use doc; then
+ make apidox || die
+ fi
+}
+
+src_install() {
+ kde_src_install
+ if use doc; then
+ make DESTDIR="${D}" install-apidox || die
+ fi
+
+ dodoc changes-*
+}