summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2012-01-25 09:03:16 +0000
committerAlex Alexander <wired@gentoo.org>2012-01-25 09:03:16 +0000
commit3c759a70a41131739759902a677a63cebf4e8ee5 (patch)
tree27fd6de8510f511208f73bfb67cce0202860dd99 /app-misc
parentVersion bump wrt bug #400669. Remove old. Make tests optional and add missing... (diff)
downloadgentoo-2-3c759a70a41131739759902a677a63cebf4e8ee5.tar.gz
gentoo-2-3c759a70a41131739759902a677a63cebf4e8ee5.tar.bz2
gentoo-2-3c759a70a41131739759902a677a63cebf4e8ee5.zip
version bump
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/tmux/ChangeLog9
-rw-r--r--app-misc/tmux/tmux-1.6.ebuild73
2 files changed, 80 insertions, 2 deletions
diff --git a/app-misc/tmux/ChangeLog b/app-misc/tmux/ChangeLog
index a9b1dba6ef01..7c48533038a4 100644
--- a/app-misc/tmux/ChangeLog
+++ b/app-misc/tmux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/tmux
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.69 2011/11/06 19:09:19 armin76 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.70 2012/01/25 09:03:16 wired Exp $
+
+*tmux-1.6 (25 Jan 2012)
+
+ 25 Jan 2012; Alex Alexander <wired@gentoo.org> +tmux-1.6.ebuild:
+ version bump
06 Nov 2011; Raúl Porcel <armin76@gentoo.org> tmux-1.4.ebuild,
tmux-1.5.ebuild:
diff --git a/app-misc/tmux/tmux-1.6.ebuild b/app-misc/tmux/tmux-1.6.ebuild
new file mode 100644
index 000000000000..e2ee165886cd
--- /dev/null
+++ b/app-misc/tmux/tmux-1.6.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.6.ebuild,v 1.1 2012/01/25 09:03:16 wired Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Terminal multiplexer"
+HOMEPAGE="http://tmux.sourceforge.net"
+SRC_URI="mirror://sourceforge/tmux/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="vim-syntax"
+
+DEPEND="
+ || ( >=dev-libs/libevent-2.0.10 <dev-libs/libevent-2 )
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ vim-syntax? ( || (
+ app-editors/vim
+ app-editors/gvim ) )"
+
+DOCS=( CHANGES FAQ NOTES TODO )
+
+pkg_setup() {
+ if has_version "<app-misc/tmux-1.3"; then
+ echo
+ ewarn "Commands 'up-pane', 'down-pane' and 'select-prompt' were removed in version 1.3."
+ ewarn "You may want to update your configuration file accordingly to avoid errors on"
+ ewarn "tmux startup."
+ ewarn
+ ewarn "For the full Changelog, together with details on what replaced the above"
+ ewarn "commands, visit http://tmux.svn.sourceforge.net/viewvc/tmux/trunk/CHANGES"
+ ewarn
+ ewarn "WARNING: after updating to ${P} you will _not_ be able to connect to any"
+ ewarn "running 1.2 tmux server instances. You'll have to use an existing client to"
+ ewarn "end your old sessions or kill the old server instances. Otherwise you'll have"
+ ewarn "to temporarily downgrade to tmux 1.2 to access them."
+ echo
+ elif has_version "<app-misc/tmux-1.6"; then
+ echo
+ ewarn "Some configuration options changed in this release."
+ ewarn "Please read the CHANGES file in /usr/share/doc/${PF}/"
+ ewarn "or visit http://tmux.svn.sourceforge.net/viewvc/tmux/trunk/CHANGES"
+ ewarn "for more details."
+ echo
+ fi
+}
+
+src_prepare() {
+ # look for config file in the prefix
+ sed -i -e '/SYSTEM_CFG/s:"/etc:"'"${EPREFIX}"'/etc:' tmux.h || die
+ # and don't just add some includes
+ sed -i -e 's:-I/usr/local/include::' Makefile.in || die
+}
+
+src_install() {
+ default
+
+ docinto examples
+ dodoc examples/*.conf
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/tmux.vim
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/tmux.vim
+ fi
+}