summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-28 10:09:10 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-28 10:09:10 +0000
commit3cdff684dcd9825540fc0a1fb8d01b64abd5cac3 (patch)
tree178ddf94d190cd03bde55b7f3670994c1fb201af /app-misc/symlinks
parentStable for amd64, wrt bug #409753 (diff)
downloadgentoo-2-3cdff684dcd9825540fc0a1fb8d01b64abd5cac3.tar.gz
gentoo-2-3cdff684dcd9825540fc0a1fb8d01b64abd5cac3.tar.bz2
gentoo-2-3cdff684dcd9825540fc0a1fb8d01b64abd5cac3.zip
Add lfs flags in order to handle largefiles, #409927; drop optimization flag from upstream
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/symlinks')
-rw-r--r--app-misc/symlinks/ChangeLog10
-rw-r--r--app-misc/symlinks/symlinks-1.4-r1.ebuild35
2 files changed, 43 insertions, 2 deletions
diff --git a/app-misc/symlinks/ChangeLog b/app-misc/symlinks/ChangeLog
index bd1d6e89b2cb..f07f85ff61cd 100644
--- a/app-misc/symlinks/ChangeLog
+++ b/app-misc/symlinks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/symlinks
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/symlinks/ChangeLog,v 1.34 2011/03/27 21:54:14 darkside Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/symlinks/ChangeLog,v 1.35 2012/03/28 10:09:10 jlec Exp $
+
+*symlinks-1.4-r1 (28 Mar 2012)
+
+ 28 Mar 2012; Justin Lecher <jlec@gentoo.org> +symlinks-1.4-r1.ebuild:
+ Add lfs flags in order to handle largefiles, #409927; drop optimization flag
+ from upstream
27 Mar 2011; Jeremy Olexa <darkside@gentoo.org> -symlinks-1.2-r2.ebuild:
remove old ebuilds
diff --git a/app-misc/symlinks/symlinks-1.4-r1.ebuild b/app-misc/symlinks/symlinks-1.4-r1.ebuild
new file mode 100644
index 000000000000..92ed3a4e3339
--- /dev/null
+++ b/app-misc/symlinks/symlinks-1.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/symlinks/symlinks-1.4-r1.ebuild,v 1.1 2012/03/28 10:09:10 jlec Exp $
+
+EAPI=4
+
+inherit flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="Scans for and fixes broken or messy symlinks"
+HOMEPAGE="http://www.ibiblio.org/pub/linux/utils/file/"
+SRC_URI="http://www.ibiblio.org/pub/linux/utils/file/${P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static"
+
+src_prepare() {
+ # could be useful if being used to repair
+ # symlinks that are preventing shared libraries from
+ # functioning.
+ use static && append-flags -static
+ append-lfs-flags
+ sed 's:-O2::g' -i Makefile || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dobin symlinks
+ doman symlinks.8
+ dodoc symlinks.lsm
+}