summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-11-15 16:21:03 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-11-15 16:21:03 +0000
commite9711fa1f206a5509ac0503bcf2d613e69ea3752 (patch)
tree7e2d86d0b7e5cfbf2354d001d2b6a67cdcb2ae60 /app-i18n
parentFixed dependency, bug #345253. (diff)
downloadgentoo-2-e9711fa1f206a5509ac0503bcf2d613e69ea3752.tar.gz
gentoo-2-e9711fa1f206a5509ac0503bcf2d613e69ea3752.tar.bz2
gentoo-2-e9711fa1f206a5509ac0503bcf2d613e69ea3752.zip
Version bumped, Fixed HOMEPAGE and SRC_URI, bug #327817.
(Portage version: 2.1.9.22/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/man-pages-ja/ChangeLog8
-rw-r--r--app-i18n/man-pages-ja/man-pages-ja-20101110.ebuild91
2 files changed, 98 insertions, 1 deletions
diff --git a/app-i18n/man-pages-ja/ChangeLog b/app-i18n/man-pages-ja/ChangeLog
index eff4ed05d83f..1b2d31bf9180 100644
--- a/app-i18n/man-pages-ja/ChangeLog
+++ b/app-i18n/man-pages-ja/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/man-pages-ja
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/man-pages-ja/ChangeLog,v 1.28 2010/02/21 17:17:35 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/man-pages-ja/ChangeLog,v 1.29 2010/11/15 16:21:03 matsuu Exp $
+
+*man-pages-ja-20101110 (15 Nov 2010)
+
+ 15 Nov 2010; MATSUU Takuto <matsuu@gentoo.org>
+ +man-pages-ja-20101110.ebuild:
+ Version bumped, Fixed HOMEPAGE and SRC_URI, bug #327817.
21 Feb 2010; Ulrich Mueller <ulm@gentoo.org> man-pages-ja-20070515.ebuild:
Fix LICENSE.
diff --git a/app-i18n/man-pages-ja/man-pages-ja-20101110.ebuild b/app-i18n/man-pages-ja/man-pages-ja-20101110.ebuild
new file mode 100644
index 000000000000..12fd28f04996
--- /dev/null
+++ b/app-i18n/man-pages-ja/man-pages-ja-20101110.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/man-pages-ja/man-pages-ja-20101110.ebuild,v 1.1 2010/11/15 16:21:03 matsuu Exp $
+
+EAPI="3"
+GENTOO_MAN_P="portage-${PN}-20060415"
+
+DESCRIPTION="A collection of manual pages translated into Japanese"
+HOMEPAGE="http://linuxjm.sourceforge.jp/ http://www.gentoo.gr.jp/jpmain/translation.xml"
+SRC_URI="http://linuxjm.sourceforge.jp/${P}.tar.gz
+ http://dev.gentoo.org/~hattya/distfiles/${GENTOO_MAN_P}.tar.gz"
+
+LICENSE="as-is GPL-2 LGPL-2 BSD MIT FDL-1.1 LDP-1 LDP-1a"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/man"
+
+src_prepare() {
+
+ sed -i -e "/^\(man\|shadow\)/s:Y:N:" script/pkgs.list || die
+
+ # remove man pages that are provided by other packages.
+ # - sys-apps/shadow +nls
+ rm -f manual/*/man1/{chfn,chsh,newgrp,su,passwd,groups}.1 || die
+ rm -f manual/*/man8/{vigr,vipw}.8 || die
+
+ for f in manual/*/man8/ld{,-linux}.so.8 ; do
+ mv ${f} ${f/.so.8/.so.ja.8} || die
+ done
+ mv "${WORKDIR}"/${GENTOO_MAN_P}/portage/g-cpan.pl{,.ja}.1 || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+
+ local x y z pkg
+
+ for x in $(tac script/pkgs.list | grep -v '^[#].*'); do
+ if [[ -z "$pkg" ]]; then
+ pkg=$x
+ continue
+ fi
+
+ if [[ "$x" == "N" ]]; then
+ pkg=
+ continue
+ fi
+
+ einfo "install $pkg"
+
+ for y in $(ls -d manual/$pkg/man* 2>/dev/null); do
+ doman -i18n=ja $y/*
+ done
+
+ pkg=
+ done
+
+ dodoc README || die
+
+ cd "${WORKDIR}"/${GENTOO_MAN_P}
+
+ for x in *; do
+ if [ -d "$x" ]; then
+ einfo "install $x"
+
+ for z in $(for y in $x/*.[1-9]; do echo ${y##*.}; done | sort | uniq); do
+ doman -i18n=ja $x/*.$z
+ done
+ fi
+ done
+
+ newdoc ChangeLog ChangeLog.GentooJP || die
+
+}
+
+pkg_postinst() {
+
+ echo
+ elog "You need to set appropriate LANG variables to use"
+ elog "Japanese manpages."
+ elog "e.g."
+ elog "\tLANG=\"ja_JP.eucJP\""
+ elog "\texport LANG"
+ echo
+
+}