summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-04-21 16:38:20 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-04-21 16:38:20 +0000
commite457d6e978417903b849cba20133e2fe23641d54 (patch)
treec5a28110e8bececb7a63dbcf5061da5d1b721a41 /app-i18n/scim-anthy
parentinherit eutils too. (diff)
downloadgentoo-2-e457d6e978417903b849cba20133e2fe23641d54.tar.gz
gentoo-2-e457d6e978417903b849cba20133e2fe23641d54.tar.bz2
gentoo-2-e457d6e978417903b849cba20133e2fe23641d54.zip
Version bumped, bug #218678.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-i18n/scim-anthy')
-rw-r--r--app-i18n/scim-anthy/ChangeLog11
-rw-r--r--app-i18n/scim-anthy/scim-anthy-1.2.6.ebuild58
-rw-r--r--app-i18n/scim-anthy/scim-anthy-1.3.1.ebuild58
3 files changed, 125 insertions, 2 deletions
diff --git a/app-i18n/scim-anthy/ChangeLog b/app-i18n/scim-anthy/ChangeLog
index 5a13cdc76a45..f225490da6e5 100644
--- a/app-i18n/scim-anthy/ChangeLog
+++ b/app-i18n/scim-anthy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-i18n/scim-anthy
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/ChangeLog,v 1.53 2007/11/16 17:50:10 matsuu Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/ChangeLog,v 1.54 2008/04/21 16:38:20 matsuu Exp $
+
+*scim-anthy-1.3.1 (21 Apr 2008)
+*scim-anthy-1.2.6 (21 Apr 2008)
+
+ 21 Apr 2008; MATSUU Takuto <matsuu@gentoo.org> +scim-anthy-1.2.6.ebuild,
+ +scim-anthy-1.3.1.ebuild:
+ Version bumped, bug #218678.
16 Nov 2007; <matsuu@gentoo.org> scim-anthy-1.2.4.ebuild,
scim-anthy-1.3.0.ebuild:
diff --git a/app-i18n/scim-anthy/scim-anthy-1.2.6.ebuild b/app-i18n/scim-anthy/scim-anthy-1.2.6.ebuild
new file mode 100644
index 000000000000..1e246ab4ce7a
--- /dev/null
+++ b/app-i18n/scim-anthy/scim-anthy-1.2.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/scim-anthy-1.2.6.ebuild,v 1.1 2008/04/21 16:38:20 matsuu Exp $
+
+inherit libtool
+
+DESCRIPTION="Japanese input method Anthy IMEngine for SCIM"
+HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMAnthy"
+SRC_URI="mirror://sourceforge.jp/scim-imengine/30199/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="gtk kde nls"
+
+DEPEND="|| ( >=app-i18n/scim-1.2 >=app-i18n/scim-cvs-1.2 )
+ || ( >=app-i18n/anthy-5900 >=app-i18n/anthy-ss-5911 )
+ nls? ( virtual/libintl )
+ gtk? ( >=x11-libs/gtk+-2.4 )"
+RDEPEND="${DEPEND}
+ gtk? ( app-dicts/kasumi )"
+DEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+PDEPEND="kde? ( app-i18n/skim-scim-anthy )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ --disable-static \
+ --disable-dependency-tracking || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ elog
+ elog "To use SCIM, you should use the following in your user startup scripts"
+ elog "such as .gnomerc or .xinitrc:"
+ elog
+ elog "LANG='your_language' scim -d"
+ elog "export XMODIFIERS=@im=SCIM"
+ elog "export GTK_IM_MODULE=scim"
+ elog "export QT_IM_MODULE=scim"
+ elog
+}
diff --git a/app-i18n/scim-anthy/scim-anthy-1.3.1.ebuild b/app-i18n/scim-anthy/scim-anthy-1.3.1.ebuild
new file mode 100644
index 000000000000..01ed2d308167
--- /dev/null
+++ b/app-i18n/scim-anthy/scim-anthy-1.3.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/scim-anthy-1.3.1.ebuild,v 1.1 2008/04/21 16:38:20 matsuu Exp $
+
+inherit libtool
+
+DESCRIPTION="Japanese input method Anthy IMEngine for SCIM"
+HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMAnthy"
+SRC_URI="mirror://sourceforge.jp/scim-imengine/29660/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk kde nls"
+
+DEPEND="|| ( >=app-i18n/scim-1.2 >=app-i18n/scim-cvs-1.2 )
+ || ( >=app-i18n/anthy-7500 >=app-i18n/anthy-ss-7500 )
+ nls? ( virtual/libintl )
+ gtk? ( >=x11-libs/gtk+-2.8 )"
+RDEPEND="${DEPEND}
+ gtk? ( app-dicts/kasumi )"
+DEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+PDEPEND="kde? ( app-i18n/skim-scim-anthy )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ --disable-static \
+ --disable-dependency-tracking || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ elog
+ elog "To use SCIM, you should use the following in your user startup scripts"
+ elog "such as .gnomerc or .xinitrc:"
+ elog
+ elog "LANG='your_language' scim -d"
+ elog "export XMODIFIERS=@im=SCIM"
+ elog "export GTK_IM_MODULE=scim"
+ elog "export QT_IM_MODULE=scim"
+ elog
+}