summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2011-12-01 13:51:22 +0000
committerTony Vroon <chainsaw@gentoo.org>2011-12-01 13:51:22 +0000
commitf0f5ef02be1f8d07204557ccbca3961e48808860 (patch)
tree0343781a525164da0cf5adef90f0163102196525 /app-i18n/libguess
parentVersion Bump (diff)
downloadgentoo-2-f0f5ef02be1f8d07204557ccbca3961e48808860.tar.gz
gentoo-2-f0f5ef02be1f8d07204557ccbca3961e48808860.tar.bz2
gentoo-2-f0f5ef02be1f8d07204557ccbca3961e48808860.zip
Version bump. Libmowgli dependencies bled through into the external headers, this is now fixed.
(Portage version: 2.1.10.39/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/libguess')
-rw-r--r--app-i18n/libguess/ChangeLog8
-rw-r--r--app-i18n/libguess/libguess-1.1.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/app-i18n/libguess/ChangeLog b/app-i18n/libguess/ChangeLog
index af08e1311007..48ec3a204e76 100644
--- a/app-i18n/libguess/ChangeLog
+++ b/app-i18n/libguess/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/libguess
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/libguess/ChangeLog,v 1.10 2011/10/11 16:56:14 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/libguess/ChangeLog,v 1.11 2011/12/01 13:51:22 chainsaw Exp $
+
+ 01 Dec 2011; Tony Vroon <chainsaw@gentoo.org> +libguess-1.1.ebuild:
+ Version bump. Libmowgli dependencies bled through into the external headers,
+ this is now fixed.
+
+*libguess-1.1 (01 Dec 2011)
11 Oct 2011; Jeroen Roovers <jer@gentoo.org> libguess-1.0.ebuild:
Stable for HPPA (bug #380575).
diff --git a/app-i18n/libguess/libguess-1.1.ebuild b/app-i18n/libguess/libguess-1.1.ebuild
new file mode 100644
index 000000000000..ffa86a078dc7
--- /dev/null
+++ b/app-i18n/libguess/libguess-1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/libguess/libguess-1.1.ebuild,v 1.1 2011/12/01 13:51:22 chainsaw Exp $
+
+EAPI=2
+
+DESCRIPTION="A high-speed character set detection library."
+HOMEPAGE="http://www.atheme.org/project/libguess"
+SRC_URI="http://distfiles.atheme.org/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-libs/libmowgli-0.7.0"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0"
+
+src_configure() {
+ econf $(use_enable examples) \
+ || die "econf failed"
+}
+
+src_test() {
+ cd src/tests
+ make || die "test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+}