summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2014-05-27 13:11:54 +0000
committerRick Farina <zerochaos@gentoo.org>2014-05-27 13:11:54 +0000
commit8f258309a888f3e8877c7a9fe5e0ea630a898be1 (patch)
tree846fd55eb01941394462a0319270666f6f6055d4 /app-forensics
parentnet-libs/czmq: Add missing dep in libsodium, #511612; version BUmp (diff)
downloadgentoo-2-8f258309a888f3e8877c7a9fe5e0ea630a898be1.tar.gz
gentoo-2-8f258309a888f3e8877c7a9fe5e0ea630a898be1.tar.bz2
gentoo-2-8f258309a888f3e8877c7a9fe5e0ea630a898be1.zip
simple revbump as requested by bug 504066. tested and functional
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/rkhunter/ChangeLog9
-rw-r--r--app-forensics/rkhunter/rkhunter-1.4.2.ebuild65
2 files changed, 72 insertions, 2 deletions
diff --git a/app-forensics/rkhunter/ChangeLog b/app-forensics/rkhunter/ChangeLog
index 9ac4ccd154bf..9887e6e088c2 100644
--- a/app-forensics/rkhunter/ChangeLog
+++ b/app-forensics/rkhunter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/rkhunter
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/ChangeLog,v 1.97 2013/04/11 06:20:32 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/ChangeLog,v 1.98 2014/05/27 13:11:54 zerochaos Exp $
+
+*rkhunter-1.4.2 (27 May 2014)
+
+ 27 May 2014; Rick Farina <zerochaos@gentoo.org> +rkhunter-1.4.2.ebuild:
+ simple revbump as requested by bug 504066. tested and functional
11 Apr 2013; Patrick Lauer <patrick@gentoo.org> rkhunter-1.4.0.ebuild:
Dependency fix for #398123
diff --git a/app-forensics/rkhunter/rkhunter-1.4.2.ebuild b/app-forensics/rkhunter/rkhunter-1.4.2.ebuild
new file mode 100644
index 000000000000..b47fff61805a
--- /dev/null
+++ b/app-forensics/rkhunter/rkhunter-1.4.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/rkhunter-1.4.2.ebuild,v 1.1 2014/05/27 13:11:54 zerochaos Exp $
+
+EAPI=5
+
+inherit eutils bash-completion-r1
+
+DESCRIPTION="Rootkit Hunter scans for known and unknown rootkits, backdoors, and sniffers."
+HOMEPAGE="http://rkhunter.sf.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ dev-lang/perl
+ sys-process/lsof[rpc]
+ virtual/cron
+ virtual/mailx
+"
+
+S="${WORKDIR}/${P}/files"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}.conf.patch"
+}
+
+src_install() {
+ # rkhunter requires to be root
+ dosbin ${PN}
+
+ insinto /etc
+ doins ${PN}.conf
+
+ exeinto /usr/lib/${PN}/scripts
+ doexe *.pl
+
+ insinto /var/lib/${PN}/db
+ doins *.dat
+
+ insinto /var/lib/${PN}/db/i18n
+ doins i18n/*
+
+ doman ${PN}.8
+ dodoc ACKNOWLEDGMENTS CHANGELOG FAQ README
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/${PN}-1.3.cron" ${PN}
+
+ newbashcomp "${FILESDIR}/${PN}.bash-completion" ${PN}
+}
+
+pkg_postinst() {
+ elog "A cron script has been installed to /etc/cron.daily/rkhunter."
+ elog "To enable it, edit /etc/cron.daily/rkhunter and follow the"
+ elog "directions."
+ elog "If you want ${PN} to send mail, you will need to install"
+ elog "virtual/mailx or alter the EMAIL_CMD variable in the"
+ elog "cron script and possibly the MAIL_CMD variable in the"
+ elog "${PN}.conf file to use another mail client."
+}