summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-04-28 18:32:37 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-04-28 18:32:37 +0000
commitdee63c7d1a05a0669e3ecaf28c0c6cfcbcb5ca8e (patch)
tree52648a66ec65def3987366f46ddfcd7649f017cc /app-emulation
parentVersion bump, remove broken version. (diff)
downloadgentoo-2-dee63c7d1a05a0669e3ecaf28c0c6cfcbcb5ca8e.tar.gz
gentoo-2-dee63c7d1a05a0669e3ecaf28c0c6cfcbcb5ca8e.tar.bz2
gentoo-2-dee63c7d1a05a0669e3ecaf28c0c6cfcbcb5ca8e.zip
Fix issue with the PPC system targets. bug #413487
Add epatch_user during the src_prepare phase allowing people to apply patches Default enewgroup to gid 78 as part of GLEP 27. (Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu-kvm/ChangeLog7
-rw-r--r--app-emulation/qemu-kvm/qemu-kvm-1.0.1.ebuild9
2 files changed, 13 insertions, 3 deletions
diff --git a/app-emulation/qemu-kvm/ChangeLog b/app-emulation/qemu-kvm/ChangeLog
index 5317a82d34b7..69dfc3986450 100644
--- a/app-emulation/qemu-kvm/ChangeLog
+++ b/app-emulation/qemu-kvm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/qemu-kvm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/ChangeLog,v 1.114 2012/04/23 05:14:39 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/ChangeLog,v 1.115 2012/04/28 18:32:37 cardoe Exp $
+
+ 28 Apr 2012; Doug Goldstein <cardoe@gentoo.org> qemu-kvm-1.0.1.ebuild:
+ Fix issue with the PPC system targets. bug #413487
+ Add epatch_user during the src_prepare phase allowing people to apply patches
+ Default enewgroup to gid 78 as part of GLEP 27.
*qemu-kvm-1.0.1 (23 Apr 2012)
diff --git a/app-emulation/qemu-kvm/qemu-kvm-1.0.1.ebuild b/app-emulation/qemu-kvm/qemu-kvm-1.0.1.ebuild
index 0082c2de89fc..f17a96201bc8 100644
--- a/app-emulation/qemu-kvm/qemu-kvm-1.0.1.ebuild
+++ b/app-emulation/qemu-kvm/qemu-kvm-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/qemu-kvm-1.0.1.ebuild,v 1.1 2012/04/23 05:14:39 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/qemu-kvm-1.0.1.ebuild,v 1.2 2012/04/28 18:32:37 cardoe Exp $
#BACKPORTS=1
@@ -171,7 +171,7 @@ pkg_pretend() {
pkg_setup() {
python_set_active_version 2
- enewgroup kvm
+ enewgroup kvm 78
}
src_prepare() {
@@ -190,6 +190,9 @@ src_prepare() {
# to the qemu-devel ml - bug 337988
epatch "${FILESDIR}/qemu-0.11.0-mips64-user-fix.patch"
+ # Fix compilation of the qemu-system-ppc component
+ epatch "${FILESDIR}"/${PN}-1.0-fix-qemu-system-ppc.patch
+
# drop '-g' by default as it tends to eat
# A LOT (~2GB) of ram for each job #355861
sed -e 's/CFLAGS="-g $CFLAGS"/CFLAGS="$CFLAGS"/g' \
@@ -198,6 +201,8 @@ src_prepare() {
[[ -n ${BACKPORTS} ]] && \
EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
epatch
+
+ epatch_user
}
src_configure() {